Exporting images

Tips for exporting and sharing images including managing orientation, size, and layers when moving between devices

Jump to AndroidiOS or Windows 10


Export sketches to share with others or save‍ elsewhere. Import images‍ into Sketchbook to continue working on them.

Exporting in Sketchbook Pro for desktop

When you export an image, there are a few things to keep in mind. The first is the orientation. If you are exporting to a device, see the section below on exporting landscape-oriented images. Another thing to consider is the capacity of the device in regards to layer capacity and canvas size. See the other section below for this.


Exporting Sketchbook Pro landscape-oriented images to a device

When you export a layered landscape-oriented image from Sketchbook Pro to an iPad or iPhone, the image is cropped. The iPad maps the bottom left corner of the exported image to its bottom left corner. If the original layered image is wider than the iPad or iPhone, do one of the following:

  • Set the canvas to the same resolution as the device before exporting

Select Image > Image Size. In the Image Size dialog, change the value for Resolution.

  • Take the exported image and open it in any application that can open PSDs, then make changes to fit it to the device
  • Rotate your layers to change the image’s orientation and ensure the canvas is no longer than the length of the intended device’s canvas

To rotate your layers (the whole canvas), tap-hold the Spacebar to access the Transform puck. With the Spacebar still pressed, drag left or right.

To change the canvas length, select Image > Image Size. In the Image Size dialog, change the value for Document Size. Then select Image > Canvas Size. In the New Size dialog, tap the center of Anchor, then change the value for Document Size.


Exporting Sketchbook Pro images to a device

When you export an image with layers and/or a large canvas size from Sketchbook Pro on desktop to a device, if the device cannot support the file, a warning appears. The warning will let you know what the issue is.

  • If the version of Sketchbook you're bringing the file into doesn't have layer grouping, then the layers come in ungrouped.
  • If the canvas is too large, you can reduce your image in Sketchbook Pro before bringing it into the other device.

To change the canvas length, select Image > Image Size. In the Image Size dialog, change the value for Document Size. Then select Image > Canvas Size. In the New Size dialog, tap the center of Anchor, then change the value for Document Size.

With older devices and older versions of Sketchbook, here is an example of what could happen. When you export an image with 8 layers from Sketchbook Pro to an older device running an older version of Sketchbook, layers may be missing.

  • The iPad2 has a limit of 4 high-resolution or 12 regular layers. Layers 5 and up from the original image are not loaded for a device with high-resolution layers. Turn off High-resolution canvas, then re-import the file.
  • The iPad1 has 6 layers, so layers 7 and 8 are not loaded. Merge some of the layers before exporting for an iPad1 user.
  • The iPhone has from 3 - 6 layers, so some layers are not loaded. Merge‍ some of the layers, then select File > Save a Copy As and rename the file. 


Exporting in Sketchbook for Android

Exporting a layered image

Export layered images to your SD card, cloud storage, or another destination. Images will be exported at 72 dpi.

  1. Tap Info Settings, then Gallery iconGallery, and select an option from the dialog that appears.
  2. Swipe to the thumbnail view of the sketch you want to export.
  3. Tap Export/Save icon and select Export PSD.
  4. Choose a method for exporting your sketch.
  5. Following the onscreen instructions.


Sharing an image

When you share an image with layers, the image that is sent gets flattened to one layer. Did you know that Share can also be used to save images to your Photos? See how you can use Save Image to do this.

  1. Tap Info Settings icon, then Gallery iconGallery.
  2. Swipe to the thumbnail view of the sketch you want to export.
  3. Tap Export/Save icon and select Share.
  4. In the next dialog, select Save Image to save your image to Photos


Exporting in Sketchbook for iOS

Sketchbook version 5.2 for iOS introduced new workflows for exporting files from Sketchbook. If you are using a previous version of Autodesk SketchBook, please reference the above section exporting in Sketchbook for Android‍ as the legacy iOS workflow is the same.


Exporting a layered image

Export to Files provides the ability to directly save a copy of your current sketch to folders on your local device, iCloud or to other available cloud storage services. When exporting, Sketchbook prepares your file and opens the iOS Files browser.

  1. Tap Info Settings icon, then Save.
  2. Tap Export to Files .
    The browser lets you edit the name of the export. This name is only applied to the export and is not assigned to your piece in Sketchbook. If the file had been previously saved and given a name in the Sketchbook Gallery, that name will be applied in the dialog.
  3. Once you tap SAVE, the dialog will dismiss and you will return to Sketchbook.

TIPS:

  • When saving to folders in Files, duplicate file names are not allowed, so if the name exists, you will be prompted if you want to ‘Replace’, ‘Keep Both’, or ‘Stop.’ 
  • If you want to repeatedly export to Files and use the same name to replace (update) the file, it may be easier to save it and name it in the Gallery first. This will allow the export to use the same name automatically
  • If you do not re-name your file, you are given the option to ‘Replace’, ‘Keep Both’, or ‘Stop.’ If ‘Replace’ is tapped, it writes over the original image, and it cannot be recovered


Sharing an image

When you want to produce a flattened (no layers) image, you can do this from the menu in the main toolbar or from the Gallery. 

From the main toolbar:

  1. Tap Info Settings icon, then Save.
  2. Tap Share 1632115887558-share.png.
    Select PNG from dialog box to produce a flattened image. Sketchbook will take a moment to prepare the image. 
  3. The iOS Share dialog lets you share the image via apps, email, or iMessages, save to Photos, or save to Files (including iCloud or other applicable 3rd party cloud services)

TIP: When you have a final piece, save a PNG copy of it. Not only will it be a smaller file size, it is a more convenient format for use in other apps, social media, or just to view as an attachment.


Exporting in Sketchbook for Windows 10

If you want to save changes to your file, but you don’t want to overwrite the original, use Export. Another difference from Save is the file saving options. With Export, you can save as PNG, JPEG, and PSD.

  1. Select Menu icon Export.
  2. Tap the Save as type option and select a file format.
    INFORMATION: If you want to keep your layers, select PSD. If you don’t mind if your image is flattened to one layer, select either png and JPEG.
  3. Select Save.