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Introduction to Sketchbook

Get started with an overview of the interface and basic interactions.

See below for a basic overview of the workspace in Sketchbook Pro (macOS and Windows) and Sketchbook
(Android and iOS).

While the general concepts are the same in Sketchbook Pro and Sketchbook for iOS and Android mobile devices, the
user experience is a bit different because PCs and mobile devices work in different ways. For example while
everyone on a mobile device is drawing on the screen, most people on a PC may have multiple monitors, a mouse
and a peripheral drawing tablet - so Sketchbook Pro on desktop is designed to enable using that kind of workspace.

Sketchbook Pro for desktop

1. Canvas - the white drawing space is called the canvas. For details on how to set the canvas size and changing
its color, read Creating a canvas.

2. Brush Puck
3. Brush Palette – including advanced brushes and the customizable Brush Library
4. Color Puck with the Color Picker, transparent color, and color palettes
5. Color Editor
6. Layer Editor with blend layers, grouping, and unlimited layers
7. Lagoon gestural toolbar

https://app.knowledgeowl.com/#desktop
https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/what-is-a-canvas
https://sketchbook.knowledgeowl.com/docs/creating-a-canvas
https://sketchbook.knowledgeowl.com/docs/using-the-brush-puck
https://sketchbook.knowledgeowl.com/docs/brush-palette
https://sketchbook.knowledgeowl.com/docs/brush-library
https://sketchbook.knowledgeowl.com/docs/color-puck
https://sketchbook.knowledgeowl.com/docs/using-the-color-picker
https://sketchbook.knowledgeowl.com/docs/color-editor
https://sketchbook.knowledgeowl.com/docs/intro-to-layer-editor
https://sketchbook.knowledgeowl.com/docs/basic-ui-elements#lagoon
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8. Main toolbar includes selection tools, guides, rulers, and more
9. When a Flipbook is created or opened, the animation interface will appear

Watch our getting started video for a quick orientation to Sketchbook Pro on a Mac or Windows PC:

After creating your first new sketch, here are some articles that could come in handy:
Selecting a brush
Sketching tools
Importing images
Customizing Preferences

Getting started in Sketchbook for mobile devices

Getting oriented:
1. Canvas - the white drawing space is called the canvas
2. Toolbar

https://sketchbook.knowledgeowl.com/docs/toolbars
https://sketchbook.knowledgeowl.com/docs/animation-in-sketchbook-pro
https://sketchbook.knowledgeowl.com/docs/brushes-in-sketchbook
https://sketchbook.knowledgeowl.com/docs/tools-in-sketchbook
https://sketchbook.knowledgeowl.com/docs/importing-images
https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook
https://sketchbook.knowledgeowl.com/docs/creating-a-canvas#mobile
https://sketchbook.knowledgeowl.com/docs/toolbars#mobile
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3. Brush Palette – including advanced brushes and the customizable Brush Library
4. Double Puck – choose colors and adjust the active brush's properties
5. Color Editor
6. Layer Editor with blend modes and grouping
7. Marking menu for quick access to common tools

Watch our getting started video for a quick orientation to Sketchbook on an iPad or Android tablet:

Here are some ideas for what to read about next:

Basic UI elements
Importing images
Using the Gallery
Sketching tools
Selection tools

https://sketchbook.knowledgeowl.com/docs/brush-palette
https://sketchbook.knowledgeowl.com/docs/color-puck#mobile
https://sketchbook.knowledgeowl.com/docs/color-editor#mobile
https://sketchbook.knowledgeowl.com/docs/intro-to-layer-editor#mobile
https://sketchbook.knowledgeowl.com/docs/basic-ui-elements#marking-menu
https://sketchbook.knowledgeowl.com/docs/basic-ui-elements#mobile
https://sketchbook.knowledgeowl.com/docs/importing-images#mobile
https://sketchbook.knowledgeowl.com/docs/gallery-in-sketchbook
https://sketchbook.knowledgeowl.com/docs/tools-in-sketchbook#mobile
https://sketchbook.knowledgeowl.com/docs/intro-to-selection-tools#mobile
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Basic UI elements

Orient yourself with the canvas, toolbars, brushes, color tools and marking menus

Jump to Mobile

When you first open Sketchbook you will see the default UI. On all platforms, that will include the canvas and toolbar.
The rest of the interface will be slightly different depending on the platform you're on (mobile or desktop). See the
sections below to familiarize yourself with the interface and how it works.

Basic UI elements in Sketchbook Pro for desktop

When you open Sketchbook Pro, you'll see the canvas, lagoon, toolbar, brush and color pucks, and Brush Palette.

Use hotkey shortcuts and marking menus to access tools and functions quickly.

To change your view and navigate around your canvas, hold down the Spacebar key to activate the puck.

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/what-is-a-canvas
https://sketchbook.knowledgeowl.com/docs/toolbars
https://sketchbook.knowledgeowl.com/docs/what-is-a-canvas
https://app.knowledgeowl.com/#lagoon
https://sketchbook.knowledgeowl.com/docs/toolbars
https://sketchbook.knowledgeowl.com/docs/using-the-brush-puck
https://sketchbook.knowledgeowl.com/docs/color-puck
https://sketchbook.knowledgeowl.com/docs/brush-palette
https://sketchbook.knowledgeowl.com/docs/hotkey-shortcuts
https://sketchbook.knowledgeowl.com/docs/hotkey-shortcuts#marking-menu
https://sketchbook.knowledgeowl.com/docs/changing-your-view
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Lagoon tool

The Lagoon is the round UI element that is found in the bottom left corner of the screen by default, though you can
change its location. It is a hub for many useful tools in Sketchbook Pro.

The Lagoon is driven by gestural movements. To view the tools in a lagoon marking menu, tap-hold an icon to
expose the tools in that category. With your stylus (or right mouse button) held down, drag to the tool you want to
select. When the icon is highlighted, lift your stylus (or release your right mouse button).

You can customize the tools that appear in the Lagoon marking menus in Preferences.

1. Interface controls
2. View controls, rulers, layers, and vertical and horizontal symmetry
3. Brushes
4. Colors and Transparent Color
5. Selection, editing, and transform tools
6. Open, Save, New, Next and Previous Image
7. Shows current tool
8. Shows current color
9. Undo/redo

https://sketchbook.knowledgeowl.com/docs/customizing-your-ui
https://sketchbook.knowledgeowl.com/docs/tools-in-sketchbook
https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook#lagoon
https://sketchbook.knowledgeowl.com/docs/customizing-your-ui#lagoon
https://sketchbook.knowledgeowl.com/docs/changing-your-view
https://sketchbook.knowledgeowl.com/docs/rulers-and-guides
https://sketchbook.knowledgeowl.com/docs/layers-in-sketchbook
https://sketchbook.knowledgeowl.com/docs/symmetry
https://sketchbook.knowledgeowl.com/docs/brushes-in-sketchbook
https://sketchbook.knowledgeowl.com/docs/color-editor
https://sketchbook.knowledgeowl.com/docs/turning-a-brush-into-an-eraser
https://sketchbook.knowledgeowl.com/docs/intro-to-selection-tools
https://sketchbook.knowledgeowl.com/docs/cutting-and-pasting
https://sketchbook.knowledgeowl.com/docs/transforms
https://sketchbook.knowledgeowl.com/docs/undoing-and-redoing
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Basic UI elements in Sketchbook for mobile devices

To get the most out of Sketchbook, you need to become familiar with its basic UI including the canvas, toolbar,
Double Puck, marking menu and corner tools.

Once you are familiar with the tools, you may prefer to draw with the UI is hidden.

Tablets

You will see the toolbar, a full brush palette which gives you access to the customizable Brush Library, the Double
Puck which launches the Color Editor, and the Layer Editor with blend modes.

Handheld devices

You will see a toolbar and the marking menu. Due to the smaller screen size on phones, other UI elements are
hidden by default. You can turn on the Brush Palette in Preferences. You can also choose to pin open the Layer
Editor.

https://sketchbook.knowledgeowl.com/docs/what-is-a-canvas
https://sketchbook.knowledgeowl.com/docs/toolbars#mobile
https://sketchbook.knowledgeowl.com/docs/color-puck#mobile
https://app.knowledgeowl.com/#marking-menu
https://app.knowledgeowl.com/#corner-tools
https://sketchbook.knowledgeowl.com/docs/hiding-the-ui-while-you-draw
https://sketchbook.knowledgeowl.com/docs/toolbars#mobile
https://sketchbook.knowledgeowl.com/docs/brush-palette
https://sketchbook.knowledgeowl.com/docs/brush-library#mobile
https://sketchbook.knowledgeowl.com/docs/color-puck#mobile
https://sketchbook.knowledgeowl.com/docs/color-editor#mobile
https://sketchbook.knowledgeowl.com/docs/intro-to-layer-editor#mobile
https://sketchbook.knowledgeowl.com/docs/blending-layers
https://sketchbook.knowledgeowl.com/docs/toolbars#mobile
https://app.knowledgeowl.com/#marking-menu
https://sketchbook.knowledgeowl.com/docs/brush-palette
https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook#ui
https://sketchbook.knowledgeowl.com/docs/intro-to-layer-editor#mobile
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Marking menu

Use   (the marking menu) to access an assortment of tools, as well as the corner tools without going to the
toolbar. If you are working with the interface hidden, the marking menu provides access to a host of tools without
unhiding your interface.

The Marking menu includes tools for switching between the current and last brush, Transparent Color, selecting a
color from your screen (color picker), accessing the Double Puck (on tablet) or the last color (on handheld) and
flipping the canvas.

On handheld devices, tapping the marking menu will also open the Double Puck.

You can customize the marking menu tools in Preferences.

https://sketchbook.knowledgeowl.com/docs/hiding-the-ui-while-you-draw
https://sketchbook.knowledgeowl.com/docs/swapping-between-brushes
https://sketchbook.knowledgeowl.com/docs/turning-a-brush-into-an-eraser
https://sketchbook.knowledgeowl.com/docs/using-the-color-picker
https://sketchbook.knowledgeowl.com/docs/color-puck#mobile
https://sketchbook.knowledgeowl.com/docs/color-puck#mobile
https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook#ui
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Corner tools

Trigger a corner tool by double-tapping a corner of the screen.

When you tap    and open the marking menu, the Corner tools are also visible.

The default corner quick tool mappings are:
Top left  (Clear Layer)
Top right  (Fit To View)
Bottom left  (Undo)
Bottom right  (Redo)

If you want to customize your corner tools, read Customizing your UI.

https://sketchbook.knowledgeowl.com/docs/customizing-your-ui#mobile
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Toolbars

Jump to Mobile

By default, the toolbar is at the top of the canvas and provides access to most of the Sketchbook tools. When you
select a tool, another toolbar may appear below it, containing additional options.

In Sketchbook Pro for Mac and Windows, the toolbar can be optionally hidden or moved to give you a larger work
space.

On mobile, the device you have (handheld device or tablet) determines which tools you see in the toolbar and what it
looks like. Due to the screen size of some devices, you may have to swipe left or right in these toolbars to access
more options.

  

Which tool is active?

Tap a tool in the toolbar to select it and make it active. The tool is highlighted blue. When there are two or more tools
highlighted blue, that means they are both active. For example, you could have both Symmetry on and a Shape tool
selected.

https://app.knowledgeowl.com/#mobile
https://app.knowledgeowl.com/#desktop
https://app.knowledgeowl.com/#mobile
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Toolbars in Sketchbook Pro for desktop

The version of Sketchbook Pro you're running will determine the tools available in the toolbar. Some tools have a
secondary toolbar, containing additional tools or options.

1. Undo and redo
2. Zoom/rotate/move the canvas
3. Selection tools and de-select
4. Crop canvas (can be used in conjunction with selection tools)
5. Quick transform
6. Transform
7. Flood fill
8. Text tools
9. Rulers and guides

10. Perspective guides
11. Symmetry tools
12. Pen mode
13. Steady and Predictive Stroke
14. Shape tools
15. Auto hide UI
16. Layer Editor
17. Brush Palette
18. Color Editor
19. Color Palettes

Toolbars in Sketchbook for mobile devices

The toolbar will look different if you have a handheld/phone device or a tablet, since the available screen space is
different. Please see the sections below and find the one that's right for you.

Some tools also have a secondary toolbar, containing additional tools and options.

Toolbar on tablet devices

https://sketchbook.knowledgeowl.com/docs/undoing-and-redoing
https://sketchbook.knowledgeowl.com/docs/changing-your-view
https://sketchbook.knowledgeowl.com/docs/intro-to-selection-tools
https://sketchbook.knowledgeowl.com/docs/crop-to-a-selection
https://sketchbook.knowledgeowl.com/docs/transforms#quick-transform
https://sketchbook.knowledgeowl.com/docs/transforms
https://sketchbook.knowledgeowl.com/docs/flood-fill
https://sketchbook.knowledgeowl.com/docs/text
https://sketchbook.knowledgeowl.com/docs/rulers-and-guides
https://sketchbook.knowledgeowl.com/docs/perspective-guides
https://sketchbook.knowledgeowl.com/docs/symmetry
https://sketchbook.knowledgeowl.com/docs/tools-in-sketchbook#pen-mode
https://sketchbook.knowledgeowl.com/docs/steady-and-predictive-stroke
https://sketchbook.knowledgeowl.com/docs/shape-tools
https://sketchbook.knowledgeowl.com/docs/hiding-the-ui-while-you-draw#auto-hide
https://sketchbook.knowledgeowl.com/docs/intro-to-layer-editor
https://sketchbook.knowledgeowl.com/docs/brush-palette
https://sketchbook.knowledgeowl.com/docs/color-editor
https://sketchbook.knowledgeowl.com/docs/color-palettes
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1. Main menu: create a new sketch, access the Gallery, save the canvas, import a file, export or share, and
Preferences

2. Undo and redo
3. Selection tools
4. Transform tools
5. Flood fill
6. Rulers and guides
7. Symmetry tools
8. Shape tools
9. Steady and Predictive Stroke

10. Import image
11. Perspective guides
12. Auto hide UI
13. Text tools
14. Time-lapse record
15. Either hide or display the interface

Toolbar on handheld/phone devices

1. Main menu: create a new sketch, access the Gallery, save the canvas, import a file, export or share, and
Preferences

2. Undo and redo
3. Tools
4. Brush Library
5. Color Editor
6. Layer Editor
7. Either hide or display the interface

https://sketchbook.knowledgeowl.com/docs/creating-a-canvas#mobile
https://sketchbook.knowledgeowl.com/docs/gallery-in-sketchbook
https://sketchbook.knowledgeowl.com/docs/saving-files#mobile
https://sketchbook.knowledgeowl.com/docs/importing-images#mobile
https://sketchbook.knowledgeowl.com/docs/exporting-images#mobile
https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook#mobile
https://sketchbook.knowledgeowl.com/docs/undoing-and-redoing#mobile
https://sketchbook.knowledgeowl.com/docs/intro-to-selection-tools#mobile
https://sketchbook.knowledgeowl.com/docs/transforms#mobile
https://sketchbook.knowledgeowl.com/docs/flood-fill#mobile
https://sketchbook.knowledgeowl.com/docs/rulers-and-guides#mobile
https://sketchbook.knowledgeowl.com/docs/symmetry#mobile
https://sketchbook.knowledgeowl.com/docs/shape-tools#mobile
https://sketchbook.knowledgeowl.com/docs/steady-and-predictive-stroke#mobile
https://sketchbook.knowledgeowl.com/docs/importing-images#mobile
https://sketchbook.knowledgeowl.com/docs/perspective-guides#mobile
https://sketchbook.knowledgeowl.com/docs/hiding-the-ui-while-you-draw#auto-hide
https://sketchbook.knowledgeowl.com/docs/text#mobile
https://sketchbook.knowledgeowl.com/docs/time-lapse-recording
https://sketchbook.knowledgeowl.com/docs/hiding-the-ui-while-you-draw#rapid-ui
https://sketchbook.knowledgeowl.com/docs/creating-a-canvas#mobile
https://sketchbook.knowledgeowl.com/docs/gallery-in-sketchbook
https://sketchbook.knowledgeowl.com/docs/saving-files#mobile
https://sketchbook.knowledgeowl.com/docs/importing-images#mobile
https://sketchbook.knowledgeowl.com/docs/exporting-images#mobile
https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook#mobile
https://sketchbook.knowledgeowl.com/docs/undoing-and-redoing#mobile
https://sketchbook.knowledgeowl.com/docs/tools-in-sketchbook#mobile
https://sketchbook.knowledgeowl.com/docs/brush-library#mobile
https://sketchbook.knowledgeowl.com/docs/color-editor#mobile
https://sketchbook.knowledgeowl.com/docs/intro-to-layer-editor#mobile
https://sketchbook.knowledgeowl.com/docs/hiding-the-ui-while-you-draw#rapid-ui


17

�

Free Extras

You can download free Sketchbook brushes and more from our Extras library!

Instructions to install Extras in Sketchbook on mobile (Android and iOS)

Instructions to install Extras in Sketchbook on desktop (Mac and Windows)

We are introducing new categories of extras starting with the release of Sketchbook Pro 9.0 on desktop and
Sketchbook 6.0 + the Premium Bundle on mobile.

Available Extras:
brush sets (.zip or .skbrushes)
color palettes (.skcolors)
reference images for creating color palettes
templates

Shout-out to Reddit user jrush2klb who let us know he posted a Mega Set of Sketchbook brushes for
bulk download - find it here:

https://www.reddit.com/r/SketchbookPro/comments/n95maj/sketchbook_pro_free_brushes_mega_set/

Sketchbook Pro for desktop

Installing a brush set

1. In the Brush Palette, tap  to open the Brush Library
2. Tap the brush set marking menu  
3. Select  Import Brush Set
4. Locate the downloaded brushes (usually in your Downloads folder). The files may be in either .zip or .skbrushes

format
5. Tap Open

Importing a color palette

1. In the Custom Colors window, tap  to open the Color Library
2. Tap  and select Import...
3. Locate the downloaded palette (usually in your Downloads folder) file. The file format will be .skcolors
4. Tap Open
5. Tap the new palette or the x at the top right of the Color Library to return to palette view

Importing a reference image

1. In the Custom Colors window, tap  to switch to the Image Sets tab

https://www.sketchbook.com/extras
https://app.knowledgeowl.com/#mobile
https://app.knowledgeowl.com/#desktop
https://www.reddit.com/r/SketchbookPro/comments/n95maj/sketchbook_pro_free_brushes_mega_set/
https://sketchbook.knowledgeowl.com/docs/brush-library
https://sketchbook.knowledgeowl.com/docs/color-palettes#custom-colors
https://sketchbook.knowledgeowl.com/docs/color-palettes#color-library
https://sketchbook.knowledgeowl.com/docs/color-palettes#image-sets
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2. Tap an empty image space along the left side of the window
3. Tap  to load a new image
4. Browse to the image location and tap Open

Troubleshooting importing brush .zip files

The .zip format can be an issue when using the Microsoft Edge and Internet Explorer browser to download. To
correct this issue, use a different browser, such as Google Chrome. The zipped file will download correctly and you
will have .skbrushes format files.

NOTE: The zipped files can be imported into Sketchbook Pro without extracting.

Sketchbook on mobile devices

To install Extras in Sketchbook on mobile, you'll need to be on Sketchbook version 6 and have purchased the
Premium Bundle.

Installing a brush set

1. In the Brush Palette, tap  to open the Brush Library
2. The brush import menu  appears in the upper right corner of the pinned brush set
3. Tap the menu and choose  Import
4. The file browser will launch. Navigate to the downloaded brushes, which should be in .skbrushes format
5. Tap the file to import it

Importing a color palette

1. In the Color Editor, tap to the palettes tab  
2. Tap  to open the Color Library
3. Tap  . The file browser will launch
4. Locate the downloaded palette, the file format will be .skcolors
5. Tap the file to import it
6. Tap the arrow at the upper left of the Library to return to palette view

Importing a reference image

1. In the Color Editor, tap  to switch to the Image Sets tab
2. Tap  to load a new image
3. Choose whether you want to import the file from Files (Browse), Photos (Import photo), or take a photo with the

camera (Import from camera).
4. Select the image by tapping or taking a photo with the camera

https://www.sketchbook.com/get-more
https://sketchbook.knowledgeowl.com/docs/color-editor#mobile
https://sketchbook.knowledgeowl.com/docs/color-palettes#image-sets-mobile
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Troubleshooting tips

If you get an error message when importing brush sets, color palettes, or image sets, there are a few things to take a
look at to see if you can resolve the problem quickly.

Check the file type. If your file is a .zip, you will need to unzip the archive in order to import. Check the sections
above for the expected file type for each option
Check the file size. If you are importing an extremely large file, your device may not have enough memory
(RAM) allocated to Sketchbook in order to complete the processing. Close background apps or restart your
device to free up memory.
Some Android devices can be very particular about where they allow Sketchbook to import data from on your
device. If a brush set or color palette will not import, try placing the file in the Pictures > Sketchbook Gallery
folder where Sketchbook saves its native files.

If none of these tips solve the issue, reach out to us at support@sketchbook.com with your device type, its version of
the operating system, and some information about the file you are attempting to import so we can help.
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What is a canvas?

The canvas is the virtual paper you sketch on. When you open Sketchbook, a default canvas is created for you.

What is the size of the default canvas?

The default canvas is based on the width and height of your screen. In Sketchbook Pro on Mac and Windows you
can change the default size of a new canvas in Preferences. In Sketchbook on Android and iOS, you can change the
canvas size in the New Sketch window, or use one of our presets. For more information, read Creating a canvas.

What are the canvas units?

Sketchbook Pro on Mac and Windows offers pixels/inches, pixels/cm, and pixels/mm.

Sketchbook on mobile devices will offer dimensions in pixels by default. If you want to be able to work in pixels/inch
or pixels/cm, you will need to get the Premium Bundle.

What's the difference between ppi and dpi?

Let's start with what each stands for:
ppi is pixels per inch
dpi is dots per inch

Both are used to describe the resolution of an image. PPI describes screen resolution (what you see on your
monitor); whereas DPI describes print resolution (the number of dots of ink used for printing an image with a ink jet
printer).

How will the resolution of an image affect file size?

PPI and DPI are metadata in the file, changing the resolution does not affect the file size or the pixels of the image.
The physical printer hardware uses this file metadata information to determine how to properly apply the pixels to
the paper.

https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook#canvas
https://sketchbook.knowledgeowl.com/docs/creating-a-canvas#mobile
https://sketchbook.knowledgeowl.com/docs/creating-a-canvas
https://sketchbook.knowledgeowl.com/docs/premium-bundle


21

�

Creating a canvas

Learn about setting canvas size and orientation, including rotating orientation

Jump to Mobile

When you open Sketchbook for the first time, a canvas is automatically created for you, but you may want to
customize the default settings for your specific needs.. There are an assortment of tools for customizing your
canvas. 

Canvas size

Your canvas size is its pixel dimensions (width x height). Remember that a larger canvas will be a larger file and will
require more processing power from your hardware, so bigger is not always better. Extremely large canvases may
impact device performance. For information about printing your canvas, read Setting the maximum canvas size for
printing.

Maximum canvas size

The maximum canvas resolution across all versions of Sketchbook is 100 megapixels. On a mobile
device you may be limited to how many layers you can add to a large canvas. This is determined by the available
processing capability of your device.

Creating a canvas in Sketchbook Pro for desktop

To create a new sketch, in the menu bar select File > New. You could also use the following hotkeys: Cmd+N on Mac
or Ctrl+N for Windows, or in the lagoon select  and then   .

If you want to change the default canvas size, you can update that in Preferences.

Setting your saved default file format

Do you need your files saved as PSD, but they keep getting saved as a TIFF by default? You can change your default
file type in Preferences.

For Windows users, select Edit > Preferences, then tap the General tab.
For Mac users, select Sketchbook Pro > Settings, then tap the General tab.

Select the format you want to use as default.

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/what-is-a-canvas
https://sketchbook.knowledgeowl.com/docs/setting-the-maximum-canvas-size-for-printing
https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook#canvas
https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook#general
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Tap OK.

Note that there are some features that will not be preserved when Sketchbook files are saved to PSD.

Changing the default canvas size for new files

By default, the size of a new image is the size of the display. To change the default new canvas size:
For Windows users, select Edit > Preferences, then tap the Canvas tab.
For Mac users, select Sketchbook Pro > Settings, then tap the Canvas tab.

To specify a custom size, deselect 'Use width and height of window'. The width and height entry boxes will now
be editable. You can choose to define the dimensions in either pixels, inches, cm, or mm.

To use the default display size again, check the box next to Use width and height of window.

Creating a canvas in Sketchbook for mobile devices

NOTE: to resize a canvas after you have created it in Sketchbook on mobile devices you will need to unlock the
Premium Bundle.

In the toolbar, tap  and select  New Sketch to create a new canvas. The panel changes, displaying more
options.

https://sketchbook.knowledgeowl.com/docs/import-from-photoshop
https://www.sketchbook.com/get-more
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1. Enter a pixel dimension width and height. It will start with your last-used dimensions.
If you don’t want to keep the current aspect ratio, tap the link icon  in the center to unlock the aspect
ratio

2. If the previewed canvas is portrait and you want it to be landscape, you can simply tap the rotate icon   in
the middle of the canvas preview.

3. Note the image size will display in the upper right. Avoid making excessively large files as the bigger your data
file gets, the more your device's storage and performance will be impacted.

4. Tap Create.

Selecting a custom pre-defined canvas size

1. Tap  , then  New Sketch
2. Tap or swipe the top of the window to the right side tab 
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3. Look through and select the option that best suits your needs.
4. You can edit or delete a preset with the icons to the right. Tap the gear to change the Preset name or settings,

tap the trash can to delete the preset.
If you want the canvas presets restored to the defaults, you can do that in Preferences

5. If you want to create your own preset, tap "Add Preset" at the bottom of the window
The create new preset window will default the last canvas dimensions as a starting point, but you can
choose your own dimensions and preset name.

Warning: Keep in mind that the bigger your data file gets, the more your device's performance will be
impacted. Adding many layers and/or importing multiple high resolution images to a large canvas will

require a large amount of available RAM to process.

https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook#defaults-mobile
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Importing images

Jump to Mobile

Do you have a grid, templates, reference image, want to trace something, or something else you'd like to add to
Sketchbook? If so, import the image. Once imported, lock the layer, add layers, and build up your sketch.

Importing in Sketchbook Pro for desktop

Importing an image to the open canvas

1. In the Layer Editor, tap  to browse for an image.
2. Select an image and tap Open. 

By default, when you add an image a new layer is automatically created with the image. This keeps you from
inadvertently writing over your artwork when you import. However, if you prefer to import on existing layers you
can disable this behavior in Preferences.

Importing an image as a new canvas

From the menu bar, select File > Open. 
or in the Lagoon, select  and choose  
or press Cmd+O on Mac or Ctrl+O on Windows.

Choose your image. Sketchbook will create a new canvas with the image's pixel dimensions and the image data.

You can import layered TIFF and PSD, or flat PNG, BMP or JPEG files.

Importing in Sketchbook for mobile devices

Importing an image to an existing canvas

Import Image takes an image from your camera or device and adds it to a new layer, above the active layer.
1. In the toolbar, choose  Import Image.
2. Select the image to import from either somewhere on your device or using your camera.
3. You'll enter a transform workspace, where you can position, scale, rotate, mirror, and/or flip the image:

Tap-drag to freely move the image in any direction.
Pinch with two fingers to scale the image
Tap    and use the handles to distort the image
Tap  to nudge the content one pixel at a time, by tapping an arrow or tap-drag from the middle to move

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/locking-layers
https://sketchbook.knowledgeowl.com/docs/adding-layers
https://sketchbook.knowledgeowl.com/docs/intro-to-layer-editor
https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook#general
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in any direction or on an arrow to move in that direction.
Tap  to flip the image vertically.
Tap  to flip the image horizontally.
Tap  to rotate the image counter-clockwise.
Tap  to rotate the image clockwise.

4. Tap  to accept the changes and complete the import.

Importing an image as a new canvas

Import in the Gallery

In the Gallery tap  then select one of the following:
  New from Image - select either Browse, Import photo, or Import from camera and select the image. Once
the file or image is selected, it will open in canvas view

 Add Image to Gallery - the Files browser will open, and you can navigate to the file you want to import. Tap
the file and it will be added to the Gallery, and you will remain in Gallery view.

 Add Scan to Gallery - the camera will launch so you can take your scan

Import in the canvas
1. Tap  then select Import from Files   
2. This will launch the Files browser, where you can browse files on your device or on any cloud storage you have

enabled on your device.
3. Tap the file to import

Dragging an image into the canvas (iPad only, iOS 11+)

Drag and drop creates another layer containing the dragged image.
1. With Sketchbook open, access the Apple dock and select the Files app. This opens the Browser along the side.
2. Select the image you want from the supported image formats (PNG, JPG, PSD, or Sketchbook TIFF).
3. When you find an image, drag and drop it into the canvas. 

NOTE: If the image is a Sketchbook TIFF and has multiple layers, it will be flattened onto one layer.

https://sketchbook.knowledgeowl.com/docs/scanning-sketches
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Saving files

Jump to Mobile

We can't over-emphasize how important it is to actively save your work. We sometimes hear from users who have
lost work due to an app or system crash, and had been working for hours without saving. The best method of
preserving your hard work is to save it.

Sketchbook has an Autorecovery function in case of an app or system crash. These are temporary data caches, not
conventional files that can be accessed and opened. If an Autorecovery is available, the app will ask you if you want
to recover it when you relaunch.

Do not rely on Autorecovery as a method of saving your work. If your device encounters a memory (RAM) issue, the
autorecovery cache may be cleared. You should always actively save your work.

Sketchbook TIFF files

Sketchbook's native file format is TIFF. A TIFF created in Sketchbook or Sketchbook Pro can be opened with layers
intact in Sketchbook apps on other platforms.

Only Sketchbook apps will read Sketchbook TIFF files with separate layers. If you open a Sketchbook
TIFF in another program, it will be flattened.

Saving in Sketchbook Pro for desktop

When saving your work, you can save out an alpha channel and choose the file format. Sketchbook Pro supports
saving TIFF, BMP, GIF, JPEG, PNG, and PSD.

Also see Exporting images.

The format you select determines whether the image is saved with all its layers or if it is flattened. Only TIFF and PSD
will preserve layers. Note that there are some limitations of saving a file to PSD.

You can customize the following file save behaviors in Preferences:
1. Set the default save format to either TIFF or PSD
2. Turn on the creation of backup (.bak) files
3. Set the default new file name to be incremental, or "untitled"
4. Turn on additional file verification during save, to avoid bad/interrupted saves
5. Customize how often Autosave updates
6. Customize Page Up behavior for file browsing

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/creating-an-alpha-channel
https://sketchbook.knowledgeowl.com/docs/exporting-images
https://sketchbook.knowledgeowl.com/docs/import-from-photoshop
https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook#general
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Saving in Sketchbook for mobile devices

Tap  , then   Save.

If a sketch has been previously saved to the Gallery and additional edits have been made, the prompt will also
include the option to Save the current sketch as a copy. This is useful when you want to have checkpoints of
progress on a piece or when you want to take a piece in a different direction without overwriting the current version.

You can access your saved files in the Gallery.

You can also save your file by exiting to the Gallery
1. Tap  , then   Gallery.
2. A dialog appears. Select an option.

Save current sketch – updates the saved file.
Save current sketch as a copy – creates a new file and saves the sketch with the changes to that file,
while preserving the original.
Discard changes – deletes any modifications to the original file.

3. The Gallery opens. Swipe to the left to ensure your sketch has been saved to the Gallery.
4. For information on exporting or sharing your layered image files, see the article Exporting images.

Additional information for Android devices

Auto Save Timer 
You can set a timer to automatically save your open canvas while you work. This can protect you from losing
unsaved work due to low available RAM or from your device shutting down due to low battery.

To enable the timer:
1. Tap  , then  Preferences
2. Navigate to the Sketchbook Data section
3. At "Automatically Save to Gallery" tap the button to switch the setting from 'Never' to 15 minutes, 30 minutes,

or 60 minutes.

Where are your files saved

Android devices save your work into internal storage, so they will appear in your Files app. If you are on Android 11 or
higher, your files are in the folder Internal Storage > Pictures > Sketchbook Gallery. 
If you are on Android 10 or below, your files are in Internal Storage > Autodesk > SketchBook3. 

The TIFF files in this folder are your Sketchbook art.

https://sketchbook.knowledgeowl.com/docs/gallery-in-sketchbook
https://sketchbook.knowledgeowl.com/docs/exporting-images#mobile
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Important - Android   
If you move, rename, or delete the TIFF files in this folder, your Sketchbook Gallery will not be able to
find them. You may see an error message Failed to open image the next time you try to open a file from

your Sketchbook Gallery. Do not move, rename, or delete the TIFF files from this folder.

Additional information for iOS devices

Warning - iOS
On iOS your art files are saved within the app, they cannot be navigated to from outside the app. If you

delete the app, you will delete your art. Apple warns you before deleting that you are deleting all your data. The
only recovery from this is to restore an earlier device backup if you have one.

https://sketchbook.knowledgeowl.com/docs/android-tiff-could-not-be-opened
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Resizing images

Jump to Mobile

When you want to change the size of your entire artwork, you will need to edit Image Size. This will affect the pixels
of your work, unlike editing the Canvas Size which changes the canvas without affecting the existing pixels on the
canvas.

For information on changing canvas and resolution, read Resizing your canvas.

Resizing an image in Sketchbook Pro for desktop

From the menu bar, go to Image > Image size to change the dimensions of the image in pixels, its resolution, or the
document size.

This change directly affects memory usage, quadrupling it if you double the pixel size. The maximum image size is
100 megapixels.

Resizing an image

1. In the toolbar, select Image > Image size.
2. In the Image Size window, do any of the following:

If you know the pixel dimensions you want, in Pixel Dimensions, choose between pixels or percent, then
enter a numeric value for Width and Height.
If you know the print/paper size you want, in Document Size, choose the units (percent, pixels, inches,
cm, or mm), then enter a numeric value for Width and Height.
To change the resolution of the image, enter a new value in Resolution. You can also choose from
pixels/inch, pixels/cm, or pixels/mm.

If Resample image is checked, when you change the resolution you will also see the pixel

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/resizing-your-canvas
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dimensions adjust proportionally. After tapping "OK", Sketchbook Pro will resample the image and
add pixels to increase the resolution of the work.
If Resample image is unchecked, when you change the resolution you will see the print dimensions
adjust proportionally. 

3. Tap OK.

Resizing an image in Sketchbook for mobile devices

Resizing an image is available when you unlock the Premium Bundle.

1. From the main canvas toolbar, tap the  menu, and then  Edit Canvas 

2. In the Image Size window, do any of the following:
To change the dimensions of the image, enter a new numeric value in the two boxes which correspond to
Width and Height

You can change the unit of measurement by tapping the arrow > above the Width and Height boxes
and choose Pixels, Inches, or Centimeters. When units are shown in inches or centimeters, the
corresponding pixel dimensions will appear beneath, as a frame of reference

To change the resolution of the image (leaving the document size the same, but changing the quality of
the image and resolution), in Resolution, enter a new number in the numerical field.

To change the unit of measurement you will need to tap the arrow > above the Width and Height
boxes and choose Pixels, Inches, or Centimeters.
If you are changing resolution in px/inch or px/cm, you will have the option to resample the image.

https://www.sketchbook.com/get-more
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This is toggled on by default.
3. Tap Done.

Resampling
If you have dimension units set to pixels, your image will automatically resample when changing image
size.

When your dimension units are set to inches or centimeters, a toggle will appear where you can change whether
or not the image will resample. The toggle is on by default. If you want to change resolution without changing
the pixel dimensions of the image, you can toggle it off.
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Resizing your canvas

Jump to Mobile

When you want to change the size of your canvas in order to increase the available space for drawing or to crop the
canvas down, you can edit the canvas size. Editing the canvas will not change the pixels of your artwork, other than
removing data if you are cropping to a smaller size.

The maximum canvas size is 100 megapixels. If you change a dimension to a number that would cause the canvas
to exceed 100 megapixels, you will see an error message and be unable to apply the change.

If you want to change the size of your artwork, for example changing the image's resolution, you will need to edit
Image Size.

Resizing your canvas in Sketchbook Pro for desktop

From the menu bar, go to Image > Canvas size to change the dimensions of the canvas.

Resizing your canvas

1. From the menu bar, select Image > Canvas size.
2. Adjust the Width and Height of the image by changing the numeric values in the boxes.

You can change the unit of measurement between percent, pixels, inches, cm and mm with the drop-
down menu to the right

3. Choose the anchor point for the adjustment. This defaults to the center of the canvas, but you can change it if
you want to extend or crop your canvas on a particular side by tapping a box to set the anchor at that location.

For example if you set the anchor at the right middle box, the canvas will adjust to the center left.
4. Tap OK

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/resizing-images
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Resizing your canvas in Sketchbook for mobile devices

Resizing your canvas is available when you unlock the Premium Bundle.

1. From the main canvas toolbar, tap the  menu, and then  Edit Canvas
2. Tap the tab on the right to switch from Image Size to Canvas size

3. Adjust the Width and Height of the image by changing the numeric values in the boxes.
You can change the unit of measurement between pixels, inches, and cm by tapping the arrow > and
choosing a new dimension option

4. Choose the anchor point for the adjustment. This defaults to the center of the canvas, but you can change it if
you want to extend or crop your canvas on a particular side by tapping a box to set the anchor at that location.

For example, if you set the anchor at the right middle box, the canvas will adjust to the center left.
5. Tap Done.

Crop the canvas to a selection

If you want to reduce the size of your canvas, you can crop it by creating a selection and then using the crop tool in
the selection toolbar. 

https://www.sketchbook.com/get-more
https://sketchbook.knowledgeowl.com/docs/intro-to-selection-tools#mobile
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This will crop the entire canvas (all layers) to the selection. Regardless of the type of selection, the cropped canvas
will be a rectangle. Keep in mind that this action will also reduce the number of pixels in your canvas, there is no
resampling when cropping to a selection.
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Exporting images

Tips for exporting and sharing images including managing orientation, size, and layers when moving
between devices

Jump to Mobile

Exporting from Sketchbook Pro for desktop

You can export your images from Sketchbook Pro to the following formats:
TIFF
PSD
PNG
JPEG
BMP

for Flipbook animations, see Saving and exporting Flipbooks.

When you export an image, there are a few things to keep in mind. The first is any limitations of the file type.
TIFF is Sketchbook's native file format, and will reopen in any Sketchbook app with layers and data intact.
However only Sketchbook will reads layers in a Sketchbook TIFF, so this file opened in a different software
package will be flat
PSD will preserve layers and most data, but there are some Sketchbook features that will not be preserved
PNG and and BMP will be flattened, compressed files in a lossless format
JPEG will be a flattened file with some lossiness

Exporting Sketchbook Pro images to a mobile device

When moving files from desktop to a mobile device, it is good to consider is the capacity of the device you will
import to. On mobile devices, the number of layers supported will be dependent on the device's available memory
(RAM).

When you export an image with layers and/or a large canvas size from Sketchbook Pro on desktop to a mobile
device, if the device cannot support the file a warning will appear. The warning will let you know what the issue is.

If the version of Sketchbook you're bringing the file into doesn't have layer grouping, then the layers come in
ungrouped.

Exporting from Sketchbook for mobile devices

Use Share when you want to send a drawing directly to another app on your device. The Share workflow brings up
the device's sharesheet, a window showing options to send via text message or to select from a list of apps.
Sketchbook does not control the contents of the sharesheet, that is defined by your device and its version of the
operating system.

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/saving-and-exporting-flipbooks
https://sketchbook.knowledgeowl.com/docs/import-from-photoshop
https://sketchbook.knowledgeowl.com/docs/max-layers-on-mobile
https://sketchbook.knowledgeowl.com/docs/grouping-layers
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Use Export when you want to save a file to your device's Files app. Similar to the sharesheet, the files window is
controlled by your device, and will include options for local or cloud folders that you have set up in your Files app.

To export a single canvas:

1. Tap Share/Export  from the menu
2. Choose Export to Files if you want to save a file, or Share if you want to send it to another app
3. Choose the file type

Sketchbook TIFF is Sketchbook's native file format and contains all your layer data. This choice is best if
you plan to open the file in Sketchbook or Sketchbook Pro on another device. Only Sketchbook will open
a Sketchbook TIFF with layers, other apps will flatten the image.
PSD is the best choice for moving a layered file to another image editor. Note that there are some
features that will not be preserved when Sketchbook files are saved to PSD.
PNG
JPG
PDF (requires the Premium Bundle)

4. Export to Files will open your file browser, where you can edit the name of the file and where it will be saved.
This name is only applied to the export and is not assigned to your piece in Sketchbook.

Exporting multiple canvases from the Gallery

1. In the Gallery, pinch-zoom out or tap  to enter small thumbnail view
2. Tap Share/Export  from the menu
3. Choose Export to Files if you want to save to your device or connected cloud server, or Share if you want to

send it to another app
4. Choose the file type and follow the same steps as above for a single image export. 

Note: PSD is not available for batch export due to the processing required to convert the files

Exporting PDFs

Exporting a single image or entire Gallery Album as a PDF is available as part of the Premium Bundle.

See Exporting PDF files for more details.

TIPS:
When saving to folders in Files, duplicate file names are not allowed, so if the name exists, you will be
prompted if you want to ‘Replace’, ‘Keep Both’, or ‘Stop.’
If you want to repeatedly export to Files and use the same name to replace (update) the file, it may be easier to
save it and name it in the Gallery first. This will allow the export to use the same name automatically

https://sketchbook.knowledgeowl.com/docs/import-from-photoshop
https://www.sketchbook.com/get-more
https://sketchbook.knowledgeowl.com/docs/gallery-in-sketchbook
https://www.sketchbook.com/get-more
https://sketchbook.knowledgeowl.com/docs/exporting-pdf-files
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If you do not re-name your file, you are given the option to ‘Replace’, ‘Keep Both’, or ‘Stop.’ If ‘Replace’ is tapped,
it writes over the original image, and it cannot be recovered

Warning

The iOS Photos app is known to convert PNG files to JPG, with the most obvious result being the loss
of a transparent background. It is more common for files over 4k and under 360px, but it can happen to any file.
The only workaround if this is happening on your device is to save your PNGs to Files instead of to Photos.
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Transferring images with layers

This articles explains how to move images between Sketchbook apps on one device and another, whether from
desktop to mobile, mobile to mobile, or mobile to desktop, while preserving the image’s layer structure.

Use this when starting a sketch on one platform, then transferring the sketch to another platform to continue
sketching without collapsing your layer structure during the transfer, or when you are setting up a new device.

Due to differences in number of supported layers across various mobile devices, you may not be able to transfer an
image fully intact. In some cases, you may see a warning that the layers need to be flattened to be supported on a
different mobile device.

Be aware that there are some features that will not be preserved when Sketchbook files are saved to PSD.

Click the link that best describes from where and to where you want to transfer your images:
iOS to Desktop
iOS to iOS or Android
Android to Desktop or iOS
Android to Android
Desktop to mobile

iOS to Desktop

You can export from the canvas, or if you have multiple files to move you can export from the Gallery.

From the canvas, tap , then Share/Export . From here you have two options to transfer your file to another
location:

1. Tap Export to Files  to open the iOS Files app, where you can save to your iCloud Drive. The file saved will be
the full layered TIFF.

2. or Tap Share  . It will first ask you to choose whether you want to share a flattened PNG (smaller file size) or
your Sketchbook TIFF (your complete layered art). Select Sketchbook (TIFF). Then the iOS share sheet will
open, where you can select how you want to share the file (eg: by email, cloud service app, etc)

From the Gallery, select the file or files you want to transfer. Tap the menu in the lower right corner then
Share/Export .

1. Tap Export to Files  to open the iOS Files app, where you can save to your iCloud Drive. The file saved will be
the full layered TIFF.

2. or Tap Share  . It will first ask you to choose whether you want to share a flattened PNG (smaller file size) or
your Sketchbook TIFF (your complete layered art). Select Sketchbook (TIFF). Then the iOS share sheet will
open, where you can select how you want to share the file (eg: by email, cloud service app, etc)

Go to your desktop computer (Win/Mac) and connect to the service you shared to (iCloud Drive, email, other cloud
service). Save/download the TIFF file to your desktop. You can then open the TIFF file in Sketchbook Pro on your
desktop with all of its layer data intact.

https://sketchbook.knowledgeowl.com/docs/max-layers-on-mobile
https://sketchbook.knowledgeowl.com/docs/import-from-photoshop
https://app.knowledgeowl.com/#ios-desktop
https://app.knowledgeowl.com/#ios-android
https://app.knowledgeowl.com/#android-desktop
https://app.knowledgeowl.com/#android-android
https://app.knowledgeowl.com/#desktop-mobile
https://sketchbook.knowledgeowl.com/docs/what-is-a-canvas
https://sketchbook.knowledgeowl.com/docs/gallery-in-sketchbook
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iOS to iOS or Android

You can export from the canvas, or if you have multiple files to move you can export from the Gallery.

From the canvas, tap , then Share/Export . From here you have two options to transfer your file to another
location:

1. Tap Export to Files  to open the iOS Files app, where you can save to your iCloud Drive. The file saved will be
the full layered TIFF.

2. or Tap Share  . It will first ask you to choose whether you want to share a flattened PNG (smaller file size) or
your Sketchbook TIFF (your complete layered art). Select Sketchbook (TIFF). Then the iOS share sheet will
open, where you can select how you want to share the file (eg: by email, cloud service app, etc)

From the Gallery, select the file or files you want to transfer. Tap the menu in the lower right corner then
Share/Export .

1. Tap Export to Files  to open the iOS Files app, where you can save to your iCloud Drive. The file saved will be
the full layered TIFF.

2. or Tap Share  . It will first ask you to choose whether you want to share a flattened PNG (smaller file size) or
your Sketchbook TIFF (your complete layered art). Select Sketchbook (TIFF). Then the iOS share sheet will
open, where you can select how you want to share the file (eg: by email, cloud service app, etc)

On the other device, open Sketchbook and go to the Gallery. Tap  at the bottom of the Gallery screen and select
Add Image to Gallery. Browse to where your TIFF file or files are located - if you shared via email or messages, you
will need to save the file to your local Files before this step. Find the file and tap on it to bring it into the Gallery.

Android to Desktop or iOS

You can move between the mobile and desktop version of Sketchbook to work on your layered images, as long as
the file’s canvas size and layer limits remain within the storage and RAM capacity of your Android device.

You can export from the canvas, or if you have multiple files to move you can export from the Gallery.

From the canvas, tap , then Share/Export . From here you have two options to transfer your file to another
location:

1. Tap Export to Files  to open your Files app, where you can save to your Google Drive or other connected
drive. The file saved will be the full layered TIFF.

2. or Tap Share  . It will first ask you to choose whether you want to share a flattened PNG (smaller file size) or
your Sketchbook TIFF (your complete layered art). Select Sketchbook (TIFF). Then the Android share sheet will
open, where you can select how you want to share the file (eg: by email, cloud service app, etc)

From the Gallery, select the file or files you want to transfer. Tap the menu in the lower right corner then
Share/Export .

1. Tap Export to Files  to open your Files app, where you can save to your Google Drive or other connected
drive. The file saved will be the full layered TIFF.

2. or Tap Share  . It will first ask you to choose whether you want to share a flattened PNG (smaller file size) or
your Sketchbook TIFF (your complete layered art). Select Sketchbook (TIFF). Then the Android share sheet will

https://sketchbook.knowledgeowl.com/docs/what-is-a-canvas
https://sketchbook.knowledgeowl.com/docs/gallery-in-sketchbook
https://sketchbook.knowledgeowl.com/docs/what-is-a-canvas
https://sketchbook.knowledgeowl.com/docs/gallery-in-sketchbook
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open, where you can select how you want to share the file (eg: by email, cloud service app, etc)

Then on your desktop or your iOS device, navigate to the location you shared to.
If you are moving the file to desktop, you can simply open it with File > Open in Sketchbook Pro
If you are moving the file to iOS, launch Sketchbook on your iOS device and go to the Gallery. Tap  at the
bottom of the Gallery screen and select Add Image to Gallery. Browse to where your TIFF file is located - if you
shared via email or messages, you will need to save the file to your local Files before this step. Find the file and
tap on it, the canvas will open with your file. 

Alternatively, because Android allows you to navigate Internal Storage to where your Sketchbook files are saved in
their native TIFF format, you can move files between devices this way.

In Sketchbook on Android, go to the Gallery. Find the image you want to move to another device, and tap on the
information icon  above the image. In the information window, you will see the File ID and File location. Navigate
to the location and identify the .TIFF file with that File ID. Copy that TIFF file to your desktop or iOS device through
any method (cloud service, Bluetooth, email, etc).

1. If you are moving the file to desktop, you can simply open it with File > Open in Sketchbook Pro
2. If you are moving the file to iOS, launch Sketchbook on your iOS device and go to the Gallery. Tap  at the

bottom of the Gallery screen and select Add Image to Gallery. Browse to where your TIFF file is located - if you
shared via email or messages, you will need to save the file to your local Files before this step. Find the file and
tap on it, the canvas will open with your file. 

Android to Android

If you have a new Android device, you may be looking to move your art from the old device to the new one.
1. Navigate your Internal Storage or My Files to the folder Pictures > Sketchbook Gallery 

If your older device is Android 10 or lower, or on an older version of the Sketchbook app, you want the folder
Autodesk > SketchBook3

2. Select all the TIFF files in the folder 
IMPORTANT: do not select any other subfolders, as copying anything but your TIFF files to another Android
device may cause serious problems. If you have done this, and Sketchbook crashes on start, please reach out
to our support team for help.

3. Copy these TIFF files to a cloud service or an SD card
4. On your new device, make sure you have Sketchbook installed, and have launched it at least one time. This will

create the correct folder structure on your device to receive the files.
5. Copy the TIFF files from the SD card or cloud service into the Pictures > Sketchbook Gallery folder on the new

device 
If your new device is on Android 10 or lower, the folder will be Autodesk > SketchBook3

6. Launch Sketchbook, and from the main menu go to Preferences, and tap on "Check for Recoverable Images".
This will populate your Gallery with the images from your old device, in a folder named "Recovered". You can
then organize them into albums if you prefer. 

Desktop to mobile
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1. Save your sketch as a TIFF file to your computer.
In the menu bar, select File > Save As. In the Save As dialog, tap the Save as type option and select TIFF Files,
then tap Save.

2. Send the file to your mobile device by whatever means is convenient: cloud service, email, Bluetooth
connection, etc.

3. On your device, go to whatever service you sent the TIFF through, and save the TIFF to your Files on your
device.

4. Launch Sketchbook
5. In the Gallery, tap the  icon at the bottom and select Add Image to Gallery.
6. Browse to where you saved the TIFF file on your device and select it. The canvas will be added to your Gallery

as a new file.
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Sending, Printing, and Presenting

Jump to Mobile

Print images or email them. Present sketches to colleagues, clients, or friends.

Sending, printing, and presenting in Sketchbook Pro for desktop

Once you've created an image, you might want to send it to a client, print it for sale, or present it in a meeting. Here
are instructions to help you do that:

Emailing a sketch (Windows only)

Email a sketch to someone by selecting File > Send Mail, a file format, then Send Mail.

If you want to know the size of the image, use Calculate File Sizes.

Troubleshooting

If you see a message that you cannot email the image, check that:
Your email program is open. Some email programs must be actively running before using this feature.
You have selected a default email application and you can launch your default email program from outside of
Sketchbook Pro. Try the following:

From the Windows Start menu, choose Run.
Type the “mailto:” command.
Click OK. 
If a new empty message window does not appear, then there is a problem with the configuration of your
email application and/or account.

Printing images

Make printouts of your sketches by selecting File > Print. See Setting the maximum canvas size for printing for
information on setting canvas size and dpi for print.

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/setting-the-maximum-canvas-size-for-printing
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Presenting images: flipping through your sketches

You can navigate the files in a folder from the Lagoon. Using this process, Sketchbook Pro will open any image files
in the folder, not only files saved from Sketchbook Pro.

To open the next image file in the current folder, tap  then choose . Files will be displayed in increasing
order by file name.

To move to the previous image file in the current folder, tap  then choose . Files are displayed in decreasing
order by file name.

NOTE: If you mark up the files, a prompt to save your changes when you go to the previous or next
image appears. To preserve the original image, save the marked-up image under a different file name.

Changing the behavior of Page Up (Windows only)

On Windows PCs with Page Up / Page Down keys, you can customize the behavior. Tap the General tab, in the Page
Up section, tap one of the following setting to set up the program behavior that works best for your system.

Opens next image
Opens previous image

Sending and printing in Sketchbook on mobile devices

Sketchbook on mobile devices does not have its own internal function for sending a file to a printer, it instead calls
out to your device's settings. So your options will depend on the apps and settings you have for email, messaging,
and printing. 

1. Tap Share/Export  from the menu
2. Choose Share
3. Choose the file type

Sketchbook TIFF is Sketchbook's native file format and contains all your layer data. This choice is best if
you plan to open the file in Sketchbook or Sketchbook Pro on another device. Only Sketchbook will open
a Sketchbook TIFF with layers, other apps will flatten the image.
PSD is the best choice for moving a layered file to another image editor. Note that there are some
features that will not be preserved when Sketchbook files are saved to PSD.
PNG
JPG
PDF (requires the Premium Bundle)

4. The Share Sheet will open, where you can select the app you want to share the file to. The Share Sheet is a
function of your device's operating system, Sketchbook does not control which apps appear here.

https://www.sketchbook.com/get-more


45



46

�

Setting the maximum canvas size for printing

When printing out an image, the resolution is measured in ink dots per inch (dpi). Therefore, when you are setting up
a canvas that you want to later print you need to calculate the needed pixel size of your canvas for your preferred
printing resolution (usually 150 or 300 dpi).

In Sketchbook for mobile devices, the maximum canvas size will be limited by the capacity of the device. Different
devices will max out at different sizes, though the ultimate maximum canvas size is 100 megapixels.

Keep in mind that bigger may not be better - a 4k canvas on your mobile device will be a very large file, taking both
storage on your device and impacting performance due to the RAM requirements of a large file.

What's the difference between ppi and dpi?

Let's start with what each stands for. PPI is pixels per inch, dpi is dots per inch. Both are used to
describe the resolution of an image. PPI describes screen resolution (what you see on your monitor); whereas
dpi describes print resolution (the number of dots of ink used when printing an image). In Sketchbook, the ratio
of PPI to DPI is 1:1.

See below for some common document sizes.

A-series paper sizes

Size Width x Height (mm) Width x Height (in)

A1 594 x 841 mm 23.4 x 33.1 in

A2 420 x 594 mm 16.5 x 23.4 in

A3 297 x 420 mm 11.7 x 16.5 in

A4 210 x 297 mm 8.3 x 11.7 in

US Paper sizes

Size Width x Height (mm) Width x Height (in)

Letter 216 x 279 mm 8.5 x 11.0 in

Legal 216 x 356 mm 8.5 x 14.0 in

Common photo print sizes
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Print size Image size for 300 dpi

3 x 5 inches 900 x 1500 pixels

4 x 6 inches 1200 x 1800 pixels

5 x 7 inches 1500 x 2100 pixels

8 x 8 inches 2400 x 2400 pixels

8 x 10 inches 2400 x 3000 pixels

8.5 x 11 inches 2550 x 3300 pixels

9 x 16 inches 2700 x 4800 pixels

11 x 14 inches 3300 x 4200 pixels

11 x 16 inches 3300 x 4800 pixels
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Customizing your UI

Jump to Mobile

Customizing your UI in Sketchbook Pro for desktop

Move the tools you use the most to where you can get to them in a flick of your stylus. If you spend a lot of time in
Sketchbook Pro, a few customizations can go a long way toward improving your productivity. The tools found in the
Lagoon can be customized, along with the brushes in the Brush Palette. 

Don't forget, there are hotkeys to access tools quickly as well. You can customize those, too.

Customizing your desktop

In the Lagoon, the first icon at the top  houses the Interface Controls. Use these to change your layout and set
what interface elements are visible.

 Toggle UI – turns on (or off) visibility of all toolbars, windows, palettes, the pucks and the lagoon. When toggled
off, you will see only the canvas, and the Interface Controls icon trigger for the lagoon. Alternatively, you can set the
UI to automatically disappear when you draw using Auto Hide UI

 Toggle full screen – when in full screen mode, the title bar and Task bar (Windows) or Dock (Mac) are hidden.

 Lagoon Right – flips the lagoon to the right corner of the canvas. Toggles to Lagoon Left 

 Toggle Lagoon – turns the Lagoon on and off

 Scroll Bars – turns canvas scroll bars on or off

I can't find my Layer Editor, Color Editor, or other UI elements

If you can't find a UI element or window, or they are on one monitor while your canvas is on the other, here is a quick

https://app.knowledgeowl.com/#mobile
https://app.knowledgeowl.com/#lagoon
https://app.knowledgeowl.com/#brushes
https://sketchbook.knowledgeowl.com/docs/hotkey-shortcuts#customize
https://sketchbook.knowledgeowl.com/docs/basic-ui-elements#lagoon
https://sketchbook.knowledgeowl.com/docs/hiding-the-ui-while-you-draw
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fix:
1. In the menu bar, select Window > Default Layout. This will centralize things.
2. Next, either open the editors you need through the toolbar or by selecting them from the Window menu.

Where's my title bar?

If your title bar is not visible, you can re-enable it with the hotkey combination Ctrl+Alt+J (Win) or
Option+Command+J (Mac)

Customizing your lagoon

The Lagoon (the round UI element) by default is found in the bottom left corner of the canvas. This where you can
find lots of useful tools. It is gesture driven, like the menu in the Layer Editor.

You can customize which tools appear in the Lagoon in Preferences 

For Windows users, select Edit > Preferences, then tap the Lagoon tab.

For Mac users, select Sketchbook > Settings, then tap the Lagoon tab.

By default, the top marking menu icon is selected. In this case, it’s Zoom/Rotate/Move Canvas. In the Default
Sketchbook Pro Tools list to the right, you can see that Zoom/Rotate/Move Canvas is selected. To change the tool
assigned to this location in the marking menu, scroll through the list to find a new tool and click it. You can always
revert back to default settings by tapping Reset in the bottom left corner.

Changing Lagoon icons

You can manually swap out or rearrange the existing Lagoon icons. In the representation of the Lagoon in the upper

https://sketchbook.knowledgeowl.com/docs/basic-ui-elements#lagoon
https://sketchbook.knowledgeowl.com/docs/layer-editor-marking-menu
https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook#lagoon
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left of the Preferences window, tap the icon you wish to change. Once highlighted, select an icon from the group to
the right.

The Lagoon will not update until you click OK and close the Preference window.
You cannot change the Interface Controls icon.

Once done, you can use hotkeys (1-6) or right-click to access these custom marking menus without visiting the
Lagoon. 

If you have made any custom changes to the Lagoon marking menus, the hotkey assignment will have also changed
(based on your customization of the Lagoon). The new custom marking menus will always be pinned to those
hotkeys. The only way to reset them is to tap Reset.

Naming custom brushes

When creating custom brushes, there are a few reasons it is important to assign names. The first is lagoon
customization. Without names, you will have a hard time identifying your custom brushes from a list of Do-It-
Yourself-Brushes and Do-It-Yourself-Brush copies.

Once you've learned this the hard way and had to back-track to name these brushes in the Brushes marking menu,
you'll see just how important this is. For instructions on how to do this, see Renaming brushes and brush sets.

Change the brush cursor

In Sketchbook Pro to turn on or off the brush crosshair, in the title bar go to View > Brush Crosshair

In earlier versions of Autodesk Sketchbook, this option is found in the Brush tab of Preferences.

Note: if you have your device/stylus global settings set to the cursor OFF, turning on brush crosshair in Sketchbook
Pro will have no effect. Sketchbook Pro will not override the global setting.

View the brush outline and/or brush stamp

By default, a brush outline appears for the sharpen, blur, and smear brushes, eraser, and other low-opacity brushes
such as the airbrush. This circle shows you the brush size before you start drawing.

You can also turn on the option to show the brush stamp. This will show a preview of the brush texture or stamp as
you hover your stylus.

To turn on or off the brush outline, in the title bar go to View > Brush Outline

To turn on or off the brush stamp, in the title bar go to View > Brush Stamp

In earlier versions of Sketchbook Pro and Autodesk Sketchbook, these options are found in the Brush tab of

https://sketchbook.knowledgeowl.com/docs/hotkey-shortcuts#marking-menu
https://sketchbook.knowledgeowl.com/docs/hotkey-shortcuts#marking-menu
https://app.knowledgeowl.com/#lagoon
https://sketchbook.knowledgeowl.com/docs/renaming-brushes-and-brush-sets
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Preferences.

Changing the language displayed in the UI

Sketchbook Pro is available in the following languages: English, Simplified Chinese, Traditional Chinese, French,
German, Italian, Japanese, Korean, Brazilian Portuguese, Russian and Spanish.

If your device is set to a language that Sketchbook Pro does not support, the app will default to English. You can set
a different language for Sketchbook Pro if you prefer.

On Windows you can change the language of the UI in Preferences.
1. In the first tab (General) of the window, select the Language option. There's a dropdown menu with the

language choices.
2. Select the language you want.
3. Tap OK. 

A restart of Sketchbook Pro is required for this change to take effect. Close Sketchbook Pro, then relaunch it.
The language changes will now be visible.

On macOS language preferences are defined in macOS System Preferences. You can set app-specific languages in
the Language and Region dialog.

Customizing your UI in Sketchbook for mobile devices

If you spend a lot of time in Sketchbook, a few customizations can go a long way toward improving your
productivity.

Customizing the UI can be done in Preferences. Tap  and select  Preferences.

https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook#general
https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook#mobile
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Gestures and menus for quick tool access

You can apply these tools to corner shortcuts, the marking menu, and tap and swipe gestures:
Clear Layer
Frame Canvas
undo
Redo
Last Brush
Last Color
Transparent Color
Brush Library
Color Wheel (Color Editor)
Full Screen
Color Picker
Flip Canvas
Gallery
Save to Gallery

Show/hide the status bar

If you prefer to see the status bar across the top of your screen showing information such as the time and battery
available, you can toggle this option on. It will be off by default.

Show/hide tooltips

Tooltips appear briefly when you tap on a tool, showing the tool name. Tooltips are enabled by default, but you can
disable them if you prefer.

Marking Menu

The marking menu is the quick-access menu enabled with the  icon at the bottom center of the screen. Along with
being able to customize which tools appear in the marking menu, you can also disable it entirely by toggling it off in
Preferences.

https://sketchbook.knowledgeowl.com/docs/basic-ui-elements#marking-menu
https://sketchbook.knowledgeowl.com/docs/gestures#mobile
https://sketchbook.knowledgeowl.com/docs/basic-ui-elements#marking-menu
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Show Brush Panel

The Brush Panel was previously not available in the phone/handheld version of Sketchbook, but this option is
available starting in Sketchbook version 6. It is on by default, but it you prefer not to see it you can toggle it off.
Tablet users have the same option.

Pen Connection (iOS only)

In the Pen Connection section, you have the option to set your stylus, and how it engages with the canvas.

Tap-hold for Color Picker - when enabled, a long-press with your Apple Pencil will turn on the Color Picker. This
setting is off by default.

Pen Mode - when enabled, finger touch will not make marks on the canvas, only the stylus can mark the canvas.
Touch is still enabled for menus and toolbars. Pen mode will enable by default when you set your pen connection.

Enable Multi-Touch Gestures - this setting is paired with Pen Mode, and will be on by default. It allows touch
gestures such as pinch-zoom and taps to be registered by the canvas when Pen Mode is active.

Brush Stamp - will show the current brush stamp preview hover on Apple Pencil and Apple Pencil Pro hardware. The
stamp preview will be at the minimum pressure size on hover.

https://sketchbook.knowledgeowl.com/docs/using-the-color-picker#mobile


54

� On Android devices, the Pen Connection section is located in the main menu

Small Double Puck

Depending on the resolution of your device, you may prefer the Double Puck to appear smaller. This option will be off
by default.

Double Puck Small Double Puck

How to hide your UI

If you like to sketch without the visual clutter of the UI, you have a few options on how to hide and re-access the UI.
See Hiding the UI while you draw for the details.

Changing the language displayed in the UI on Mobile

If you would like to change the language displayed in the app to something else, you can do this through the settings
of your device.

iOS

https://sketchbook.knowledgeowl.com/docs/color-puck#mobile
https://sketchbook.knowledgeowl.com/docs/hiding-the-ui-while-you-draw
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On iOS, Sketchbook uses the language setting of the device. To change the app language, you must change your
device's language settings.

1. On your device, open your Settings app > General and scroll to the bottom of the page. Look for and tap
Language & Region.

2. Tap Language and select the language you want from there.
3. Tap Done. A message appears asking if you would like the language settings changed.
4. Tap Continue to change the displayed language.

Android

On Android, Sketchbook uses the language setting of the device. To change the app language, you must change your
device's language settings.

On your device, open your Settings > General Management and select Language and input , then Language. You
might need to press Add language to load the one you want. Different versions of Android may have these settings
in different locations.
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Hotkey shortcuts

Speed up your sketching by assigning key combinations or buttons to marking menus or individual
tools.

Jump to Mobile

Hotkeys are key combinations or buttons assigned to marking menus or individual tools. Once you get to know them,
you’ll notice an increase in your speed as you sketch.

Hotkeys are also very customizable.

Hotkeys in Sketchbook Pro for desktop

There are hotkeys for marking menus and tools. If you don't like the defaults, you can change them. 

Marking menu Hotkeys

The lagoon marking menus have the hotkeys 1, 2, 3, 4, 5, and 6 assigned to them. Even if you have customized your
lagoon, these won’t change. These hotkeys can be particularly useful when set up as express keys on your tablet or
stylus buttons.

Lagoon Position Mouse Stylus

First press 1, then right-click
Press-hold 1 and pen-down (left
click)

First press 2, then right-click
Press-hold 2 and pen-down (left
click)

First press 3 then right-click
Press-hold 3 and pen-down (left
click)

First press 4 then right-click
Press-hold 4 and pen-down (left
click)

First press 5, then right-click
Press-hold 5 and pen-down (left
click)

First press 6, then right-click
Press-hold 6 and pen-down (left
click)

https://app.knowledgeowl.com/#mobile
https://app.knowledgeowl.com/#marking-menu
https://app.knowledgeowl.com/#customize
https://app.knowledgeowl.com/#customize
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Creating custom hotkeys

If the default hotkeys in Sketchbook Pro aren't how you prefer to work, many of them can be customized.
1. Select Edit > Preferences and tap Hotkeys.

2. Scroll through the list to select the command you want to change.
3. Tap the hotkey associated with the command to make it editable.
4. Enter a new hotkey.
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5. What happens if a hotkey is already assigned to the new value you entered? 
A message appears. You can either use the assigned hotkey for the current command or enter a new one. If
you choose to use it, you will need to create a new hotkey for the other command.

6. Tap Open.

Resetting hotkeys

You can reset some or all hotkeys to their default setting.
To reset the hotkey for a specific command, select the command, tap Reset, then OK.
To reset all hotkeys to their default settings, tap Reset All, then OK.

Hotkeys in Sketchbook for mobile devices

Hotkeys for Android

Action Shortcut

Quit app ESC or Ctrl + Q

Color Picker Alt or I

Copy Ctrl + C
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Cut Ctrl + X

Paste Ctrl + V

Undo Ctrl + Z or Back

Redo Ctrl + Y, Ctrl + Shift + Z, or Forward

Preferences Ctrl + ,

Last brush S

Toggle fullscreen UI Tab or T

Fit canvas Ctrl + 0

Clear selection Ctrl + D

Sketchbook for iOS doesn't currently support hotkey shortcuts.
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Gestures

Sketchbook on mobile devices supports an assortment of gestures to help you navigate.

Use one, two, and three fingers to access an assortment of tools, along with preferences for customization. If you
prefer to work without seeing the UI, try Rapid UI mode for a clean screen where you can still access just about
everything, with sliders for resizing and changing brush opacity, and quick access to layers, colors and more.

NOTE: Sketchbook Pro only supports standard two-finger gestures such as pinch-zoom, pan and rotate on
touchscreen-enabled laptops. For customizable shortcuts on Mac and Windows, instead see Hotkey shortcuts.

1-finger gestures

Use your finger and the marking menu to access an assortment of tools. See Marking menus for more information.

Tap-hold for color picker
This setting is on by default, but you can toggle it off in Preferences if you prefer. When enabled, a tap-hold of your
finger or stylus will enable the Color Picker.

2-finger gestures

Rotate the canvas
Use your fingers to freely rotate the canvas. Just twist with two fingers to rotate the content on all layers.

Move the canvas
Use your finger(s) to freely move the canvas. Just drag with two fingers in any direction to move the canvas.

https://sketchbook.knowledgeowl.com/docs/hiding-the-ui-while-you-draw
https://sketchbook.knowledgeowl.com/docs/hotkey-shortcuts
https://sketchbook.knowledgeowl.com/docs/basic-ui-elements
https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook#gestures
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Zooming into and out of the canvas
In the canvas, drag with two fingers and expand to zoom in. Pinch your fingers together to zoom out.

2-finger gestures and the Transform tool

Scaling content
While in the Transform tool, use your fingers for scaling. Select a layer with an image, drag with two fingers and
expand to scale the image up, making it larger. Pinch your fingers together to scale it down, making it smaller.
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While in the Transform tool, use your fingers to freely rotate the image. Just twist with two fingers to rotate the
content on that layer.

Moving content
While in the Transform tool, use your finger(s) to freely move the image. Just drag with two fingers in any direction to
move the image.
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Customizing Tap options

You can customize the action applied to:
two finger double-tap (default is Frame Canvas)
three finger single-tap (default is Undo)
three finger double-tap (default is Full Screen view)

3-finger swipe gestures

In Preferences there are also options for customizing your 3-finger swipe gestures.

These are the default settings:
3-finger swipe left to undo
3-finger swipe right to redo
3-finger swipe up to access the Color Editor
3-finger swipe down to access the Brush Library

To learn how to set your own, see Customizing your UI.

Here are some tips to successfully use the 3-finger gestures:
Have your fingers slightly separated.
Swipe on an angle.

https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook#gestures
https://sketchbook.knowledgeowl.com/docs/undoing-and-redoing#mobile
https://sketchbook.knowledgeowl.com/docs/undoing-and-redoing#mobile
https://sketchbook.knowledgeowl.com/docs/color-editor#mobile
https://sketchbook.knowledgeowl.com/docs/brush-library#mobile
https://sketchbook.knowledgeowl.com/docs/customizing-your-ui#mobile
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Hiding the UI while you draw

If you prefer to have no UI around while you draw, there are a few different ways you can hide the UI in Sketchbook,
depending on which platform you are on.

You can also customize your UI settings to suit your own preferences.

Auto Hide UI

Auto Hide UI  temporarily turns off visibility of the interface during drawing or interaction with UI handles. This
feature is available in both Sketchbook Pro on macOS and Windows, and Sketchbook on iOS and Android.

The amount of time it takes to restore the UI is adjustable, so you can set the amount of delay that best suits your
natural drawing style. The delay range goes from 0.5 seconds to 2 seconds (shown as 0.4 to 2 on mobile, and 1 to
16 on desktop)

To enable Auto Hide UI, tap the  icon in the toolbar. When active, the icon will have a blue highlight. The icon
toggles the feature on and off, so tap it a second time to disable it.

Rapid UI mode

Rapid UI mode is only available in Sketchbook on mobile devices

For mobile users, Rapid UI mode provides a full-screen working environment. You can work with the full screen real
estate, yet still have quick access to tools when you need them

In the toolbar, tap  to enter this mode.

Here is an overview of the UI that will be visible when working in this mode:

https://sketchbook.knowledgeowl.com/docs/customizing-your-ui
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Along the side are the Palette Sliders and the Trigger.

Using Palette Sliders

These change basic brush settings. A readout appears on-screen, indicating the numeric changes. A brush stamp
appears showing the new brush stamp.

To change brush size, or hardness and size (depending on the brush), tap-drag the top slider.
To change brush opacity or flow, tap-drag the bottom slider.

Using the Trigger

This feature has two functions:
To quickly access the Brush, Color, and Layer Editors and their settings, with your non-dominant hand, tap the
Trigger , then drag-hold up or down to select an editor.
To switch the UI from right-handed to left-handed, drag it to the other edge of the screen.

Then with your other hand, tap whatever you want to select it in the editor or tap-drag values to change settings.

Flipping the UI

If you’re left-handed, here’s another reason you’ll love this. You can flip the UI to the other side of the screen – where
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it’s not obscured by your hand.

To flip the position to optimize left-handed usage, drag the 'Trigger' UI handle to the other side.

No matter which hand you draw with, your non-dominant hand can now help. Use it to access the UI, as you continue
drawing. Change brushes, brush settings, colors, color settings, even layers and layer properties, as you draw with
your other hand. Use the radial menu to access other tools.
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Pressure-sensitivity in Sketchbook

Jump to Mobile

Pressure-sensitivity in Sketchbook Pro on desktop

For desktop users, if you are having issues with pressure-sensitivity in Sketchbook Pro, there are a couple things you
can do to troubleshoot.

1. On Windows, make sure Windows Ink is enabled in your tablet or pen driver. Sketchbook Pro will not have
pressure sensitivity with Windows Ink disabled

2. Ensure you have the most up-to-date tablet driver on your display tablet or pen tablet device. If you just did an
OS update and lost pressure sensitivity in Sketchbook Pro, double-check your tablet manufacturer's website to
see if newer drivers are available

3. Check our Troubleshooting pressure sensitivity article
4. In the Sketchbook Pro menu bar, select Edit > Stylus Responsiveness and try making adjustments.

For info on stylus tilt, check this article Setting stylus tilt.

Pressure-sensitivity in Sketchbook for mobile devices

Which pressure-sensitive stylus does Sketchbook support on Android?

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/no-pressure-sensitivity-windows
https://sketchbook.knowledgeowl.com/docs/setting-stylus-tilt


69

For Android users, Sketchbook only officially supports pressure with S-pen (Samsung). Other manufacturer's devices
that also use S-Pen technology may also support pressure.

Which pressure-sensitive stylus does Sketchbook support on iOS?

Sketchbook supports pressure-sensitivity with the Apple Pencil and the Apple Pencil Pro. The Apple Pencil USB-C
does not have pressure sensitivity.

I used to have pressure sensitivity on my iPhone, but now it's gone

Apple had a feature called 3D Touch that was available on iPhone 6S through iPhone XR. 3D Touch enabled pressure
sensitivity when drawing with touch in Sketchbook on those devices. With the iPhone 11, 3D Touch was
discontinued in favor of Haptic Touch. Therefore this kind of pressure sensitivity is not possible on newer iPhones.
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Secondary monitor setup for Mac users

For Mac users with dual monitors and a custom UI layout in Sketchbook Pro, you can set up dual docks and launch
Sketchbook Pro from your secondary monitor.

Here’s how to do this:
1. Select   System Settings > Displays. Tap Arrangement and arrange your two displays. For example, if you

have an iMac on a riser and the secondary monitor physically below it, drag the secondary monitor to reflect
this.

2. Do the following to display a menu bar and dock on both monitors and prevent “spreading” a window or app
between your monitors.

Back out to System Settings and select Desktop and Dock. In the Mission Control section, enable
Displays have separate Spaces. If your dock is at the bottom your display, it will be at the bottom of both
displays.

Setting up your custom UI

1. In your secondary monitor, click the bottom of your screen to access your dock.
2. Tap the Sketchbook Pro icon and launch Sketchbook Pro.
3. Drag the different UI elements, such as the Brush Palette and Color Editor, into position.
4. Quit Sketchbook Pro to save your custom layout.

NOTE: Keep in mind that the custom UI was created on your secondary monitor, so you must launch Sketchbook Pro
from your secondary monitor if you want to retain that layout.
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Changing your view

Jump to Mobile

Changing your view in Sketchbook Pro for desktop

If you are using a stylus, the puck provides a quick way to zoom and move your view.

Press spacebar to show the puck.
Tap-drag the center of the puck to zoom, or the bottom center of the puck to rotate the canvas

 

In the outer ring of the puck, tap-drag to pan the canvas 

 

Navigate with gestures

For touchscreen-equipped devices, gestures can be used for navigation.
With two fingers, drag and expand on the canvas to zoom in, or pinch to zoom out
Twist with two fingers to rotate the content on all layers
Drag with two fingers in any direction to move the canvas

 

Use the View menu

From the menu bar, the View menu includes multiple options for changing your view, including zooming, rotating, and
fitting the canvas to the view.

https://app.knowledgeowl.com/#mobile
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Zoom using a touch strip

Cintiqs and some tablets have a touch strip for zooming. Position your cursor over the area you want to zoom in or
out of. Move your finger along the touch strip in an upward motion to zoom in or a downward motion to zoom out.

Locking maximum zoom

If you want to limit how closely you can zoom in to your work, tap the zoom icon on the main toolbar and adjust the
slider on the sub-toolbar. The default setting is 30, which represents 3000% and is the maximum possible zoom.
Reducing it to 1 will lock maximum zoom to 100%.

View at actual size

For the actual pixel size of an image, in the Lagoon tap  and then choose . Or press the hotkeys Option+Cmd+0
(zero) on Mac, or Alt+Ctrl+0 (zero) on Windows.

Fit an image in the display

To expand or shrink an image to fit the current display, in the Lagoon tap  and then choose . Or use the hotkeys
Cmd+0 (zero) on Mac or Ctrl+0 (zero) on Windows.
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Changing your view in Sketchbook for mobile devices
With two fingers, drag and expand on the canvas to zoom in, or pinch to zoom out
Twist with two fingers to rotate the content on all layers
Drag with two fingers in any direction to move the canvas

To learn more about customizing gestures in Sketchbook, read Gestures.

Viewing the full canvas

Set a corner tool to  Frame Canvas (see Customizing the corner tools) and tap it to display the full canvas.

Split screen view

Sketchbook supports split-screen multi-tasking, using Split View and/or Slide Over.
Split View allows you to see two apps side-by-side. 
Slide Over is a peek-in-peek-out type function that is supported on iPad

Be aware that if you split your view and make Sketchbook's portion of the screen small enough, the UI will switch
from tablet to handheld (phone) mode.

https://sketchbook.knowledgeowl.com/docs/gestures
https://sketchbook.knowledgeowl.com/docs/customizing-your-ui#mobile
https://sketchbook.knowledgeowl.com/docs/basic-ui-elements#tablet
https://sketchbook.knowledgeowl.com/docs/basic-ui-elements#phone


75

What's new in Sketchbook for iOS and Android

Sketchbook 6 is loaded with new features and provides increased flexibility for you to work the way you want to.

What's New

Updated Brush Panel with brush history
Brush Panel is now available on Phone screen sizes
Option to enable/disable Brush Panel in Preferences
Ability to name layers
Ability to add fonts to the text tool
Auto-hide the UI while you draw
Batch export files from the Gallery
Free Symmetry tool
Steady Stroke tool
Customize new canvas size presets
More options for tap and swipe gestures
More options to customize how the UI appears
The ability to back up and restore your Preferences

Get the Premium Bundle

For people who want to take their creativity even further, the Premium Bundle unlocks advanced features for brush
creation, color management, layer management and new export options.

The Premium Bundle is available as an in-app purchase. To get it, go to the canvas menu  > Upgrade to Premium
Import and export brushes
Create brushes with your own custom shapes and textures
Duplicate brushes
Organize brushes and brush sets
Randomize brushes in a set between strokes
Resize your canvas or Image
Set canvas size in inches or centimeters
Set canvas resolution in px/inch or px/cm
Additional color harmonies
Additional custom gradients
Select color from reference images
Extract color palettes from images
Import and export color palettes
Clipping Masks
Layer grouping
Layer masking blend modes
Additional Layer Adjustments:

Blur
Sharpen
Brightness/Contrast
Grayscale

https://sketchbook.knowledgeowl.com/docs/brush-palette
https://sketchbook.knowledgeowl.com/docs/brush-palette
https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook#ui
https://sketchbook.knowledgeowl.com/docs/intro-to-layer-menu#mobile
https://sketchbook.knowledgeowl.com/docs/text#mobile
https://sketchbook.knowledgeowl.com/docs/hiding-the-ui-while-you-draw#auto-hide
https://sketchbook.knowledgeowl.com/docs/exporting-images#mobile
https://sketchbook.knowledgeowl.com/docs/symmetry
https://sketchbook.knowledgeowl.com/docs/steady-and-predictive-stroke#mobile
https://sketchbook.knowledgeowl.com/docs/creating-a-canvas#mobile
https://sketchbook.knowledgeowl.com/docs/gestures#mobile
https://sketchbook.knowledgeowl.com/docs/customizing-your-ui#mobile
https://sketchbook.knowledgeowl.com/docs/backing-up-preferences#data
https://www.sketchbook.com/get-more
https://sketchbook.knowledgeowl.com/docs/importing-brushes#mobile
https://sketchbook.knowledgeowl.com/docs/exporting-brush-sets#mobile
https://sketchbook.knowledgeowl.com/docs/creating-a-texture-brush#mobile
https://sketchbook.knowledgeowl.com/docs/randomizing-brushes#mobile
https://sketchbook.knowledgeowl.com/docs/resizing-your-canvas#mobile
https://sketchbook.knowledgeowl.com/docs/resizing-images#mobile
https://sketchbook.knowledgeowl.com/docs/color-palettes#image-sets-mobile
https://sketchbook.knowledgeowl.com/docs/color-palettes#image-sets-mobile
https://sketchbook.knowledgeowl.com/docs/color-palettes
https://sketchbook.knowledgeowl.com/docs/clipping-masks#mobile
https://sketchbook.knowledgeowl.com/docs/grouping-layers#mobile
https://sketchbook.knowledgeowl.com/docs/mask-blend-modes
https://sketchbook.knowledgeowl.com/docs/making-color-adjustments-to-a-layer
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Invert
Export sketches or entire albums to PDF

https://sketchbook.knowledgeowl.com/docs/exporting-pdf-files
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What's new in Sketchbook Pro for macOS and Windows

Sketchbook Pro 9.0 brings a large number of new features and updates.

Those who have used Sketchbook for a while will be happy to find some of their feature requests included in this
version. We have approached both new and updated workflows with the muscle memory and preferences of
existing users in mind.

Below you can find a list of new and updated features in v9, with links to the updated help documents throughout
this site. 

New features for custom color management

Create custom color palettes and sets of palettes. Any palette can have up to 60 color swatches, there can be
up to 12 palettes in a set, and a maximum of 50 color sets in the Color Library.

Your custom color swatches from the previous version of Sketchbook Pro will migrate to the new Color
Library and can be found a set called "My Colors"

Pick colors or extract entire palettes from reference images. Define how colors are extracted from the image to
a new color palette.

Updates to the Color Editor

Color harmony bar: complementary, split complementary, analogous, triadic, or tetradic
Gradient bar: color gradient presets and custom-defined gradients
Visualize color harmony in the color wheel
HSV sliders
HEX value input
Randomize color: select from HSV, gradient, or active color palette 

New masking and blend modes

Clipping Masks
Versatile layer masking using a layer's alpha channel (transparency)
Isolate mask effects by grouping layers and applying 'Normal' blend mode to the group 

Brush Library updates

Randomize brush set changes brushes after each stroke. This is particularly useful for creating realistic natural
textures such as hair, fur or grass
Additional pre-loaded brush sets 

Tool updates

Free Symmetry tool in the symmetry sub-toolbar. Rotate your line of symmetry to any angle.
The Text Editor now uses the Color Editor for color selection
There is a new option in the Predictive Stroke sub-menu to enable/disable snapping. Disabling snapping will
allow the creation of straight lines that don't snap to 0 / 45 / 90 angles. Snapping is on by default, because in
previous versions it could not be disabled. 

https://sketchbook.knowledgeowl.com/docs/color-palettes
https://sketchbook.knowledgeowl.com/docs/color-palettes
https://sketchbook.knowledgeowl.com/docs/color-palettes#image-sets
https://sketchbook.knowledgeowl.com/docs/color-editor
https://sketchbook.knowledgeowl.com/docs/randomizing-color
https://sketchbook.knowledgeowl.com/docs/clipping-masks
https://sketchbook.knowledgeowl.com/docs/mask-blend-modes
https://sketchbook.knowledgeowl.com/docs/randomizing-brushes
https://sketchbook.knowledgeowl.com/docs/symmetry
https://sketchbook.knowledgeowl.com/docs/text
https://sketchbook.knowledgeowl.com/docs/steady-and-predictive-stroke
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User interface updates

Higher contrast graphics for improved readability
Updated icons for this decade
Auto Hide UI when drawing, with customizable timer for restoring the interface
Menu bar > View changes:

Brush crosshair, outline and stamp, and scroll bar view options have been moved here from Preferences,
so that they can be more dynamically enabled/disabled

Support for common hotkey combinations for zooming in and out has been added
Lagoon view menu (position 1): view states for UI, fullscreen, and Lagoon now toggle to remove duplicate
commands
Layer menu: rename layer no longer supports custom thumbnail workflow. This was retired as part of updates
to improve overall stability
Changing color of the background layer now uses the Color Editor. Note that it is not possible to use the color
picker when changing the background layer. 

Preferences updates

New Preferences options for creating backup files at each save (off by default)
Choose whether new files will default to incremental file names (on by default) or use "Untitled"
Option to verify TIF files after saving, for an extra check that a save completed successfully (off by default)
Disable anti-aliasing with Pixel preview (off by default)
Create or restore a backup of your Preferences

https://sketchbook.knowledgeowl.com/docs/hiding-the-ui-while-you-draw#auto-hide
https://sketchbook.knowledgeowl.com/docs/backing-up-preferences
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Failed to open file error message

When people see this message it is usually because they are working with a very large canvas, and/or are running
out of space or RAM on their device.

It may have been triggered when you added an image to the canvas, or opened a canvas from the Gallery.

Common causes

Low available memory (RAM):

Low available RAM can trigger this message, particularly on mobile devices. The amount of RAM your device has in
its specifications is not the same as the amount of RAM available in the moment. The operating system uses RAM,
as do any other apps running at the same time. The first thing to try is to restart your device. Restarting your device
will stop these process you didn't know were taking up memory and free up more for other actions.

Low available storage (Android or iOS):

The next thing to check would be the open storage on your device. Large canvases with many layers and/or images
imported to them can become very large data files. If your device storage is nearly full, Sketchbook won't be allowed
to open the file. See if you can free up some storage space, but be very careful to not delete your art data files in the
process.

Permissions failure:

We occasionally hear from people who see this message when opening a file from a server, or importing an image
from their Downloads folder or from Google Drive. This failure is caused by Sketchbook not having permission to the
location, so try moving the image you want to import into your Documents folder and see if the import will work
correctly. On AndroidOS, screen mirroring or sharing tools such as Samsung DeX can also cause file permissions
issues - exit the mirroring environment and try again.

Corrupted file:

A "Failed to open file" message can appear when a file you're trying to open has been corrupted. The message may
note that the "file size or type is not supported". Please reach out to our support team for assistance at
support@sketchbook.com. If you are on a mobile device, it will be helpful to send along a screenshot of the file's
information - in the Gallery tap the  icon above the affected piece to open the information window. 

https://sketchbook.knowledgeowl.com/docs/adding-an-image
https://sketchbook.knowledgeowl.com/docs/gallery-in-sketchbook
https://sketchbook.knowledgeowl.com/docs/android-tiff-could-not-be-opened
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If none of these options apply to your situation, please reach out to our support team at support@sketchbook.com.
Include in your message as much detail as possible on the problem, including your device type, version # of the
operating system, and anything you've already tried to fix the issue.
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Missing windows or menus (Mac and Windows)

If you have launched Sketchbook Pro and can't find the layer editor, brush palette, a secondary toolbar, or open the
Brush Library and the window doesn't appear, it is likely that the window has opened offscreen.

Resetting the layout back to default will bring missing windows back into alignment.

Go to the menu bar and choose:

Window> Default Layout

Once everything looks correct, exit Sketchbook Pro completely and restart.

Sketchbook saves your window locations on exit, so exiting and restarting should keep windows where you want
them to appear going forward.
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Unable to log in to webpage error

Some users of older versions of Autodesk Sketchbook on desktop report seeing a message “the webpage cannot be
found” in place of the log in screen they used to see.

Sketchbook spun out of Autodesk as an independent company in 2021, and Autodesk no longer supports these
older versions of the app. It appears that the servers that supported the log in feature were shut down in early May
2024.

The current version of Sketchbook Pro is available on the Windows Store and the Mac App Store as a one-time
purchase (not a subscription). As an independent company we continue to support and update this version of the
app.
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Internet connection error message

If you are using Autodesk SketchBook on Mac or Windows desktop and you go to update or access " Extras", you
might get the following error message:

"Something is wrong with the internet connection; please check your internet connection and try again"

After Autodesk spun out Sketchbook to us, the server that held "Extras" and updates was shut down. The error
message appears because the older Autodesk versions of Sketchbook can't find this server.

You can continue to use your Autodesk SketchBook product for as long as you wish, but no future updates will be
released by Autodesk. If you want to get updates some time in the future you will need to get our version of
Sketchbook from the Mac App Store, or the Windows Store.

As for "Extras", we have made them available to download from this page Free brushes ("Extras").

https://www.sketchbook.com/extras
https://www.sketchbook.com/extras
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Missing time-lapse recording

If you saved a Timed Lapse recording but it does not appear in your Photo Library, one of two things happened:
1. the recording was too large of a file for the available storage space on your device, so it could not be saved
2. you quit Sketchbook before the file had completely saved

Unfortunately it is not possible to recover a Time Lapse video that failed to save.

Please keep in mind that these long recordings can be extremely large files. Most of the failures we hear of are
people who left Time Lapse recording for an hour or more.

It is a best practice to keep your Time Lapse recordings short to avoid issues, and stitch videos together later.
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Premium Bundle troubleshooting

Is the Premium Bundle unlocked?

Before troubleshooting, there are a few easy things to look for to know whether the Premium Bundle is unlocked
already.

On first unlock, the unlocked/new features will be marked with an orange star. The star will disappear after the first
time you tap the feature.

When the Premium Bundle is unlocked, the last item in the main menu will change to say “Purchased”, and the
upgrade window's button will also note the Bundle has been purchased.

If your Premium Bundle purchase is unlocked but you can't find a new feature, please reach out to us at

Star denotes unlocked menu option

"Edit Canvas"

Upgrade window button noting

Premium Bundle is purchased and

unlocked
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support@sketchbook.com for help!

Troubleshooting: the Premium Bundle did not unlock

Android

If your purchase is complete but the bundle is not unlocked, exit Sketchbook and restart the app.

If you have more than one Google Account, it is possible to have downloaded Sketchbook on one account and
purchase the Premium Bundle on a different account. This can cause Google Play to not allow the unlock of the in-
app purchase inside Sketchbook. Log out of the non-purchasing account(s), and fully exit Sketchbook. Relaunch
Sketchbook and see if the Premium Bundle is unlocked. Once it is unlocked, you should be able to log back in to your
secondary Google Accounts.Is the Premium Bundle unlocked?

If you see an error message on the Upgrade window that an internet connection is required
Confirm that you are indeed connected to the internet :)
This message can also appear if Google Play Services has a problem on your device. Open your Settings app
and go to Apps > Google Play > Storage and clear the app cache and then relaunch Sketchbook and try again.
If the purchase is still not available, repeat the steps but clear app data from the Google Play app. Do not clear
the app cache or app data from the Sketchbook app, this will not fix the issue.
If your device or region is blocked from Google Play Services, it will not be possible to purchase the Premium
Bundle

If you receive payment errors or issues with specific payment types, please reach out to Google Play for help:
https://support.google.com/googleplay/answer/1267137

iOS

If your purchase is complete but the bundle is not unlocked, from Sketchbook's main menu tap Preferences, then
scroll to the Factory Defaults section. Next to “In-app Purchase” tap the “Restore” button.

https://support.google.com/googleplay/answer/1267137
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Downloading and reinstalling

Sketchbook is available to download from the Microsoft Store, Mac App Store, Apple App Store, and Google Play.

Can I get Sketchbook directly instead of from one of the Stores?

No, we don't sell or distribute Sketchbook directly. All purchases, downloads, reinstalls and updates are handled
through the Stores.

Do you have a student or Education license?

Because we only distribute Sketchbook through the Stores, we are limited to the available options to provide bulk or
discounted licenses to students and educators.

For Mac, we have opted-in to the Apple School Manager program which provides a 50% discount for classrooms.

Microsoft is retiring the Store for Business and Education. Unfortunately this leaves us without an option for
education licensing on Windows.

There is not currently a student license option available on any of the Stores.

Is networked or enterprise licensing available?

For macOS, if your organization is using the Apple Business Manager program, you should be able to purchase and
deploy Sketchbook from there.

Microsoft is retiring the Store for Business and Education. Unfortunately this leaves us without an option for
education licensing on Windows.

If I uninstall Sketchbook will I lose my art?

While uninstalling an app can sometimes fix issues, it often does more harm than good. If you're
having trouble with Sketchbook, please reach out to us at support@sketchbook.com before

uninstalling and reinstalling the app.

Android - uninstalling and reinstalling will delete your brush customizations, custom color palettes, your preferences,
your Gallery organization, and any unsaved progress on an open canvas. Saved files will not be deleted by an
uninstall/reinstall, you will be prompted to recover your Gallery after restarting the app.

iOS - WARNING! Uninstalling and reinstalling the app will delete everything including all your saved artwork . This
data will not be recoverable without restoring your device from an earlier backup.

Mac - uninstalling and reinstalling will not affect your saved artwork. Your custom brushes, color palettes, and
preferences should still be in place when you reinstall.

Windows - uninstalling and reinstalling will not affect your saved artwork, however it will reset all your preferences to

https://apps.microsoft.com/detail/9npqcdpgj6sz
https://apps.apple.com/us/app/sketchbook-pro/id1570472288
https://apps.apple.com/us/app/autodesk-sketchbook/id883738213
https://play.google.com/store/apps/details?id=com.adsk.sketchbook
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the factory default.

I downloaded Sketchbook and need to reinstall, or install it on another device. What do I do?

You can reinstall by going to your account in the applicable Store and looking at your previous purchases or
downloads - you should see Sketchbook there and can reinstall it.

Each Store allows a user account to download an app (purchased or free) onto up to 10 devices. For Apple devices,
an Apple ID can be connected to up to 10 devices including a maximum of 5 computers.

I have an older version of Autodesk Sketchbook, can I upgrade to the current release?

We are unable to update older versions of Autodesk SketchBook on desktop because the licenses are tied to
Autodesk. These are still great apps though and you can continue to use them for as long as you like, however they
cannot receive updates or bug fixes.

I had an older copy of Autodesk SketchBook and want to reinstall it, what do I do?

Autodesk has discontinued offering Autodesk SketchBook. If you purchased or downloaded Autodesk SketchBook
from the Apple or Microsoft Store, you can reinstall that version by going to your account in the store and looking at
your previous purchases - you should see Autodesk SketchBook there and can reinstall it.

If you received Autodesk SketchBook as a pre-load on your Windows tablet, that version (5.x) was discontinued and
cannot be redownload. Be aware that if your tablet is factory reset, the app will be deleted and cannot be reinstalled.

If you purchased or downloaded directly from Autodesk's website or from a reseller, you can reinstall if you still have
the original download package backed up. There is no access available to discontinued downloads.
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Purchase and download from the Microsoft Store

We occasionally hear from people who have issues completing a purchase or downloading their Sketchbook Pro
purchase from the Microsoft Store.

Some issues may require you to reach out to Microsoft Support as we do not have access to your purchase records
or your account. However we have a few tips that can help solve the most common questions/problems.

The most commonly successful solution is to reset the Microsoft Store app
1. Press Windows key + R. This will open Run. 

Alternatively, you can go to Start and search for "Run"
2. In the Run dialog box, type "wsreset" and hit enter

Additional troubleshooting tips:

Did you make your purchase on a different device than you're installing onto?

Some people have more than one Microsoft account. If you made your purchase on another computer or device than
the one you want to install on, make sure that this additional device is linked to the same Microsoft account that
made the purchase, and is logged in to that account.

You'll also need to make sure that the device you're installing onto is supported by Sketchbook Pro. You can check
the system requirements for Sketchbook Pro.

The Microsoft Store will not allow a purchase of Sketchbook Pro on an unsupported device. If you
aren't able to purchase on your preferred device, check the system requirements.

Do you get a "non-US credit card" error message?

If you get an error or message where the Store will not allow a non-US credit card or PayPal purchase, check to make
sure that your Home Location set in Windows matches the location of your payment method (ie: you may have
Home Location set to US, but be living or traveling elsewhere or using a non-US credit card or PayPal account)

Contact Microsoft Support for expert help

If you continue to have issues after trying these tips, please reach out to Microsoft Support for expert assistance with
the Microsoft Store: https://support.microsoft.com/en-us/account-billing/contact-microsoft-store-support-4f615f2a-
6bbd-fd69-6695-ae213d63eef0.

https://support.microsoft.com/en-us/account-billing/add-a-device-to-your-microsoft-account-5219941b-b577-79c0-756b-a5c12ff3b006
https://sketchbook.knowledgeowl.com/docs/system-requirements-for-sketchbook
https://sketchbook.knowledgeowl.com/docs/system-requirements-for-sketchbook
https://support.microsoft.com/en-us/account-billing/contact-microsoft-store-support-4f615f2a-6bbd-fd69-6695-ae213d63eef0
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Make sure the customer support representative understands that Sketchbook Pro is purchased through the Store,
with Microsoft processing the transaction. Because so many apps are subscription these days, sometimes a rep
will assume this is a subscription issue and send you back to us. Sketchbook Pro is not a subscription, and we do
not have access to your Microsoft Account records.
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Sketchbook Motion

What's the status of Sketchbook Motion?

Sketchbook Motion has been retired by Autodesk and is no longer available. It is not part of the Sketchbook, Inc.
portfolio.
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Crashes on open (Android)

If Sketchbook on your Android device crashes as soon as you open it, there are a couple of possible causes, and
things that you can try to fix it:

1. Free up memory
2. Clear autorecovery data
3. Reset preferences

About uninstalling and reinstalling

While uninstalling/reinstalling the app on AndroidOS will not delete your art files, it is not generally the
best solution for fixing issues with Sketchbook. We recommend you follow the other tips to avoid deleting more
app data than necessary.

Never uninstall/reinstall the app on iOS - you will delete your art files and they cannot be recovered.

Free up memory

If your device is low on memory (RAM), Sketchbook may crash after opening. This problem may become more acute
if you are working on a large canvas or have many layers.

The best way to free up memory is to restart your device, this will close apps running in the background and clear
out temporary processes. You can also free up memory on your device by closing apps that are running in the
background.

If Sketchbook is crashing after you've been using it for hours, that usually indicates your device is running out of
memory. You can also see the article Crashing after long use.

Clear autorecovery data

Any unsaved work left open on your canvas is held in an autorecovery cache - this allows Sketchbook to restore your
work when you return to the app. However if any of this data becomes corrupted, the app will crash as it attempts to
load the bad data. Clearing this autorecovery data will fix this problem, however you will lose any unsaved progress
on your open canvas (data saved to Sketchbook's Gallery is not affected).

Follow these steps to clear autorecovery data:

On Android 11 and higher:
1. Launch your Settings app and go to Apps > Sketchbook.
2. Look for Additional Settings. It can be listed in different places depending on your device and version of

Android - check for "Additional settings in the app", "In-app notification settings", or "Configure in Sketchbook"
3. Find the toggle "Clear Autosave" and toggle it ON
4. Relaunch Sketchbook

https://app.knowledgeowl.com/#memory
https://app.knowledgeowl.com/#autorecovery
https://app.knowledgeowl.com/#preferences
https://sketchbook.knowledgeowl.com/docs/crashing-after-long-use
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After Sketchbook launches, the toggle in Settings will automatically revert to the off position, you do not need to take
further action.

Reset your preferences

Sketchbook loads your preferences - the database that contains your custom brushes, color palettes, and other
settings - as part of the app launch process. So if your Preferences file has become corrupted that can cause the the
app to crash because it cannot complete the launch. Resetting preferences will fix this problem and a new
preferences file will replace the old, corrupted version.

Follow these steps to delete and reset preferences:

On Android 11 and higher:
1. Launch your Settings app and go to Apps > Sketchbook.
2. Look for Additional Settings. It can be listed in different places depending on your device and version of

Android - check for "Additional settings in the app", "In-app notification settings", or "Configure in Sketchbook"
3. Find the toggle "Reset Preferences" and toggle it ON
4. Relaunch Sketchbook

After Sketchbook launches, the toggle in Settings will automatically revert to the off position, you don't need to take
further action.

On Android 10 and older:
1. Go to your Android Files (it may be called My Files or something similar, depending on your device

manufacturer)
2. Tap to go into Internal Storage
3. Tap on Autodesk folder
4. Tap on SketchBook3 folder. Here you will see multiple app folders and all the SketchBook Tiff files
5. Look for the Preferences folder. Tap and hold to show options
6. Tap DELETE
7. Confirm by tapping MOVE TO TRASH

After completing these steps, you can relaunch Sketchbook. The app will generate a new, fresh Preference folder to
replace the one that was removed.
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Android - Missing files in Gallery

There are a few instances where data can become disconnected from the Sketchbook Gallery on Android devices.
The image appears to be in the Gallery, but when tapping to edit or open it, a “Failed to open file” warning
appears
An image you expect to be in the Sketchbook Gallery does not appear

Important Tips for Android Photos and Samsung Gallery app users

Be aware that Sketchbook files will appear in the Android Photos and Samsung Gallery apps, which
search all folders on the Android device for images. Sketchbook thumbnail previews and layered TIFF files will
appear in those apps and can look like duplicates or unwanted files. 

Moving or renaming these files will break the connection with the Sketchbook Gallery, and they will appear to be
missing.

The Samsung Gallery app will allow you to hide a folder if you don't want to see your Sketchbook files. Google
Photos has a similar function.

Do Not add a ".nomedia" file to the folder as a workaround. Doing so will cause Sketchbook's Gallery to not be
able to scan and recover its files.

Failed to open file

This message is displayed when the Sketchbook TIFF (the full layered file) is not found. This happens when  the file
is deleted, moved, or renamed from outside of Sketchbook.

The most common cause of file errors on Android devices is editing or deleting Sketchbook files from
the Android Photo Gallery app.

Sketchbook actually creates two versions of your art - the layered TIFF file that is your work, and a flattened PNG
preview image.

https://app.knowledgeowl.com/#failed-to-open-file
https://app.knowledgeowl.com/#missing-previews
https://www.samsung.com/au/support/mobile-devices/how-do-i-hide-and-unhide-albums-in-my-gallery/
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Most photo gallery apps search for images across device folders and will add Sketchbook’s PNG preview images
and TIFF files to their library.

TIFF files are often displayed with a generic image icon:

Some people have moved, deleted or renamed their Sketchbook files from inside their Android Photo Gallery, not
realizing they were affecting their Sketchbook art files.

How to fix when a TIFF file was moved or deleted

If the TIFF file is moved or deleted from the Android Photo Gallery or from the File Manager, the Sketchbook Gallery
will not be able to locate it.

You must recover the file from the Trash or the folder you moved it to
Bringing the file back into Sketchbook will depend on which version of Sketchbook you are using, and which
version of Android OS your device is on. Please reach out to our support team for help, and be sure to let them
know these details so they can give you the correct instructions.
Note: deleted files on Android are often automatically removed from Trash after 30 days and would become
unrecoverable
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Missing previews in Sketchbook Gallery

If a Sketchbook preview image (PNG) is moved, renamed, or deleted from inside the Android File Manager or Photo
Gallery, the preview cannot appear in your Sketchbook Gallery so it can look like your work is missing or the Gallery is
malfunctioning.

There may be a spinner that continuously searches for the missing file or nothing will appear in that location (blank
spot in your Gallery). You may still be able to tap on the location and open the file.

The next save of that image will generate a new preview image for the Sketchbook Gallery.

This didn't help!

If none of the above tips help solve your problem, please reach out to our support team at support@sketchbook.com.
Including your Sketchbook version, OS version, device type, and as much detail about the problem in your email will
help us help you more quickly!
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Android - TIFF could not be opened

Some Sketchbook users on Android have an issue where an image appears to be in their Sketchbook Gallery, but
when tapping to edit or open it, a warning appears on top of an empty canvas noting that the TIFF could not be
opened.

Sketchbook creates two files for your art - the layered TIFF file that is your art data, and a flattened PNG preview
image that displays in the Sketchbook Gallery. If the preview PNG is present but the TIFF is missing, you will see this
message.

Possible causes for a missing TIFF are
1. you moved files on your device
2. you inadvertently deleted it from your device
3. you renamed the file on your device

One common cause on Android devices is unintentional changes to Sketchbook files from inside the Android Photo
Gallery.

Most photo gallery apps search for images across device folders and will add Sketchbook’s PNG preview images
and TIFF files to their library.

TIFF files are often displayed with a generic image icon:

https://app.knowledgeowl.com/#moved
https://app.knowledgeowl.com/#deleted
https://app.knowledgeowl.com/#renamed
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Some people have unknowingly moved, deleted or renamed their Sketchbook files from inside their Android Photo
Gallery, particularly because they don't recognize the icon or believe it to be a bad file.

Important Tips for Android Photos and Samsung Gallery app users

Be aware that Sketchbook files will appear in the Android Photos and Samsung Gallery apps, which
search all folders on the Android device for images. Sketchbook thumbnail previews and layered TIFF files will
appear in those apps and can look like duplicates or unwanted files. 

Moving or renaming these files will break the connection with the Sketchbook Gallery, and they will appear to be
missing.

The Samsung Gallery app will allow you to hide a folder if you don't want to see your Sketchbook files. Google
Photos has a similar function.

Do Not add a ".nomedia" file to the folder as a workaround. Doing so will cause Sketchbook's Gallery to not be
able to scan and recover its files.

Fixing this issue

If a file was moved

If a TIFF file is moved into another folder on the device, the Sketchbook Gallery will not be able to locate it. Clicking
on the preview in the Sketchbook Gallery will generate the error message because the linked TIFF file is not where
Sketchbook expects it to be.

You can move TIFF files back to the /Pictures/Sketchbook Gallery folder to restore the connection to the
Sketchbook Gallery.

If a file was deleted

If a TIFF file is deleted from the Android Photo Gallery or from the File Manager, clicking on the preview in the
Sketchbook Gallery will generate an error message because the linked TIFF file has been manually deleted.

You must recover the photo from the Photo Gallery Trash

Note: deleted files on Android are often automatically removed from Trash after 30 days and would become
unrecoverable

If a file was renamed

https://www.samsung.com/au/support/mobile-devices/how-do-i-hide-and-unhide-albums-in-my-gallery/
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If you renamed a Sketchbook TIFF file in your Android Photo Gallery, that will break its connection to the Sketchbook
Gallery and the file will appear to be missing from Sketchbook.

In the Android Photo Gallery details of the file you want to restore, check to see if the renamed TIFF remains in the
/Pictures/Sketchbook Gallery folder. If it does, go to Sketchbook > Preferences and use the Gallery Image Recovery
tool.

This will identify any unconnected TIFF files in the folder and restore them to the Sketchbook Gallery in a new folder
called “Recovered”.

Alternatively, you can restore the original name of the TIFF, and therefore the connection to the Sketchbook Gallery.
The original name with be the same as the PNG image with only the differing file extension at the end. This will
restore the connection to the Sketchbook Gallery.

After running the Gallery Image Recovery tool, go to your Sketchbook Gallery and tap on the title to show your
folders. Any recovered images will appear in a new folder called "Recovered".
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Backing up files on Android

Your Sketchbook art files are .tiff files. These files contain the data for your layered art and are stored in the folder
Internal Storage > Pictures > Sketchbook Gallery.

The PNG files you see in the subfolder Sketchbook Previews are thumbnail previews for the Sketchbook Gallery.
They are not your art files and there is no value to Sketchbook in backing them up. If you ever need to restore your
.tiff files in Sketchbook, new previews will be created and these files will be unneeded duplicates.

How to back up your art files on Android

1. Navigate to Files or Internal Storage (this may be called something different depending on your device
manufacturer)

2. Find the folder Pictures
3. Click in to the folder Sketchbook Gallery
4. In this folder you will see a number of files with alphanumeric file names and the extension .tiff. These are your

Sketchbook art files.
5. Copy these files (do not delete, remove, or rename them) to a second location in the cloud or on an SD card.

If you ever need to restore a backup, you can copy these files back to your device and run the Recover Images tool by
going to Sketchbook's main menu, and tapping Preferences. Scroll to the bottom of the screen and tap "Check for
recoverable images".
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Android data migration

Sketchbook version 5.3 and higher include an update to Google's API, this is a requirement for all new and updated
apps.

The new API changes where on your device apps are allowed to open and save files. Because Sketchbook files are
images, they are required to be saved in Pictures. Sketchbook is no longer allowed to save its data to the "Autodesk"
folder, so all your data must be migrated to a new folder in Pictures. 

Watch the video to see how the data migration works:

This change only affects Android 11 and higher
These changes will apply only to devices using Android 11 or later. Devices with earlier versions of
Android or on Chrome OS will not see a change in how files are opened and stored.

The migration process

When you start the migration, you'll be shown your internal storage folders. Tap on the "Autodesk" folder to select it.
Then tap the blue "Use this folder" button at the bottom of the screen.

If you encounter a permissions error when selecting the folder, please check that you have selected the "Autodesk"
folder.

You'll see a prompt asking you to allow Sketchbook access to files in the Autodesk folder. You must select "Allow" to
continue the migration.

If you use desktop mirroring or Samsung DeX mode, disable it before starting the migration. The
migration may not work while the device is mirrored to another display.

The migration will start, the screen will show you the progress % of the the migration and how many sketches have
transferred.

At the end of the migration, your sketches will appear in your Gallery.

If you have a large Gallery, this migration will take extra time

As an example, a large Sketchbook Gallery of 9GB may take 30 minutes to migrate. Duration of the migration will
also depend on the device specifics. Please do not force-stop the migration once it has started, as we cannot
guarantee that your data will be safe if you do this.

Your browser does not support HTML5 video.
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You can back up your data prior to the migration

We have rigorously tested this process, but if you are concerned about the safety of your data it is always a good
idea to have a backup. Information on how to backup your files can be found in this article: Backing up files.

Known issues

Devices that are managed by Google Family Link may fail to start the migration due to the additional restrictions on
the account. Data can be manually migrated, please reach out to our team at support@sketchbook.com for help.

Devices in Samsung DeX mode may fail to start the migration. Exiting from DeX mode should enable the migration
to progress.

If you have any questions or problems with the migration, please email support@sketchbook.com. Screenshots of
any error messages you get will help us help you more quickly!

https://sketchbook.knowledgeowl.com/docs/backing-up-files-on-android
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Glitched line through artwork

Some Android users have experienced a glitched line through their Sketchbook canvas. It may appear vertically,
horizontally, or both.

This glitch occurs on devices with a PowerVR GE8320 GPU.

The cause is how the GPU handles certain graphics shader code.

The glitched area is a display artifact and will not export as long as it is not selected and transformed. Once selected
and transformed, the glitch renders on the canvas and becomes part of the artwork.

We are investigating to see if anything can be done to avoid this issue. If you would like an update on this issue,
please email us at support@sketchbook.com.



104

�

Improving performance

When working on a particularly large file, there are a few things you can do to improve performance and take
additional burden off of your machine or device. See the suggestions below.

If the device or machine you're using is low on available memory (RAM), Sketchbook will be impacted
and may start to show performance issues particularly on large canvases or memory-intensive
processes such as Predictive Stroke or Steady Stroke, or a long Time Lapse recording. As a first step

we recommend you try freeing up memory by restarting your device.

Improving performance on Sketchbook Pro for desktop

Besides freeing up RAM, adjusting your preferences in Sketchbook Pro is where you can benefit the most.

The first thing we always recommend is to turn off Enable Rotate Canvas. When working with an extremely large
canvas, you can experience slower performance when this setting is enabled. Turning this option off can make a
huge difference. See Preferences for instructions on how to do this.

Another preference to turn off to improve performance is Display brush stamp, which displays the stamp of your
brush while drawing and is another thing that needs to be rendered while you draw. You can also experience a lag in
performance when using large brushes. Brush Stamp is enabled/disabled from the menu bar in the View menu.

Two last things you could do would be to reduce the maximum number of undos. 

If you are experiencing issues with Sketchbook Pro freezing or crashing on a secondary monitor, please read this
article.

Improving performance on Sketchbook for mobile devices

Your preferences are where you can benefit the most. The first thing we always recommend is to look at your canvas
size and layer usage. If you don't need to be working with an extremely large canvas with a lot of layers, select a
smaller canvas size. Since a larger canvas and layers can take its toll on your device's memory reserves, this can
greatly improve performance. If you really need to be working on a large canvas, try restarting your device to free up
RAM that was in use in the background, to make more available to working with this file.

The other thing you can do is turn off Rotate Canvas. When working with an extremely large canvas, you can
experience slower performance when this is enabled. Turn this option off can make a difference. See Preferences for
instructions on how to do this.

https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook#general
https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook#general
https://sketchbook.knowledgeowl.com/docs/freeze-on-launch
https://sketchbook.knowledgeowl.com/docs/creating-a-canvas#mobile
https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook#mobile
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Freeze on launch (Windows PC)

Some users have reported issues with Sketchbook Pro freezing, in particular when on a secondary monitor or a
display tablet such as a Wacom Cintiq.

The most common cause of this is audio drivers by Nahimic which are known to produce this issue with Sketchbook
Pro and other apps.

These services are bundled on some Windows computers so may be present without you actively being aware of it.
Check your Task Manager to see if "Nahimic Service" is installed
If it is, and is not a service you actively use, you can disable it in Task Manager
More helpful info here:
https://techcommunity.microsoft.com/t5/windows-10/nahimic-service-issue/m-p/2636587

The other known cause is a corrupted Wacom driver file. Since this driver is loaded on launch of Sketchbook Pro,
this issue can cause a freeze or crash on startup.

To repair it, you will need to uninstall and reinstall your Wacom driver, taking an extra step to delete a few files that
can get left behind after an uninstall.

Wacom has an article about fixing these issues here: https://support.wacom.com/hc/en-
us/articles/1500011495022-How-do-I-uninstall-manually-and-re-install-the-Wacom-driver-on-Windows-for-a-Pen-
Tablet-Pen-Display-or-Pen-Computer-

The key is that after an uninstall, on step 5 you need to look for that list of files that could be left behind (in our
experience the corrupted file is usually wacommt.dll) and remove them per the instructions before reinstalling
otherwise the problem will persist.

If you continue to have trouble, please reach out to support@sketchbook.com for more assistance and
troubleshooting.

https://techcommunity.microsoft.com/t5/windows-10/nahimic-service-issue/m-p/2636587
https://techcommunity.microsoft.com/t5/windows-10/nahimic-service-issue/m-p/2636587
https://support.wacom.com/hc/en-us/articles/1500011495022-How-do-I-uninstall-manually-and-re-install-the-Wacom-driver-on-Windows-for-a-Pen-Tablet-Pen-Display-or-Pen-Computer
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Crashing after long use

If you have been using Sketchbook for hours and it crashes, your device may be running out of memory.

If you're thinking "no my device has tons of memory", you might need to look a bit closer. The amount of memory
(RAM) your device has in its specifications is not the same as the amount of memory available at the moment.

Many devices will pull from storage to support more RAM so devices with too many apps, videos, music, and/or
images saved to them will more quickly run out of usable memory. Apps running in the background also use
memory.

We recommend closing unnecessary background apps. You should find Sketchbook - and your other apps - running
better.

As for working for hours, save your work, and often!

Working for hours really puts a strain on your device. Performance will start to degrade as a result.

If you are noticing glitches, use save current sketch as a copy. Glitches usually indicate that your device is running
low on usable memory, so first save your work, then try to free up usable memory.

If Sketchbook is crashing immediately after launch, that indicates a different problem. Check out the
article Sketchbook crashing on open

https://sketchbook.knowledgeowl.com/docs/saving-files
https://sketchbook.knowledgeowl.com/docs/crashes-on-open
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No pressure sensitivity (Windows)

If you just installed Sketchbook Pro or just got a new drawing tablet and are not getting pressure sensitivity or have
issues with pen pressure registering correctly in Sketchbook Pro:

1. Make sure Windows Ink is enabled on your PC, and also in your tablet's driver. 
Sketchbook Pro on Windows requires Windows Ink for pressure sensitivity.

2. If Windows Ink is enabled but you still have no pressure sensitivity
launch Sketchbook Pro and go to Edit > Preferences.
Tap the Brush tab, and in the Tablet API section change the radio button from Windows Pointer to Wintab
Restart Sketchbook Pro and check to see if pressure sensitivity works correctly

If you're still having issues after trying the above steps, please reach out to us at support@sketchbook.com for
further help.

It will speed up the help process if you can let us know your PC make/model, your peripheral drawing tablet
make/model, the tablet's driver version, and any steps you've already tried.

Additional troubleshooting steps for Huion device owners

If the above steps don't work and you are using a Huion device, it could be because your system was originally set
up with a different Wintab library that doesn't work with your current tablet (such as if Wintab was installed on your
system with a previous Wacom driver).

To repair, follow these steps in the HuionTablet App:
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Open HuionTablet app and click Settings > "About" tab, then "Software Diagnosis."

In the pop-up window, click "Repair" beside the "Wintab32" protocol. The Wintab32 protocol should have the same
values as in the screenshot below:
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NOTE: If you have a 2-in-1 touchscreen laptop that requires Windows Ink, this will unfortunately not work for both the
Huion tablet and your laptop touchscreen.
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Cursor offset issues

There are a few scenarios of cursor offset that can present slightly differently:
1. With active display tablets such as Wacom One: the Pen nib is not aligned with the position of the crosshair

cursor
2. With pen tablet peripheral (a tablet without a built-in display): the cursor on screen is accelerating and behaving

erratically compared to the pen movements on the tablet.  
3. On Windows tablets or hardware connected to a tablet peripheral: the crosshairs are offset from the brush

preview/paint stroke.

Pen position not lining up with crosshair cursor on active display

When Sketchbook Pro’s crosshair cursor is not aligned with the position of your pen on an active tablet, this is
usually the result of a calibration issue.

Check you have the proper (and latest) drivers installed from your tablet manufacturer. Your tablet should include
utilities or set up tools to help configure your tablet. Look for settings or options for calibrating the pen and tablet.

Calibrating Wacom Cintiq or Wacom One
Ensure you have the latest Wacom driver installed
Open Wacom Tablet Properties

On Mac, System Preferences > Wacom Tablet
On Windows, Start > Wacom Tablet Properties

Click the Calibrate tab
Press the Calibrate button and follow the instructions
Click OK when done
Check if pen is aligned with Sketchbook Pro cursor
If offset persists, consult Wacom Product Support online

Cursor on screen is accelerating and behaving erratically compared to the pen movements on tablet

When there is a noticeable discrepancy between pen movements on a tablet compared with what you see on screen,
this is likely due to the tablet not properly mapping to the display running Sketchbook Pro.

Calibrating Wacom Intuos or Wacom Bamboo

Ensure you have the latest Wacom driver installed
Open Wacom Tablet Properties

On Mac, System Preferences > Wacom Tablet
On Windows, Start > Wacom Tablet Properties

Select the Mapping tab
Orientation ExpressKeys Left
Mode Pen
Screen Area Full

https://app.knowledgeowl.com/#crosshair-position
https://app.knowledgeowl.com/#cursor-erratic
https://app.knowledgeowl.com/#offset-stroke
https://www.wacom.com/en-us/support/product-support
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Force Proportions check
This ensures you are drawing proportionally. For example, with Force Proportion NOT enabled, your
circles could appear as ellipses.

Tablet Area Full
Check if pen is aligned with Sketchbook Pro cursor
If issues persists, consult Wacom Product Support online

Refreshing your Wacom drivers

If you are experiencing issues that could be the result of older Wacom drivers or prior tablet settings, go to Wacom
Product Support online to find out how to uninstall and clear your system before downloading and installing the
latest Wacom drivers.

The crosshairs are offset from the paint stroke

This is a graphics-related issue that occurs on some Windows 10 and 11 hardware that is observed as a consistent
diagonal offset from the cursor crosshair and the brush preview/paint position.

There are two known possible causes: 
1. Canvas scroll bars
2. Windows Taskbar related

Please view the troubleshooting and workaround tips below.  If you are experiencing a different kind of offset issue,
please contact us at support@sketchbook.com 

Canvas scroll bars

This is a known OpenGL graphics issue that affects some Windows devices, typically laptops or tablets with high DPI
displays.

Scroll bars are not on by default in Sketchbook Pro, but they can be manually enabled in the View menu. The offset
occurs when zoomed into a canvas and the scroll bars appear.

Workarounds:
Disabling Canvas Scroll Bars is the best way to avoid this offset issue on affected hardware.
The offset can be temporarily corrected by manually resizing the canvas window, but will reoccur as the

https://www.wacom.com/en-us/support/product-support
https://www.wacom.com/en-us/support/product-support
https://app.knowledgeowl.com/#scrollbars
https://app.knowledgeowl.com/#taskbar
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scrollbars appear and disappear.
Alternatively, disabling Rotate Canvas in the Preferences and restarting bypasses the use of OpenGL in
Sketchbook Pro and avoids offset issues.

Taskbar auto-hide

This is an OpenGL graphic issue that occurs on some Windows-based hardware when the Windows Taskbar has
been customized to either auto-hide, or is set to not-visible on a secondary display running Sketchbook Pro.

Troubleshooting:
Disable auto-hide in settings under Taskbar Behaviors
If using a multi-display setup, enable Taskbar to be visible on extended displays
Disable Rotate Canvas in the Preferences and restarting the app will change the graphics used by Sketchbook
Pro and will avoid this offset issue
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iskn Repaper and Sketchbook Pro

The iskn Repaper pen & paper graphics tablet should be detected automatically as a graphics tablet by Sketchbook
Pro.

Simply connect the Repaper tablet to the dedicated Repaper Studio App on your PC or Mac and leave the app open in
the background while drawing with Sketchbook Pro.

If you’d like to adjust the Repaper’s pressure sensitivity in Sketchbook Pro, you have two options to do so:
1. Click on “Edit > Stylus Responsiveness…” in Sketchbook Pro to set the pressure sensitivity
2. Create a new brush in Sketchbook Pro and set its size, opacity and flow with light and heavy pressure. For

creating a new brush, open the brush library on the top of the brush menu. Tap-hold on the dotted circle icon for
selecting a “New brush”

Please note that it is not possible to use the mobile Sketchbook app (Android/iOS) along with Repaper.
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Tap-hold to move brushes stops working

This issue is known to happen with Wacom styluses.

After opening of some dialog boxes, the Brush Library and Brush Palette no longer seem to register the tap-hold to
activate moving brushes.

The tap hold and move will scroll the window, but the brush does not ‘pop out’ to be moved around.

This can happen after use of some brush commands from marking menu:
New Brush
Import Brush Set
Delete brush

The workaround

When this happens, the quickest means to restore the proper behavior is to tap on the marking menu icon and make
a slight gesture. Upon doing this action, tap-hold using the Wacom stylus will be re-enabled.

Alternatively, behavior is restored with:
a mouse click and hold
minimizing and maximizing Sketchbook Pro
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Re-calibrating your stylus

Before re-calibrating your stylus, ensure you've downloaded and installed the latest Wacom driver.

Cintiq calibration

For Cintiq tablet users - calibrating your Cintiq calibrates your stylus.

Windows

1. Select Start > Control Panel, then type Wacom Tablet Properties in the search to access the Wacom Tablet
Properties window.

2. Click the Calibrate tab.
3. From the Monitor pull down menu, select Cintiq. This specific type of Cintiq will be listed and select that.
4. Press the Calibrate button and click the center of the cross hair that appears with your stylus. Another

crosshair will appear in the lower right corner after clicking the first. Click its center.
5. Click OK if satisfied with the results.

Mac

1. Select    > System Preferences.
2. Select Calibration.
3. From the Monitor pull down menu, select Cintiq. This specific type of Cintiq will be listed and select that.
4. Press the Calibrate button and click the center of the cross hair that appears with your stylus. Another

crosshair will appear in the lower right corner after clicking the first. Click its center.
5. Click OK if satisfied with the results and close the Wacom Tablet window.

If for any reason the tip of the stylus does not line up, consult Wacom Product Support Online.

Intuos and Bamboo tablet setup

1. Select Start > Control Panel > Wacom Tablet Properties to access the Wacom Tablet Properties window.
2. Select the Mapping tab.
3. Set the following options:

Orientation ExpressKeys Left
Mode Pen
Screen Area Full
Force Proportions check
Tablet Area Full

The most important option to have set is Force Proportion. This ensures you are drawing proportionally. For
example, with Force Proportion NOT enabled, when you try to draw a circle, it could appear as an ellipse. If for any
reason the stylus does not track properly, consult Wacom Product Support Online.

https://www.wacom.com/en-us/support/product-support/drivers
https://www.wacom.com/en-us/support/product-support
https://www.wacom.com/en-us/support/product-support
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Connecting styluses for mobile users

Supported pen devices on Android and iOS

Android

Sketchbook on Android supports the Samsung S Pen. There is no special set up required and the S Pen will give you
true pressure-sensitivity. S Pen settings can be customized in your Android Settings.

Pen Mode options are available from the main Sketchbook menu.

When on, Pen Mode will only recognize the S Pen for drawing on the canvas. Touch inputs will be ignored for
drawing.
Enable Multi-touch Gestures enables touch on the canvas for gestures only. Disabling this will prevent multi-
touch input, including 2- and 3-finger interactions.
Tap-hold to activate color picker when active, a tap-hold with the stylus will enable the color picker.

iOS

Sketchbook only supports Apple Pencil and Apple Pencil Pro on enabled iPad and iPad Pro models.
Barrel roll and squeeze are supported with Apple Pencil Pro
Hover is supported with Apple Pencil 2 and Apple Pencil Pro
Double-tap options for Apple Pencil 2 and Apple Pencil Pro are supported and can be enabled from iOS
Settings
Scribble for input of text is supported and can be enabled from iOS Settings.

https://app.knowledgeowl.com/#android
https://app.knowledgeowl.com/#ios
https://sketchbook.knowledgeowl.com/docs/using-the-color-picker
https://app.knowledgeowl.com/#squeeze
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How to connect Apple Pencil to your iPad

Sketchbook will automatically work with Apple Pencil without needing to be paired. You can enable additional stylus
settings for Apple Pencil from Preferences.

In the Pen Connection section of Preferences you will see additional options after you select Apple Pencil.

Tap-hold to activate color picker when active, a tap-hold with the stylus will enable the color picker.
When toggled on, Pen Mode will only recognize Apple Pencil for drawing on the canvas. Touch inputs will be
ignored for drawing.
Enable Multi-touch Gestures enables touch on the canvas for gestures only. Disabling this will prevent multi-
touch input, including 2- and 3-finger interactions.
Brush Stamp will show the current brush stamp preview hover on Apple Pencil and Apple Pencil Pro hardware.
The stamp preview will be at the minimum pressure size on hover.

Squeeze Tool Palette with Apple Pencil Pro

Sketchbook supports the squeeze Tool Palette with Apple Pencil Pro. To enable, open the Settings app and in the
Apple Pencil Settings set the squeeze action to "Show Tool Palette".

The Tool Palette in Sketchbook provides quick access to your color history and brush history. Your last six brushes
and colors will appear in the palette. Tap the blue center clutch to switch between brushes and colors.

https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook#pen
https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook#pen
https://sketchbook.knowledgeowl.com/docs/using-the-color-picker
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Legacy Stylus Devices

Sketchbook no longer actively supports 3rd party styluses. The interface to pair these older input devices is still
available in the Pen Connection options, however we are no longer able to verify their operation.
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Diagonal strokes are wobbly

Are your diagonal strokes not smooth?

This is a known issue with some Windows tablets and Android devices, and is not specific to Sketchbook. It is
caused by how the sensors in the display are reading finger or pen input on angled movements. Slower strokes will
create the wobble more so than fast strokes.

Workarounds
1. Use faster gestures when drawing on angles, to reduce the effect
2. Use Predictive Stroke or Steady Stroke. These features will re-render your strokes and can smooth out the

wobble. However both are a post-stroke computation by the app, so using them can introduce lag on longer
strokes. Predictive Stroke is designed to detect the user’s intent to create straight lines, rectangles, triangles
and ellipses, which may also occasionally produce results that are not intended.

https://sketchbook.knowledgeowl.com/docs/steady-and-predictive-stroke
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Can I bring Photoshop art into Sketchbook?

Yes! Sketchbook supports import and export of PSD files on all platforms - Android, iOS, Mac and Windows. Layers,
layer groups, layer names, and most blend modes will be preserved.

There are a few limitations when exporting or saving a Sketchbook file to the PSD file format.
Text layers will be rasterized and no longer editable by a text editor
Glow blend modes (Glow and Soft Glow), and Alpha Mask/Inverse Alpha Mask which are specific to
Sketchbook will revert to Normal
Background layer color will revert to white if it has been changed to another color. The background color layer
is dropped to avoid a conflict with the background layer of a native PSD file.

The native file format of Sketchbook and Sketchbook Pro is TIFF. If the above features are necessary to preserve,
you should save your file as TIFF.

https://sketchbook.knowledgeowl.com/docs/blending-layers
https://sketchbook.knowledgeowl.com/docs/mask-blend-modes
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Android: Transferring images from one device to another

For Android users who just got a new device, you may need to transfer images from the old device to the new one.
1. On your older device open the My Files app 

If the device is on Android 11 or later, navigate to Internal Storage > Pictures > Sketchbook Gallery 
If your older device is on Android 10 or earlier, navigate to the folder Internal Storage > Autodesk >
SketchBook3 
All your images are saved as TIFF files within that folder. They will have long, alphanumeric filenames. 
Copy all these TIFF files to a cloud drive or SD card that you can use to move them to the new device 

Warning: Do not copy any of the other files or folders, only copy the TIFF files. These are your
Sketchbook art data files. Copying any other files or folders to the new device could cause
serious issues with the app.

2. Install Sketchbook on the new device. You must launch the app at least once so that it creates the correct
folders for you to copy your files into. It won't work if you create the folders yourself.

3. Navigate to Internal Storage > Pictures > Sketchbook Gallery and copy the files from your SD card or cloud drive
to this location

4. Open Sketchbook 
-Tap the Menu   
-Tap Preferences
-Tap "Check for Recoverable Images"

This should bring your files back into Sketchbook's Gallery in a folder called "Recovered". You can then organize your
files however you like in your Gallery.

You can also make a backup of your Preferences!

Your Preferences are all your custom brush settings, color palettes, and UI customizations. To transfer these over to
your new device, go to Sketchbook's main menu and tap Preferences. Scroll down to the Sketchbook Data section
and tap on "Export Preferences". Save that file to a cloud drive you can access on the other device, then repeat the
process on the new device but tap "Import Preferences".

https://sketchbook.knowledgeowl.com/docs/backing-up-preferences#mobile
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Art is blurry or doesn't scale when printed

Your image resolution may simply be too low. The recommended image resolution for printing is 300 dpi.

In Sketchbook Pro on desktop you can adjust your dpi in the Image > Image Size menu.

In Sketchbook on mobile devices, dpi can be set in the Edit Canvas menu, which is unlocked with the Premium
Bundle. 

If you do not have the Premium Bundle unlocked, your file will export with a default 72dpi. There are free online
image editors that can set dpi for an image but you will want to set up the canvas for the correct pixel dimensions
when you start. For more information, see setting the maximum canvas size for printing.

https://sketchbook.knowledgeowl.com/docs/resizing-images#mobile
https://www.sketchbook.com/get-more
https://sketchbook.knowledgeowl.com/docs/setting-the-maximum-canvas-size-for-printing
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Accessing files saved to iCloud

If you have an older version of Sketchbook on iOS from Autodesk and had saved your files to iCloud Drive, when you
update you will no longer see these files in your Gallery.

Don't panic! Your files are still available in your iCloud Drive.

The Sketchbook app for iOS was transferred from Autodesk’s developer account to the Sketchbook, Inc. account as
part of Sketchbook’s spin out. One result of this transfer is that we are no longer able to directly connect the
Sketchbook Gallery with the previous SketchBook folder on iCloud. Though your account stays the same and your
data is still there, the connection between the app and the account is tied to the developer. Since we're a different
developer, the connection was broken.

We can no longer directly populate the Gallery with those files, but we have introduced new workflows using the iOS
native File browser that will provide open and save access to this data.

To access files previously saved to iCloud:

1. Tap  , then  Import from Files
2. If the canvas you were working on had not been saved, you will see a "Sketch Updated" prompt. You can save

your canvas to the Gallery, save to the Gallery as a copy, or choose not to save
3. The native iOS Files browser will come up
4. Browse to iCloud Drive
5. Locate the SketchBook folder
6. Select the file you wish to bring into Sketchbook

Via the web/desktop:

go to https://www.icloud.com/iclouddrive/ and look for the SketchBook folder. Your saved work is there.

On your iPhone or iPad, tapping on this link might give you an error "Item unavailable - the owner stopped sharing".
You'll need to long-press to pop-up the browser sheet, where you should see your iCloud Drive files.

If you are having trouble finding or opening your saved iCloud files, please email us at support@sketchbook.com so
we can help.

https://www.icloud.com/iclouddrive/
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Why do I have to allow Sketchbook access my photos, media, and
files?

When you download Sketchbook, a dialog appears asking to allow access to your photos, media, and files. We get
people asking why we need access to these a lot, and for good reason. Who wants to give access to content on their
phone?

Here's what we are accessing and why:
Photos - When you want to use images from your device for importing images, the app needs to access your
photos to import them into the app.
Media - When you want to use the Scan sketches tool, the app needs to access to your camera to take a picture
of what you want scanned.
Files - When you save or retrieve your sketches or other images from your device, the app needs to access your
files to locate the image or be able to navigate your file structure to save the image where you want.

Sketchbook does not have a server connection. We do not have remote access to any of your files or data.

We hope this helps to explain why we do this and puts you a bit more at ease.

https://sketchbook.knowledgeowl.com/docs/importing-images#mobile
https://sketchbook.knowledgeowl.com/docs/scanning-sketches
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Maximum layers and canvas size on mobile

The number of layers you can have in a file is determined by your device’s specifications, version of
the operating system, and available memory. 

NOTE: memory (RAM) and storage are different factors. Storage is the space available on the device to save files.
Memory is the processing power that the device has.

Available memory is reduced when multiple apps are running at the same time. The operating system also uses
memory. A device with 8GB of RAM is will not (and cannot) make all that memory available to Sketchbook.

When working with large canvases it is a good idea to reduce the number of other apps running in the background.

For better performance and more available layers, do not create bigger canvases than you really need. A smaller
canvas will increase the number of layers available, due to the reduced demands placed on your device.
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Is Sketchbook available in other languages?

Sketchbook is available in 11 languages: English, Chinese (simplified), Chinese (traditional Taiwan), Chinese
(traditional HK), Japanese, Korean, French, German, Italian, Spanish, Portuguese, and Russian.

On desktop, you can change your language settings in the app’s preferences.

On mobile, you will need to change the language settings on your device.

https://sketchbook.knowledgeowl.com/docs/languages
https://sketchbook.knowledgeowl.com/docs/languages#mobile
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Do I need to sign in or create an account?

Do I need to sign in or create an account?

No.

If you are using a version of Sketchbook is asking you to sign in or create an account, you should upgrade to the
latest version. You will no longer be asked to sign in.
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Where is the Copic color palette?

If you were using a version of Sketchbook developed by Autodesk, you might have known and loved the Copic color
palette.

Using the Copic brand and color system was done under an agreement between Autodesk and Too Corporation (the
makers of Copic markers).

Sketchbook, Inc. is not authorized to distribute this feature, so we had to remove it.
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Changing language settings

Sketchbook and Sketchbook Pro are available in the following languages: English, Simplified Chinese, Traditional
Chinese, French, German, Italian, Japanese, Korean, Brazilian Portuguese, Russian and Spanish.

Changing Sketchbook's interface language on SketchBook Pro on desktop

If your device is set to a language that Sketchbook Pro does not support, the app will default to English. You can set
a different language for Sketchbook Pro if you prefer.

On Windows you can change the language of Sketchbook Pro's UI in Preferences.
1. In the first tab (General) of the window, select the Language option. There's a dropdown menu with the

language choices.
2. Select the language you want.
3. Tap OK.

A restart of Sketchbook Pro is required for this change to take effect. Close Sketchbook Pro, then relaunch it.
The language changes will now be visible.

On macOS language preferences are defined in macOS System Preferences. You can set app-specific languages in
the Language and Region dialog.

Changing the interface language for Sketchbook on mobile devices

On mobile, Sketchbook takes its language settings from the global settings of the device. If your device is set to a
language that Sketchbook does not support, the app will default to English.

If you prefer another of Sketchbook's supported languages, adding that language as a secondary language to your
device global settings will allow Sketchbook to default to your preferred supported language.

https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook#general
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System Requirements

Jump to the system requirements for your platform:
Windows
macOS
Android
iOS

Sketchbook Pro (Windows v9.2.19)
x64 or ARM-based hardware
Windows 10 and Windows 11
2.5 GHz or greater processor
8GB of Memory

Large images with high layer counts require greater memory capacity
GPU with OpenGL 2.0 support

See note below re: GPUs that do not support Sketchbook Pro full functionality
Sketchbook Pro works with both touch and pen-based input
Windows Ink must be enabled for pressure sensitivity with a stylus

PCs with these older GPUs may not fully support all Sketchbook Pro features:
- 3rd and 4th generation Graphics Media Accelerators
- PowerVR edition Graphics Media Accelerators
- 1st and 2nd generation Intel HD Graphics

Surface Pro X may have some limitations -see this article

Sketchbook Pro (Mac AppStore v9.2.14)
MacOS 12 (Monterey) and above
Apple Silicon or min 2.4 GHz Intel
8GB of Memory

Large images with high layer counts require greater memory capacity
GPU with OpenGL 2.0 support
Recommended for displays with 1290x768 or higher
Sketchbook Pro is optimized for pen-based input

Pressure-sensitive pen tablet peripheral or pen display tablet

Sketchbook for Android (v6.2)
Android OS 9 and higher

https://app.knowledgeowl.com/#windows
https://app.knowledgeowl.com/#macos
https://app.knowledgeowl.com/#android
https://app.knowledgeowl.com/#ios
https://sketchbook.knowledgeowl.com/docs/surface-pro-x-limitations
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Optimized for phones and tablets
Supported styluses for pressure-sensitive input

Samsung S Pen
peripheral drawing tablets are not supported

Some functions of Sketchbook, including those related to opening, saving, and recovering files, may not be
supported when mirrored to an external monitor or device.

ChromeOS

Most Chromebooks and ChromeOS tablets are also running AndroidOS and can install Sketchbook from the Google
Play Store. User experience and functional performance will vary based on device specifications.

Your version of AndroidOS is separate from your ChromeOS version. Your Chromebook can be fully updated
and still running a lower version of AndroidOS.
Many Chromebooks do not have the drivers to support pressure-sensitive pen input. Pen-enabled ChromeOS
tablets are more likely to provide the pressure sensitivity support.
Not all manufacturers use pen technology that is compatible with enabling pressure sensitivity with
Sketchbook

Sketchbook for iOS (v6.2)
iOS 13.0 and higher
Sketchbook supports Apple Pencil and Apple Pencil Pro on enabled iPad and iPad Pro models
Hover is supported on 4th generation iPad Pro with Apple Pencil 2
Barrel roll and squeeze require Apple Pencil Pro and iOS 17.5 or higher

Language support

Sketchbook and Sketchbook Pro are localized in the following languages:
English
Chinese (Simplified)
Chinese (Traditional)
French
German
Italian
Japanese
Korean
Portuguese (Brazilian)
Russian
Spanish

On iOS and Android, localization will follow the region and languages from your device settings. If your device
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language is not one Sketchbook supports, Sketchbook will default to English or adopt a supported secondary
language preference.

On Windows, Sketchbook Pro localization can be set independently to OS language settings from inside the app at
Menu > Edit > Preferences > General and choosing from the Language drop-down. The selected language is applied
after restarting Sketchbook Pro.

On macOS, Language & Region settings in System Preferences can be customized on the App level.
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ARM processors (Windows)

Sketchbook Pro version 9.2 and higher runs natively on Windows PCs with ARM processors.

Sketchbook Pro has been updated to run natively on ARM and is fully supported on devices such as the Surface Pro
with Snapdragon chip.

Using a peripheral tablet with Sketchbook Pro and an ARM device

When connecting 3rd party pen tablets to your ARM-based hardware, make sure that tablet manufacturer provides
ARM drivers.
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Surface Pro X limitations

Sketchbook Pro will run on this device, but there are known limitations due to the hardware configuration.

Rotate Canvas may not be natively supported on this device.

When launching Sketchbook Pro on this device, Sketchbook may display a warning message: “The video driver may
not be installed correctly, canvas rotate is not supported”

Once dismissed, Sketchbook Pro will launch.

The message will appear each time the app is launched unless you go into Sketchbook Pro Preferences and disable
the Rotate Canvas feature.

If you have installed the Microsoft OpenCL, Open GL and Vulcan Compatibility Pack on your Surface Pro X , these
drivers will allow rotate canvas in Sketchbook Pro, but causes graphic artifacts when the main window is
maximized. This can be avoided by disabling rotate canvas or ensuring the main window is not maximized.
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Brushes in Sketchbook

There are a huge assortment of brushes in Sketchbook, some pressure-sensitive, others with textures, glow brushes,
splatter, and much more.

Sketchbook "brushes" include not only actual brushes, but also erasers, markers, pens, and pencils.

All versions of Sketchbook and Sketchbook Pro come with hundreds of brushes by default, you can find them in the
Brush Palette along the left side of the screen. If you have a smaller handheld device (ie: phone), your brushes will be
in the Brushes menu  .

When editing brushes, use Brush Properties, the Brush Puck, or Double Puck, or Brush Property sliders found along
the side of the Brush Palette.

More brush topics:
Free brushes ("Extras")
Introduction to Brush Properties
What are Brush Types
Customizing brushes
Swapping between brushes
Blending Brushes
Loading brushes
Resizing brushes

https://sketchbook.knowledgeowl.com/docs/erasers
https://sketchbook.knowledgeowl.com/docs/brush-palette
https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties
https://sketchbook.knowledgeowl.com/docs/using-the-brush-puck
https://sketchbook.knowledgeowl.com/docs/color-puck#mobile
https://sketchbook.knowledgeowl.com/docs/free-extras
https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties
https://sketchbook.knowledgeowl.com/docs/what-are-brush-types
https://sketchbook.knowledgeowl.com/docs/customizing-brushes
https://sketchbook.knowledgeowl.com/docs/swapping-between-brushes
https://sketchbook.knowledgeowl.com/docs/blending-brushes
https://sketchbook.knowledgeowl.com/docs/importing-brushes
https://sketchbook.knowledgeowl.com/docs/resizing-brushes
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Erasers

You can find erasers in multiple brush packs in the Brush Library.

There are two erasers - the Cashmere Eraser and the Textured Eraser - in the basic brush set which is open by
default. There are also erasers in many of the other brush sets.

For handheld phone device users, tap  and scroll through the Brush Library to find different erasers.
For tablet users, if the erasers aren't visible in the palette, tap-drag up or down within the palette to expose
them.

Because an eraser is a brush that draws transparent pixels, any brush can be turned into an eraser by
using transparent color.

Creating an eraser pack

If you want all the erasers in one place, create an eraser pack.
1. Follow the instructions in Creating a new brush set to create a new brush set.
2. Follow the steps in Renaming brushes and brush sets to rename the pack.
3. To add erasers to the pack, do one of two things:

If you don’t want to remove the selected eraser from its current set, make a duplicate using the brush
library menu or the marking menu in Sketchbook Pro. Once you have a copy, drag it to the new set.
Drag an eraser directly into the brush pack. This removes the eraser from its original pack and moves it to
the new pack.

Convert a brush to an eraser

If you have a favorite brush and want an eraser just like it:
1. in the Brush Library, use the menu to duplicate the brush
2. open the duplicated brush's Brush Properties

https://sketchbook.knowledgeowl.com/docs/brush-library
https://sketchbook.knowledgeowl.com/docs/turning-a-brush-into-an-eraser
https://sketchbook.knowledgeowl.com/docs/creating-a-new-brush-set
https://sketchbook.knowledgeowl.com/docs/renaming-brushes-and-brush-sets
https://sketchbook.knowledgeowl.com/docs/brush-library#menu-mobile
https://sketchbook.knowledgeowl.com/docs/brush-library#menu-desktop
https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties
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3. from the drop-down menu just underneath the brush name, change the brush type to Eraser

Erase with Transparent Color

You can turn any brush into an eraser by using Transparent Color.

Modifying an eraser

To make changes to an existing eraser, do the following:
1. select the eraser you want to modify and access Brush Properties
2. Edit the eraser, then close the Brush Properties and continue drawing.

https://sketchbook.knowledgeowl.com/docs/turning-a-brush-into-an-eraser
https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties
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Blending brushes

Sketchbook comes with an assortment of brushes for blending and smudging. There is also a brush type that will
turn any brush into a natural blender.

Loading custom brushes into the mobile versions of Sketchbook requires Sketchbook 6 with the addition of
the Premium Bundle

In the Brush Library, all versions of Sketchbook have the following brush sets which are designed for blending. There
may be more that you like in other brush sets, but these are a good place to start.

Synthetic Paint

As you paint, these brushes dynamically blend the colors on the canvas. Adjust the paint load to affect the amount
of color applied at the beginning of each stroke.

Smudge

Paint over an area to blend it, simulating the effect on a finger dragging over the charcoal line of a drawing.

Colorless brushes

https://app.knowledgeowl.com/#natural-blend
https://www.sketchbook.com/get-more
https://sketchbook.knowledgeowl.com/docs/brush-library
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The Colorless blending brushes blend colors already on the canvas.

There are two ways to get a Colorless brush:
1. In the Brush Library, you scroll down and select one of the Colorless brushes.
2. Select any brush, and change it to a colorless brush type:

On desktop, double-click the brush to open its properties. You will see the Type menu below the name of
the brush.

 On mobile, in the Brush Library, tap Settings. The Brush Types menu is below the example brush stroke.
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Tap the arrow, scroll down to Colorless and select it to change the properties of the brush into a
Colorless brush. 
NOTE: The stroke shape will not change.

Smear and Blur

Smear and Blur can be found in the Classic brush set in Sketchbook Pro on desktop. These brushes are not installed
by default in Sketchbook on mobile.

Creating Natural Blend brushes

The Pastel brush set brushes are a Natural Blend brush type. This means, if you want a buttery blender that mixes
colors and smooths out the transitions between them, these for you! Try laying down colors with one of the many
other brushes in Sketchbook, then use a Natural Blend brush to gently blend them. And, if you want to make a brush
with watercolor-like blending or the properties of a pastel, play with the brush properties to do that.

How to create a Natural Blend brush

https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties
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There are two ways to create a Natural Blend brush:
1. In the Brush Library, you scroll down and select one of the Natural Blend brushes in the Pastel brush set.
2. Select any brush, and change its type to Natural Blend:

On Desktop, double-click the brush to open its properties. You will see the Type menu below the name of
the brush.
On Mobile, in the Brush Library, tap Settings. The Brush Types menu is below the example brush stroke. 
NOTE: The stroke shape won’t change.
Tap the arrow and select Natural Blend to change the properties of the brush into a Natural Blend brush.
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Using the Brush Puck

Jump to Mobile

The Brush Puck provides a shortcut for changing brush opacity and size.

Using the Brush Puck in Sketchbook Pro for desktop

If the Brush Puck isn't already visible, you will need to open it. In the menu bar along the top, select Window > Brush
Puck. To close the puck, tap the circle in its top right corner.

Changing brush opacity with the Brush Puck

Drag vertically up and down across the puck to increase/decrease the brush's opacity. If the active brush does not
have an opacity setting, this will instead increase/decrease Flow.

Resizing a brush with the Brush Puck

Drag across the puck to the right to increase a brush’s size or to the left to decrease it.

You can constrain the brush puck to only affect brush size (and not opacity/flow) in Preferences. In the Brush tab,

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook#brush
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change the setting to Change brush size only and tap OK.

Using the Double Puck in Sketchbook for mobile

Sketchbook for mobile devices doesn't have a singular Brush Puck. Due to the smaller screen size of mobile devices,
it has the Double Puck.

Use the top portion of the Double Puck to change brush size and opacity. Use the bottom section to change the
saturation and luminance/brightness of the active color.

1. Brush size and opacity
2. Current brush
3. Active color

Accessing the Double Puck

On a tablet, the Double Puck will be on by default. If you do not want to see the Double Puck, tap the tap the marking
menu  then  to toggle the it off (or on again).

On a phone device, tap the marking menu  to show the Double Puck. It will disappear again once you dismiss the
marking menu.

Resizing a brush

From within the top section of the puck, tap-drag right to increase brush size and left to decrease it.

Changing paint opacity

From within the top section of the puck, tap-drag up to increase opacity and down to decrease it.
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For tablet users, you can also change brush size using the Brush Palette sliders. For more information, see Using the
Brush Palette Sliders.

Changing color saturation

From within the bottom section of the puck, tap-drag right to increase color saturation and left to decrease it.

Changing color brightness

From within the bottom section of the puck, tap-drag top to increase color luminance/brightness and bottom to
decrease it.

Accessing the Brush Editor and Color Editor

https://sketchbook.knowledgeowl.com/docs/brush-palette#sliders
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From within the Double Puck, tap the top section of the puck to open the Brush Library. Tap the bottom section to
open the Color Editor.

https://sketchbook.knowledgeowl.com/docs/brush-library#mobile
https://sketchbook.knowledgeowl.com/docs/color-editor#mobile
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Swapping between brushes

Use one brush, then return to a previous one. Swap brushes to save time when only using two brushes (or a brush
and an eraser). You can use one brush, then return to the previous one without navigating to the Brush Palette.

Swapping between brushes in Sketchbook Pro for desktop

press hotkey S
or in the Lagoon, tap  and choose  

Swapping between brushes in Sketchbook for mobile

You can swap brushes from the marking menu  . Choose  to switch between the last two brushes.

You can also set a corner hotkey or tap/swipe gesture to Last Brush. Set these in Preferences.

https://sketchbook.knowledgeowl.com/docs/erasers
https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook#gestures
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Randomizing brushes

The randomize option in the Brush Library menu randomizes the active brush with each stroke.

The brush change occurs at the end of a stroke . The brushes will be randomized from within the active brush set.

Note that this is different from randomizing an individual brush.

Why randomize brushes?

Variation in strokes

Randomizing brushes can be an effective way to add variation by expressing subtle changes to brush strokes.
Making a new brush set by duplicating a single brush and adjusting the settings - or importing custom images
to shapes or textures - can produce a family of brushes that delivers nicely blended results.
Tip: Start off with sets of 2 or 3 brushes to discover what works best.

Variations in texture

Randomizing brushes can be an effective way to realistically express natural elements that have variation, such as
fur, earth, and foliage.

The type of images used for the Nib Shape and Nib Texture can be used to express a wide range of texture. Try
using different images and/or making brushes with larger Stamp Spacing.
Using different images with slight differences that are applied onto several brushes will make patterns that
look less repetitive.

Combining randomize brushes and randomizing color can also produce some neat results.

Enabling Randomize Brushes

In Sketchbook Pro on desktop, open the Brush Library and select a brush in the set you want to randomize.
Tap the randomize icon  to turn the feature on, and again to turn it off.
In Sketchbook on mobile, randomize brushes is available with the addition of the Premium Bundle. Open the
Brush Library and select a brush in the set you want to randomize. Tap the Brush Library menu  and select
"Randomize".

https://sketchbook.knowledgeowl.com/docs/brush-library
https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties#randomize
https://sketchbook.knowledgeowl.com/docs/randomizing-color
https://www.sketchbook.com/get-more
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Introduction to the Brush Library

Jump to Mobile

The Brush Library contains all the default brush sets. You can also import new brush sets from the Sketchbook
Extras page and create your own brushes.

Using the Brush Library in Sketchbook Pro for desktop

At the top of the Brush Palette, tap  to access the Brush Library.

1. Name of the active brush and set it is in
2. Brush set name
3. Active brush icon
4. Active brush stamp
5. Brush Library marking menu
6. Reorder brush sets
7. Randomize brushes within a set
8. Scroll for accessing more brush sets

Library marking menu

When you tap within a brush set, the marking menu  appears. Tap-hold it to expose the menu options.

https://app.knowledgeowl.com/#mobile
https://www.sketchbook.com/get-more
https://sketchbook.knowledgeowl.com/docs/brush-palette
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In the Brush Library, tap  and select an option:
New Brush Set  – Create a new brush set.
Export Brush Set  – Share brushes with people working on different platforms.
Import Brush Set  – Load a brush set file into the Brush Library
Delete Brush Set  – Remove the selected brush set from the Brush Library.
Pin Set To Palette  – Replaces the Brush Palette brushes with the selected set’s brushes.
New Brush  – Create a new brush and add it to the selected brush set.
Copy Brush  – Create a duplicate of a selected brush and add it to the selected brush set.
Delete Brush  – Permanently remove a selected brush.

Using the Brush Library in Sketchbook for mobile devices

https://sketchbook.knowledgeowl.com/docs/creating-a-new-brush-set
https://sketchbook.knowledgeowl.com/docs/exporting-brush-sets
https://sketchbook.knowledgeowl.com/docs/importing-brushes
https://sketchbook.knowledgeowl.com/docs/deleting-brush-sets
https://sketchbook.knowledgeowl.com/docs/brush-palette#pin
https://sketchbook.knowledgeowl.com/docs/creating-a-texture-brush
https://sketchbook.knowledgeowl.com/docs/deleting-brush-sets
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1. Library tab
2. Brush Properties tab
3. Brush Name and Brush Set Name
4. Active brush stroke sample
5. Active Brush - tap a brush in the set to make it active
6. Pin the active brush set to the Brush Palette
7. Brush Menu - access advanced brush options including importing new brushes. Requires the Premium Bundle.

Accessing the Brush Library

Tap  at the top of the Brush Palette to access the Brush Library and an assortment of brush sets.

If the window opens to  Brush Properties, you'll need to tap  at the top of the window to tab over to the Brush
Library.

or, you can double-tap the top of the Double Puck to open the Brush Library

On a phone/handheld device, you access the Brush Library by tapping  in the toolbar

https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties#mobile
https://sketchbook.knowledgeowl.com/docs/brush-palette#pin
https://www.sketchbook.com/get-more
https://sketchbook.knowledgeowl.com/docs/using-the-brush-puck#mobile
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If your UI is hidden, tap the  Trigger to access the Brush Library.
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What are brush types?

Every brush is assigned a Brush Type, which defines the brush's properties separately from the brush stroke.
Changing the Brush Type will cause it to take on different properties while retaining the stroke.

Brush Type is found near the top of the Brush Properties window.

What Brush Types are there?

There are two groups of brush types. Standard is included in the first group and is set as the default brush type for
many brushes. The second group, Blend Modes, work like the layer blend modes but only apply the blend mode
where you paint..

Standard
Marker
Smudge
Glow
Eraser
Synthetic Paint
Colorless
Natural Blend

Blend Mode Brush Types

Darken
Multiply
Color Burn

https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties
https://sketchbook.knowledgeowl.com/docs/blending-brushes#smudge
https://sketchbook.knowledgeowl.com/docs/erasers
https://sketchbook.knowledgeowl.com/docs/blending-brushes#synthetic
https://sketchbook.knowledgeowl.com/docs/blending-brushes#colorless
https://sketchbook.knowledgeowl.com/docs/blending-brushes#natural-blend
https://sketchbook.knowledgeowl.com/docs/blending-layers#darken
https://sketchbook.knowledgeowl.com/docs/blending-layers#multiply
https://sketchbook.knowledgeowl.com/docs/blending-layers#color-burn
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Linear Burn
Lighten
Screen
Color Dodge
Linear Dodge (Add)
Overlay
Soft Light
Hard Light
Hue
Saturation
Color
Luminosity 

Using Blend Mode brushes

A Blend Mode brush is any brush that has a blend mode assigned to it. Blend modes change the color of the pixels
you paint over.

When you want to apply the effects of a blend mode to only a specific area of a layer instead of the entire layer, you
can use a blend mode brush.

To darken where you paint, try Darken, Multiply, Color Burn, or Linear Burn.
To lighten where you paint, try Lighten, Screen, or Linear Dodge (Add).
For contrast, try Overlay, Soft Light, or Hard Light.
To change components of the color, try Hue, Saturation, Color, or Luminosity.

https://sketchbook.knowledgeowl.com/docs/blending-layers#linear-burn
https://sketchbook.knowledgeowl.com/docs/blending-layers#lighten
https://sketchbook.knowledgeowl.com/docs/blending-layers#screen
https://sketchbook.knowledgeowl.com/docs/blending-layers#color-dodge
https://sketchbook.knowledgeowl.com/docs/blending-layers#linear-dodge
https://sketchbook.knowledgeowl.com/docs/blending-layers#overlay
https://sketchbook.knowledgeowl.com/docs/blending-layers#soft-light
https://sketchbook.knowledgeowl.com/docs/blending-layers#hard-light
https://sketchbook.knowledgeowl.com/docs/blending-layers#hue
https://sketchbook.knowledgeowl.com/docs/blending-layers#saturation
https://sketchbook.knowledgeowl.com/docs/blending-layers#color
https://sketchbook.knowledgeowl.com/docs/blending-layers#luminosity
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Customizing brushes

Sketchbook has a powerful brush engine that offers many ways to customize brushes to fit your style, or for you to
create your own unique brushes.

Some people create their own custom stamp and texture brushes, others like to duplicate a favorite brush so they
have multiple versions of the brush ready to go with different settings. These are just a few examples of why you
might decide to customize your brushes to improve your workflow.

Learn more below about the advanced brush settings you may want to customize, and then the step by step of doing
so in Sketchbook Pro and Sketchbook for mobile devices.

Setting a brush stamp and texture

In Advanced brush properties, you will see a section called Nib. This is where you adjust the brush stamp – it’s Edge,
Shape, and Texture. 

Using Shapes

When activated, Shape applies the selected shape to the brush, but with no assigned color. Each time the brush is
used, it will apply the shape in the active color, unless With Color is used (see below). 

https://app.knowledgeowl.com/#desktop
https://app.knowledgeowl.com/#mobile
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Changing the edge of your brush

Use the Edge slider to make the edges of your brush softer or sharper.
For a precision brush, you’ll want to set Hardness to a high value.
For a pastel-type brush, you'll want to set Hardness to a small value.

Defining the shape of your brush

If you read How to capture textures and shapes, the example uses Shape to create a chain brush. There are  three
options for defining the shape of your brush nib:

1. Tap the arrow  at the bottom corner of the default shape to access a list of brush shape options. 

2. Choose Import to import a new shape image.
3. or choose Capture to take a screen capture of something on your screen (only available in Sketchbook Pro on

desktop).

Constrain the brush shape using With Color

If your imported shape is a color image, enable With Color. This will cause the brush to only use the stamp's
imported color, leaving it unchecked means the brush will always use the current active color in the Color Editor.
Some examples of brushes using With Color are the Leaves and Colored Pencils in our Extras.

When would I use Ignore Edge?

https://sketchbook.knowledgeowl.com/docs/capturing-textures-and-shapes
https://www.sketchbook.com/extras/leaf-brushes
https://www.sketchbook.com/extras/colored-pencils-brush-set
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You can also decide to ignore the edges of the image or capture. By enabling Ignore Edge, your brush stamp shape
will not be round.

You would want to use Ignore Edge with non-circular shapes - such as the leaves example above- to avoid having
them be cropped to a circle. You might also use Ignore Edge if you want your shape to flow tightly around corners,
such as using it in conjunction with the Ellipse tool. 

Creating your own brushes in Sketchbook Pro for desktop

Create more brushes by copying a brush and changing its settings or creating a Do-It-Yourself brush.
1. In the Brush Library, Tap on a brush set to select it
2. Tap-hold  and choose  to add a brush
3. Select a brush type to base your new brush on. By default, Current Brush is selected which duplicates the type

of the active brush. Try starting with Standard.
4. Tap Create. A Do-It-Yourself Brush icon  will appear in your brush set.

Once you create a Do-It-Yourself brush, double-tap the icon to open Brush Properties to customize it:
Adjust the pressure sensitivity – In the Advanced tab, set brush radius and opacity according to the amount of
pressure applied to the stylus. The brush size values are a rough approximation of pixel size, but can vary.
Change the opacity – In the Advanced tab, set opacity to vary brush opacity as the stylus pressure changes. To
have the brush randomly changed opacity as you lay down strokes, see Randomize.

Creating your own brushes in Sketchbook for mobile devices

Creating your own brushes requires the Premium Bundle

Create more brushes by copying an existing brush and changing its settings.
1. Double-tap a brush in the Brush Palette to open Brush Properties, then tap the menu  and choose Duplicate.

https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties#randomize
https://www.sketchbook.com/get-more
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You can also duplicate the active brush from the menu in the Brush Library  .
2. The new brush will be called "Duplicate" and will be added next to its parent brush in the Brush Library
3. In Brush Properties, tap the menu  again to rename the brush, and/or change its icon.
4. Tap over to the Advanced tab of Brush Properties to customize the new brush. Adjust the pressure sensitivity –

set brush radius and opacity according to the amount of pressure applied to the stylus. Apply your own custom
texture or stamp images.
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Creating a new brush set

Jump to Mobile

If you have created new brushes, you might want to create a new brush set to help organize them.

Creating a new brush set in Sketchbook Pro for desktop
1. To create a brush set, in the Brush Library, tap-hold the marking menu  and select New Brush Set  . The

new brush set will appear below the currently active brush set in the Brush Library. 

2. To add a brush to your new brush set, tap-hold a brush to select it, then drag the brush into the set. If you don’t
want to remove the selected brush from its current set, you can duplicate the brush, using Copy Brush (found in
the marking menu). Once you have a copy, drag it to the new set.

3. After creating a new set, you might want to pin the new set to your Brush Palette.

Renaming a brush set

Once you’ve created a brush set, you may want to assign the set a name that describes its contents.

Tap the set name to make it editable, then enter a new name, and press the Enter key.

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/brush-library
https://sketchbook.knowledgeowl.com/docs/brush-palette#pin
https://sketchbook.knowledgeowl.com/docs/brush-palette
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Creating a new brush set in Sketchbook on mobile devices

Creating brush sets in Sketchbook for mobile devices requires the Premium Bundle

When you create a new brush set, it appears below the current active brush set in the Brush Library.
1. To create a brush set, in the  Brush Library, tap the menu  in the active brush set and select Create New

Set. The new brush set will appear below the currently active brush set. 

2. To add a brush to your new brush set, either:
a. tap  to copy the currently active brush to the new set
b. or drag any brush into the new set. If you don’t want to remove the selected brush from its current set, you

can duplicate the brush from the menu first. Once you have a copy, drag it to the new set.
3. After creating a new set, you might want to pin the new set to your Brush Palette.

https://www.sketchbook.com/get-more
https://sketchbook.knowledgeowl.com/docs/brush-library#mobile
https://sketchbook.knowledgeowl.com/docs/brush-palette#pin
https://sketchbook.knowledgeowl.com/docs/brush-palette
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Renaming a brush set

Once you’ve created a brush set, you may want to assign the set a name that describes its contents.
1. Tap any brush in the new set to make the set active.
2. Then tap the menu  and choose  Rename Set

3. When the keyboard pops up, enter a new name, and press Return, or tap anywhere on the canvas to exit.
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Deleting brushes and brush sets

Jump to Mobile

If you want to permanently delete brushes or entire brush sets, you can.

It's important to keep in mind that you cannot undo these actions.

To recover a deleted brush or brush set, you would need to have the file backed up somewhere and re-
import it.

Deleting a brush or brush set in Sketchbook Pro for desktop

1. In the Brush Library, tap the brush set you want to delete to activate it
2. Tap-hold  to post the marking menu
3. Select  Delete Brush Set to delete the active set
4. Select  Delete Brush to delete the active brush. This icon will only be enabled if the active brush is in the

active brush set. If the current active brush is in another set, the icon will be greyed out.

Deleting a brush set in Sketchbook for mobile devices

Deleting brushes or brush sets in Sketchbook for mobile devices requires the Premium Bundle

To delete a single brush:
1. Double-tap the brush to open its Brush Properties
2. Tap the menu  and choose  Delete

To delete a brush set:
1. Find the set in the Brush Library
2. Tap any of its brushes to activate the set's menu
3. Tap the menu  
4. Tap  Delete Set, then Confirm

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/importing-brushes
https://www.sketchbook.com/get-more
https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties#mobile
https://sketchbook.knowledgeowl.com/docs/brush-library#mobile
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Exporting brush sets

Exporting brush sets enables you to back them up, and also to share them between your devices or with other
people.

Exporting brush sets in Sketchbook Pro for desktop
1. In the Brush Library, tap the brush set you want to backup or share.
2. Tap-hold  and select  Export Brush Set. 

3. Navigate to where you want the set saved and tap Save.

Exporting brush sets in Sketchbook for mobile devices

Exporting brushes is unlocked with the purchase of the Premium Bundle.

1. Tap  to open the Brush Library
2. Tap any brush in the set you want to export to post the menu  for that set.
3. Tap the  menu and choose Export
4. The file browser will launch. You have the opportunity on this screen to rename the file if you want to. Navigate

to where you want to save the file and tap Save in the upper right corner.

https://sketchbook.knowledgeowl.com/docs/brush-library
https://www.sketchbook.com/get-more
https://sketchbook.knowledgeowl.com/docs/brush-library#mobile
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Importing brushes

Jump to Mobile

If you have downloaded brushes from the Sketchbook Extras library, have a backed up set you want to load on a new
computer or have received some from a friend or coworker, you can import them to Sketchbook in the Brush Library.

We only support the .skbrushes brush format, so you will not be able to import and use other brush
types.

Importing brushes in Sketchbook Pro for desktop

There are several ways to import a brush on desktop. The most straightforward is to drag and drop the brush into
the canvas, or double-click the brush file. Doing this will import the set to the last position in your Brush Library.

You can also manually import the brush set.

Loading brushes using Import Brush Set

1. In the Brush Library, tap the marking menu  
2. Select  Import Brush Set.
3. Navigate to your Downloads folder, or wherever you saved the brush set you want to import
4. Double-tap the brush set. Whether it is a .zip file or .skbrushes file shouldn't matter. The set is immediately

loaded into your Brush Library. It will appear after the current active set where you used the marking menu.

Pinning a brush set to the Brush Palette

If you have a preferred brush set, you can pin it to the Brush Palette so it appears there instead of the Basic set. 
1. In the Brush Library, tap the brush set you want to pin to the Brush Palette.
2. Tap-hold  and select  Pin Set To Palette. You will see your palette is now loaded in the Brush Palette.

Importing brushes in Sketchbook for mobile

You will need to purchase the Premium Bundle to unlock the option to import brushes.

1. Download the brush set to your device or connected cloud location
2. Tap  to open the Brush Library
3. At your pinned brush set, you'll see the Brush Set menu . Or you can tap a brush in any set to activate the

menu there. 

https://app.knowledgeowl.com/#mobile
https://www.sketchbook.com/extras
https://sketchbook.knowledgeowl.com/docs/brush-library
https://sketchbook.knowledgeowl.com/docs/brush-library
https://sketchbook.knowledgeowl.com/docs/brush-palette
https://sketchbook.knowledgeowl.com/docs/brush-palette
https://www.sketchbook.com/get-more
https://sketchbook.knowledgeowl.com/docs/brush-library#mobile
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4. Tap the menu and choose Import 

5. The file browser will launch, navigate to where you saved the downloaded .skbrushes file
6. Tap the file to import

Here's a quick video showing brush import in action:

Your browser does not support HTML5 video.
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Introduction to the Brush Palette

The Brush Palette panel presents one full brush set from the Brush Library, providing a quick way to access your
most frequently used brushes.

Mac / Windows  Android / iOS

1. Open the Brush Library and Brush Properties
2. Active brush. Tap to see brush history.
3. Brushes of the pinned brush set
4. Active brush. Tap to open Brush Properties.
5. Brush size slider
6. Brush opacity slider

How to pin brushes to the Brush Palette

Only one brush set can appear in the brush palette at a time. You can change the brush set that appears in the brush
palette by pinning a different brush set.

In Sketchbook Pro on desktop, the Pin feature is in the Brush Library marking menu.

https://sketchbook.knowledgeowl.com/docs/brush-library
https://sketchbook.knowledgeowl.com/docs/brush-library
https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties
https://app.knowledgeowl.com/#pin
https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties
https://app.knowledgeowl.com/#sliders
https://app.knowledgeowl.com/#sliders
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On mobile, the pin icon appears in the upper right corner of a brush set in the Brush Library.

Using the Brush Palette sliders

The sliders on the right side of the brush panel are another way to adjust brush properties.
The top handle adjusts brush size. 
When adjusting this handle, a brush preview will appear along with the numeric value of the setting to preview
the results.
The bottom handle adjusts either the opacity or flow of a brush, depending on the brush type. 
When adjusting the handle, a brush preview will appear along with the numeric value of the setting to preview
the results.

https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties
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Rearranging brushes and brush sets

Jump to Mobile

Want to rearrange the brushes in your palette or brush sets in the Brush Library, so your favorite brushes are easily
accessible? You can reorder your brush sets in the palette and also rearrange brushes within a brush set if you want
to.

Arranging brushes in a set will also help you take advantage of the Randomize Brushes feature.

Rearranging brushes in Sketchbook Pro for desktop

In the Brush Palette, tap-hold, then drag a brush to a different location within the palette.

 

Rearranging brush sets in the Brush Library

1. In the Brush Palette, tap  to access the Brush Library

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/randomizing-brushes
https://sketchbook.knowledgeowl.com/docs/brush-palette
https://sketchbook.knowledgeowl.com/docs/brush-library
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2. Tap the set you want to move. The  icon will appear
3. Tap-drag  to move the brush set to its new location

Rearranging brushes in Sketchbook for mobile devices

In the Brush Library or Brush Palette, tap-hold, then drag a brush to a different location.

 

https://sketchbook.knowledgeowl.com/docs/brush-library#mobile
https://sketchbook.knowledgeowl.com/docs/brush-palette
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Resizing brushes

Jump to Mobile

Change the size of a brush to make it smaller for adding detail or larger for quick coverage of a large area.

Resizing brushes in Sketchbook Pro for desktop
1. In the Brush Palette, select the brush you want to resize.
2. Tap the Basic tab (if there are two tabs) and drag the Size slider.

Resizing brushes in Sketchbook for mobile devices

The fastest way is to use the sliders or the Brush Puck.

Resizing a brush using the palette sliders

1. In the Brush Palette, tap any brush to select it. Sliders appear beside the palette for changing size or
hardness/size and opacity or opacity/flow.

2. Tap-drag them up or down. An on-screen display appears, indicating the new numeric values for the changed
brush property.

Resizing a brush using Brush Settings

1. Open Brush Properties 
2. On the Basic tab drag the Size slider, or tap the number above the slider to numerically input the size you want

the brush to be and then tap "Done". If you numerically enter a number that is not supported by the brush, it will
default to the nearest supported value.

If you have a pressure-sensitive stylus: the size shown on the Basic tab is the heavy pressure setting.
When you adjust it on the Basic tab, the light pressure setting will adjust as well based on the current
relationship between the two values. If you want to adjust heavy and light pressure settings
independently, tap over to the Advanced tab.

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/using-the-brush-puck#mobile
https://sketchbook.knowledgeowl.com/docs/brush-palette#sliders
https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties#mobile
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Introduction to Brush Properties

Sketchbook brushes are highly customizable. Use Brush Properties to alter or fine-tune the characteristics of a
brush. 

Opening Brush Properties in Sketchbook Pro on macOS and Windows
Opening Brush Properties in Sketchbook on Android and iOS

Different brush types can have a different set of available properties. 

Basic brush properties

Size is always included in the Basic brush properties. Depending on the brush type, a few other commonly adjusted
options will also appear. 

The basic properties tab does not show settings options based on pressure. Basic properties are shown at the
Heavy Pressure setting. For brushes that have pressure-sensitive settings, changing the setting on the basic tab will
proportionally change the light pressure setting as well. Tap over to the Advanced tab to adjust settings individually
for light or heavy pressure. 

Advanced brush properties

Pressure

Includes Brush Size (radius) and Flow, and Opacity for brush types that support it. Different settings for heavy and
light pressure can be applied here.  

Size - sets brush stroke thickness

Opacity - sets the opacity (opaqueness/transparency) of the stroke.

Flow - handles the speed of the paint. The more pressure you apply, the faster the paint appears (and the more that
appears) on the canvas. A light touch results in less and lighter paint applied to the canvas.

Stamp

Spacing – The distance between stamps in a single stroke. The default spacing of the Pencil is 1.2. The minimum
spacing is 0.1, this will give you a very dense brush. The max is 10.0. Be aware that extremely tight spacing may
generate unwanted effects.

https://app.knowledgeowl.com/#desktop
https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/what-are-brush-types
https://sketchbook.knowledgeowl.com/docs/what-are-brush-types
https://sketchbook.knowledgeowl.com/docs/pressure-sensitivity-in-sketchbook
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Roundness – Most brushes will have this set at 100%. But for a brush that requires rotation or simulated tilt, this is
where you need to start adjustments. Rotation dynamics and tilt require Roundness below 100%, as at 100% the
stamp is a perfect circle. 

Rotation - rotates the stamp image. You can see the effect of the rotation in the stroke preview at the top of the
window.

Rotation Dynamics: 
Rotate to stroke – This can be very handy for patterns that need to follow the stroke, such as braided elements,
chains, fibers and more.  For example, you’re trying to simulate the profile tire tread. Using an ellipse, you can
put a stroke down without Rotate to Stroke. However, if you turn on Rotate to Stroke, and fine tuned the
Rotation value, it hugs a circle – which is what you need for a tread profile. To finish it off, play around with
Spacing and Brush Size to perfect the loop pattern. 

Controlled by stylus tilt / Stylus Tilt and Roll  - elongates the stroke of the brush based on the tilt of your stylus.
For people drawing with Apple Pencil Pro, barrel roll is enabled along with stylus tilt - you will see the option
"Stylus Tilt and Roll". Read more in the article Setting stylus tilt.  
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Nib

Edge/Hardness - a brush with a soft edge (low hardness) gives the brush stamp a gradient/fade around the edge,
while a sharp edge (high hardness) creates a crisp stamp. With high hardness there may still be a bit of a blur at the
edge to help with anti-aliasing. 

Shape - applies the selected shape to the brush, but with no assigned color. Each time the brush is used, it will apply
the shape in the active color, unless With Color is on (see below).

With Color - when enabled, the brush will only use the color of the stamp in the stamp image, the active color in the
Color Editor will be ignored. 

Ignore Edge - ignore the edges of the applied stamp, so your brush stamp shape will not be round.

Texture - applies a texture overlay to the stroke. Can be used with a stamp or on its own.
Depth sets how visibly the texture shows through the overall stroke. This option is only available for the
Standard brushes, Erasers, and Blend Mode brushes.
Enabling Per Tip introduces the option to have the depth setting vary based on pressure sensitivity.

Randomness

Randomness inserts variability into your brush stroke. Depending on the brush type and settings, some of these
options may not be available.

Size – changes the size of the brush's stamp within a stroke.

Opacity – varies the opacity/transparency within a stroke.

Flow – varies the speed and amount of paint applied.

Rotation – changes the rotation of the stamp as the stroke is created. The only time this will not be noticeable is for
perfectly symmetrical stamps. This will be more visible on a brush with a roundness values below 50%.

Spacing – varies the amount of space between stamps in a stroke. This is more noticeable when stamp spacing is
set at a higher value.

This randomization affects only that particular brush. If you want to randomize the active brushes while you draw,
such as for creating realistic fur or grass effect, see Randomizing Brushes.

https://sketchbook.knowledgeowl.com/docs/pressure-sensitivity-in-sketchbook
https://sketchbook.knowledgeowl.com/docs/randomizing-brushes
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Brush Properties in Sketchbook Pro for desktop

Brush Properties are opened by tapping  at the top of the Brush Palette.

Depending on the brush selected, there may be two tabs of properties – Basic and Advanced – and an option for
changing the Brush Type.

Brush Properties in Sketchbook for mobile devices

Accessing brush properties from the brush palette

1. Tap a brush icon to open that brush's properties.
2. or tap  to open the Brush Library and select a brush, then tap  to switch to Brush Properties for the new

active brush

Accessing brush properties from the phone toolbar

1. tap  in the toolbar to open the Brush Library.
2. In the Brush Library, select the brush you want to customize.
3. Tap to the  Properties tab to edit the brush.

https://sketchbook.knowledgeowl.com/docs/brush-palette
https://sketchbook.knowledgeowl.com/docs/what-are-brush-types
https://sketchbook.knowledgeowl.com/docs/brush-library#mobile
https://sketchbook.knowledgeowl.com/docs/brush-library#mobile
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Renaming brushes and brush sets

Jump to Mobile

Renaming brushes and brush sets in Sketchbook Pro for desktop

Renaming a brush

Once you’ve created a brush, whether it is a DIY brush or copy of a brush that you’ve customized, it’s a good idea to
rename it. By assigning a name it will help you identify it, especially if you want to add it to your Brushes marking
menu.

1. Double-tap the brush to open its Brush Properties.
2. Tap the brush name to make it editable.
3. Enter a new name.
4. Tap the Enter key to commit the change. 

Renaming a brush set

Once you’ve created a brush set, you may want to assign a name that better describes its contents.
1. Open the Brush Library
2. Tap the set you want to rename.
3. Tap the name to make it editable.
4. Enter a new name.
5. Tap the Enter key to commit the change. 

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties
https://sketchbook.knowledgeowl.com/docs/brush-library
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Renaming brushes and brush sets in Sketchbook on mobile devices

Renaming brushes and brush sets in Sketchbook on iOS and Android requires the Premium Bundle

Renaming a brush

1. Select the brush and open its Brush Properties.
2. Tap the  menu next to the brush name.
3. Select  Rename.
4. Select the text and enter a new name.
5. Tap Return or tap anywhere on the canvas to commit the change. 

Renaming a brush set

Once you’ve created a brush set, you may want to assign a name that better describes its contents.
1. Open the Brush Library
2. Select any brush within the set you want to rename to activate the set
3. Tap the  menu next to the pin
4. Select  Rename Set and enter a new name
5. Tap Return or tap anywhere on the canvas to commit the change 

https://www.sketchbook.com/get-more
https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties
https://sketchbook.knowledgeowl.com/docs/brush-library#mobile
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Resetting brush properties

Jump to Mobile

Resetting brush properties deletes all customization made a brush. Why would you do this? Maybe you need to
delete custom proprietary brushes from a client, once the project is finished or want to reset some brushes to their
defaults because you don’t like the customized settings.

There are two options for resetting brushes to their default settings, you can reset one brush or the entire Brush
Library.

Resetting brush properties in Sketchbook Pro for desktop

Resetting one brush to its default settings

1. Double-tap the brush you want to reset to open its Brush Properties.
2. At the bottom of the Brush Properties window, tap Reset.

Resetting the Brush Library to default

When you reset the Brush Library, it will go back to how it was when Sketchbook Pro was first installed. Resetting the
Brush Library can be done in preferences.

WARNING: resetting the Brush Library will delete any new, duplicated, or imported brushes. 

1. Open Sketchbook Pro Preferences
2. In Preferences, select Factory Defaults
3. Tap the "Reset" button next to Reset Brush Palette and Library

Resetting brush properties in Sketchbook for mobile devices

Resetting one brush to its default settings

1. Tap the brush in the Brush Palette to open its properties 
or select the brush in the Brush Library and then swipe left to the  Brush Properties tab.

2. At the bottom of the window, tap Reset

Resetting the Brush Library to default

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties
https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook#defaults
https://sketchbook.knowledgeowl.com/docs/brush-palette
https://sketchbook.knowledgeowl.com/docs/brush-library
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� WARNING: resetting the Brush Library will delete any new, duplicated, or imported brushes. 

1. select  Menu > Preferences
2. Scroll to the Factory Defaults section
3. At Brush Settings, tap Reset. 

All brushes in the Brush Library will be reset to default, and any newly created, customized, or imported
brushes will be removed. This action cannot be undone.

https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook#defaults-mobile
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Creating a texture brush

Jump to Mobile

A texture brush turns a smooth stroke into something more interesting by adding a texture to it. If you want to create
a brush stroke that looks like a textured surface such as canvas or fabric, you can do this with a texture brush.

Texture can make something look soft, fluffy, even gritty. It adds another dimension to your stroke. Once you have
selected a texture, you can adjust it, making it more subtle or adding complexity.

Creating a texture brush in Sketchbook Pro for desktop
1. In the Brush Library, tap-hold the marking menu and choose New Brush
2. Select a brush from the Do-It-Yourself Brush dialog and tap Create.
3. Double-tap the new Do-It-Yourself Brush to open its Brush Properties.
4. In Brush Properties, tap the Advanced tab, scroll down to Nib and open it, then scroll down to Texture.
5. Tap (the triangle in the bottom right corner of Texture) and select a texture from the list of options. You can

also import your own texture image, or capture one from the canvas. 

If you want to modify the texture further, try inverting the texture or changing its scale, brightness, or contrast. There
are several options you can play with.

Creating a texture brush in Sketchbook on mobile devices

Creating new brushes in Sketchbook on iOS and Android requires the Premium Bundle

A texture can be applied or changed on any brush using one of the default textures, or by importing textures.
1. In the Brush Library, tap the menu  and Duplicate a brush to create a new brush.
2. Brush Properties will automatically open for the new (duplicated) brush
3. Tap the Advanced tab, scroll down to Nib and open it, then scroll down to Texture.
4. Tap  (the triangle in the bottom right corner of Texture) and select a texture from the list of options. or

import your own texture. NOTE: Sketchbook on mobile doesn't have the capture texture function that is
available in Sketchbook Pro.

If you want to modify the texture further, try inverting the texture, changing the scale. brightness, or contrast.

https://app.knowledgeowl.com/#mobile
https://www.sketchbook.com/get-more
https://sketchbook.knowledgeowl.com/docs/importing-textures
https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties#mobile
https://sketchbook.knowledgeowl.com/docs/importing-textures
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Setting brush edges

Jump to Mobile

Normally, the brush type you have selected determines the brush edge properties. When modifying a brush, to
achieve certain effects, you might need to change the brush edge.

Soft edges gives soft, feathered brush edges (example: airbrush)
Solid edges gives hard edges that still bleed slightly (example: markers or ballpoint pens)
Sharp edges are hard (example: calligraphy pen on high-quality paper stock, or lines from computer drafting
software)

Setting the edge of your brush in Sketchbook Pro for desktop
1. In either the Brush Palette or Brush Properties, double-tap the brush you want to modify to open its properties.
2. In Brush Properties, tap the Advanced tab. Scroll down to the Nib section and open it.
3. Under Edge, either tap-drag the slider or enter a numeric value (in the field to the right):

For a precision brush, you’d want sharp edges.
For a pastel-type brush, you’d want soft edges.

Setting the edge of your brush in Sketchbook for mobile devices
1. In the Brush Palette, tap the brush you want to modify to open Brush Properties.
2. In Brush Properties, tap the Advanced tab. Scroll to the Nib section and open it.
3. Under Hardness, tap-drag the slider:

For a precision brush, you’d want to set Hardness to a very high value.
For a pastel-type brush, you’d want to set Hardness to quite a small value.

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/brush-palette
https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties
https://sketchbook.knowledgeowl.com/docs/brush-palette
https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties#mobile
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Changing textures

Jump to Mobile

If you find that you have a texture that is too defined (black and white) or too subtle (gray), you can use the
Brightness and Contrast controls within Brush Properties to change it.

To pull out more details in an almost all black or almost all white texture, change the Brightness first to give
Contrast something to work with. As you decrease Brightness, the texture will pop. Then, by increasing
Contrast, the texture becomes more grainy.
To soften a black and white texture, play with Contrast first, then Brightness if necessary. As you decrease
Contrast, the texture becomes fainter. Then, if you increase Brightness, the texture will be less visibility.

Adjusting a texture in Sketchbook Pro for desktop
1. With a brush selected, tap  to open Brush Properties.
2. In Brush Properties, tap the Advanced tab, scroll down to Nib and open it, then scroll down to Texture. Add a

check to activate it if Texture is not already active.
3. Tap-drag the Brightness and/or Contrast slider to change the texture. The brush preview at the top of the

window will update.

Making changes to your texture in Sketchbook for mobile devices

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties
https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties
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1. In either the Brush Palette or Brush Library, double-tap the brush you want to modify to open Brush Properties.
2. In Brush Properties, tap the Advanced tab, scroll down to Nib and open it, then scroll down to Texture. Add a

check to activate it if Texture is not already active.
3. Tap-drag the Brightness and/or Contrast slider to change the texture. The brush preview at the top of the

window will update.

https://sketchbook.knowledgeowl.com/docs/brush-palette
https://sketchbook.knowledgeowl.com/docs/brush-library#mobile
https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties#mobile
https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties#mobile
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Scaling textures

Jump to Mobile

When you adjust a texture's Scale, you are zooming in or out of the texture. Dragging the Scale slider can provide you
with more or less detail.

In the above example, the same texture was applied to each star shape, but the scale was changed.

Scaling a texture in Sketchbook Pro for desktop
1. With a brush selected, tap  to open Brush Properties.
2. In Brush Properties, tap the Advanced tab, scroll down to Nib and open it, then scroll down to Texture. If a

texture is not already applied, add a check to activate it.
3. Tap-drag the Scale slider to zoom in or out of the texture. As you change the scale, the brush preview at the top

of the window will update.

Scaling a texture in Sketchbook for mobile devices
1. Open Brush Properties for the brush you want to update.
2. Tap the Advanced tab, scroll down to Nib and open it, scroll down to Texture

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties
https://sketchbook.knowledgeowl.com/docs/changing-textures
https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties#mobile
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3. Tap-drag the Scale slider to zoom in or out of the texture. As you change the scale, the brush preview at the top
of the window will update.
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Importing textures

Jump to Mobile

Importing textures in Sketchbook Pro for desktop
1. With a brush selected, tap  to open Brush Properties.
2. In Brush Properties, tap the Advanced tab, scroll down to Nib and open it, scroll down to Texture, and add a

check to activate it if the brush does not already have a texture applied
3. Tap Import.
4. Locate the texture file, select it, and tap Open. The display in Brush Properties will update to show the texture.

You can also capture textures from your canvas as another way to create or edit texture brushes.

Importing textures in Sketchbook on mobile devices

Importing textures in Sketchbook on iOS and Android requires the Premium Bundle

1. Double-tap a brush icon in the Brush Palette to open its properties 
or tap the active brush icon one time 
or open the Brush Library to select a brush, and then tap over to the  Settings tab to get to Brush Properties

2. tap the Advanced tab, scroll down to Nib and open it, scroll down to Texture, and add a check to activate it if a
texture is not already applied

3. Tap Import
4. Locate the texture, and select it. The display in Brush Properties will update to show the new texture

NOTE: capturing textures from your canvas is not available on mobile devices.

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties
https://sketchbook.knowledgeowl.com/docs/capturing-textures-and-shapes
https://www.sketchbook.com/get-more
https://sketchbook.knowledgeowl.com/docs/brush-palette
https://sketchbook.knowledgeowl.com/docs/brush-library#mobile
https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties#mobile
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Capturing textures and shapes

Available only in Sketchbook Pro on macOS and Windows

If the options in the default libraries don't produce the effect you're looking for, you can capture your own textures or
shapes.

In Brush Properties, when Shape or Texture are enabled, there will be a Capture button you can use to apply your
own image. 

This is a good feature to use if you have some work on the canvas that you would like to apply to a brush, for
example creating a stamp from an existing group of pixels.

1. In either the Brush Palette or Brush Library, double-tap a brush to open Brush Properties.
2. In Brush Properties, tap the Advanced tab, scroll down to Nib and open it
3. Make sure the property (Stamp or Texture) you want to capture is checked
4. Tap Capture. A prompt will appear at the bottom of the canvas, noting you are in Capture Mode
5. In the canvas, as you pen/mouse over the area, a brush outline will appear. If it isn’t large enough to surround

the area you want to capture, change the size of the brush with the Brush Puck or tap-hold the B key and drag
within the canvas until it is the required size.

6. Tap the area to be captured as the stamp or texture. The display in Brush Properties will update to show the
captured content.

Sketchbook doesn't currently support the capturing of textures or shapes on mobile devices

Tips

When capturing a stamp texture, ensure all the strokes/paint you want included in your brush stamp are on the
active layer. If you don’t want to merge all layers just for the sake of creating a brush, you can duplicate the required
layers and merge the duplicates so you have a single active layer to capture from. Once you’ve captured the stamp,
you can delete that duplicate layer.

https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties
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To change the shape of the captured stamp, use Roundness. For an elliptical stamp, set Roundness to a low value.

To rotate the stamp, in the Stamp section, under Rotation Dynamics, tap the arrow to select either Rotate to Stroke
or Controlled by stylus tilt. Rotate to Stroke dynamically rotates the texture in the direction of the stroke.

To capture the shape and color of the stamp , in the Texture section, tap the arrow next to Off and select Shape +
Colors.

To adjust the brush stamp, in the Stamp section, adjust the roundness, rotation, and spacing.

To randomize the stamp, in the Randomize section, adjust size, flow, rotation, and spacing randomize.

To change the brush edges, in the Edge section, adjust the hardness. Normally, the brush type you have selected
determines this setting. Making the edges softer will create feathered brush edges, like with an airbrush. Harder
edges are for markers or ballpoint pens. Maximum hardness is for a calligraphy pen on high-quality paper stock or
lines from computer drafting software.

Some brushes, such as the Basic brushes, don't have Advanced options. Therefore, they don't have options for
capturing a texture.

NOTE: If you keep Brush Properties open when using a texture brush, you can change rotate the
texture or change any other settings as you sketch.

With Color

When activated, the shape or texture will use the current paint color, as well as the selected shape or texture, to
create your brush stamp. If With Color is grayed out, this indicates that option is not available for that particular
brush.

If you want to capture something with multiple colors, activate Shape and With Color. Whenever the texture brush is
used, it uses the shape you captured and the color set during creation.
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With Shape and With Color, you can draw and render one component, capture it, and then lay down a stroke of
identical components in sequence.

NOTE: A brush that has "With Color" enabled cannot be switched to transparent color.

Ignore Edge

If you are capturing a shape - such as a square - that is not round and would be cut off with a circular stamp, you will
want to use Ignore Edge. You may also want to apply Ignore Edge if you want your shape to flow tightly around
corners.
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Inverting textures

Jump to Mobile

The dark and light areas define the “bumps” and “crevices” that compose the texture. You may have a texture that
would be perfect for your needs, if only the darks were lights and the lights were darks. Use Invert to switch them.
You can immediately see the effect in the Brush Properties preview.

In the example above, the same texture was used, it was just inverted.

Inverting a texture in Sketchbook Pro for desktop
1. With a brush selected, tap  to open Brush Properties.
2. In Brush Properties, tap the Advanced tab, scroll down to Nib and open it, scroll down to Texture. 
3. Place a check in the Invert box to invert the texture.

Inverting a texture in Sketchbook for mobile devices
1. Open Brush Properties for the brush you want to update.
2. Tap the Advanced tab, scroll down to Nib and open it, scroll down to Texture
3. Switch the toggle to the right of Invert ON.

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties
https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties
https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties#mobile
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Using texture depth

Jump to Mobile

Setting overall texture depth

When adjusting Depth, you set how visibly the texture shows through the overall stroke. This option is only available
for the Standard brushes, Erasers, and Blend Mode brushes.

The brush preview updates as you make changes to Depth. The higher the value, the more visible the texture
becomes. A value of zero means no texture is visible.

Setting depth per tip

When Per Tip is checked, two new options appear, Depth with Heavy Pressure and Depth with Light Pressure. Set
these to change the visibility of the texture when pressing heavily or lightly.

To further create a unique textured brush stroke, turn on Offset Randomness.

Using texture depth in Sketchbook Pro for desktop
1. With a brush selected, tap  to open Brush Properties.
2. In Brush Properties, tap the Advanced tab, scroll down to Nib and open it, then scroll down to Texture. 
3. Do one of the following:

If you want to adjust how much of the texture shows through the overall stroke, use Depth.
or if you want the texture depth to be pressure-sensitive, tap to add a check and make Per Tip active and
set Depth with Heavy Pressure and Depth with Light Pressure.

Using texture depth in Sketchbook for mobile devices
1. Open Brush Properties for the brush you want to edit
2. tap the Advanced tab. Scroll down to Nib and open it, then scroll down to Texture
3. Do one of the following:

If you want to adjust how much of the texture shows through the overall stroke, use Depth.
or if you want the texture depth to be pressure-sensitive, tap to add a check and make Per Tip active and
set Depth with Heavy Pressure and Depth with Light Pressure.

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties
https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties
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Creating shape icons

Setting a brush shape as its icon can be useful for distinguishing between brushes in the brush palette. An example
is the Splatter set that is included with Sketchbook Pro by default - these brushes use their shape as the icon so you
can quickly choose between different splatter effects.

IMPORTANT: Sketchbook on mobile devices doesn't automatically using a shape for a brush icon. However
with the Premium Bundle you have the option to import your own icons.

You can only use a shape as an icon for a brush that has a shape applied to it.
1. Double-tap a brush to open Brush Properties
2. Tap the icon next to the brush name to open a menu of icons

3. Select Use shape as icon

If you decide you don't like using the shape as the icon, resetting it to default will revert the change if it is one of
Sketchbook Pro's pre-installed brush sets, or the brush set was packaged with its icons. If you would like to create
your own icon, check out Importing brush icons.

https://www.sketchbook.com/get-more
https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties
https://sketchbook.knowledgeowl.com/docs/resetting-brush-icons
https://sketchbook.knowledgeowl.com/docs/importing-brush-icons
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Importing brush icons

Jump to Mobile

Some things to know when creating brush icons:
Recommended size: 512x512px 
This size will accommodate different icon display sizes with different screen resolutions. If the image size is
larger than needed it will be scaled down to the required size, but if the image size is smaller than needed the
size won’t change and it may not look the way you want it to.
Supported image format: PNG, JPG, or TIFF
Custom icons cannot be assigned to brushes which only have basic (no advanced) properties.

Importing brush icons in Sketchbook Pro for desktop
1. With a brush selected, tap  to open Brush Properties.
2. Tap the brush's current icon - next to the brush name - to open the menu 

3. Select Import… 
Only PNG, JPG, and TIFF images can be imported as brush icons.

4. In the dialog that appears, locate and select the icons you want to bring into Sketchbook, then tap Open.

If you decide you don't like your new icon, you can reset the brush icon to default.

Importing brush icons in Sketchbook on mobile devices

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties
https://sketchbook.knowledgeowl.com/docs/resetting-brush-icons
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Importing brush icons in Sketchbook on iOS and Android requires the Premium Bundle

1. Tap the brush icon you want to change in either the Brush Palette or Brush Library. This will open the Brush
Properties window.

2. Tap the menu   

3. Select Change Icon 
Only PNG, JPG, and TIFF images can be imported as brush icons.

4. Browse to where you have saved the new icon, or import from the camera or photos.

If you decide you don't like your new icon, you can reset the brush icon to default. 

https://www.sketchbook.com/get-more
https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties#mobile
https://sketchbook.knowledgeowl.com/docs/resetting-brush-icons
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Resetting brush icons

Resetting a brush icon in Sketchbook Pro for desktop
1. In the Brush Palette or Brush Library, double-tap the brush with the icon you want to reset to open its Brush

Properties.
2. In Brush Properties, tap the brush icon.
3. From the menu below all the icon, tap Reset to default. 

Resetting a brush icon in Sketchbook for mobile devices

Changing brush icons in Sketchbook on iOS and Android requires the Premium Bundle

On mobile, to reset the brush icon you need to reset the entire brush to default. You cannot only reset the icon.
1. Open Brush Properties for the brush you want to edit
2. Scroll down to the bottom of the window
3. Tap Reset 

https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties
https://www.sketchbook.com/get-more
https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties
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Setting stylus tilt

Jump to Mobile

Stylus tilt helps your stylus create a stroke with the directionality you expect and controls how the stroke of the brush
is drawn.

Setting stylus tilt in Sketchbook Pro for desktop

Stylus tilt is found in Brush Properties in the Advanced tab. When set, it helps your stylus create a stroke with the
directionality you expect. It controls how the stroke of the brush is drawn.

1. In Brush Properties, tap the Advanced tab.
2. Scroll down to Stamp, tap Rotation > Rotation Dynamics, then select Controlled by stylus tilt. 

Without this set, the tilt of your stylus won’t have any effect on the strokes of your brush.
3. Tap-drag the Scaling Percentage slider to control the elongating of the brush stamp in conjunction with the tilt

of your stylus.
With a low Scaling Percentage, you have to tilt your stylus a lot more to achieve the tilting effect.
With a higher value, you don’t have to tilt your stylus as much to reach a similar effect.
If your stylus reverses to an eraser, Scaling Percentage will apply to both the eraser and stylus tip.

Setting stylus tilt in Sketchbook for mobile devices

Stylus tilt is supported with Apple Pencil and Apple Pencil Pro

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties
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Setting tilt options

Scaling creates the tilt effect when drawing. It controls the elongation of the brush stamp. The higher the value, the
more elongated the stamp.

You can set tilt scaling for any brush; however, it will only generate an effect with Apple Pencil and Apple Pencil Pro
as these styluses have built-in tilt functionality.

Scaling goes from a minimum value of 100% (meaning that the brush stamp won't change no matter how much you
tilt your stylus) to a maximum value of 400% (meaning the brush stamp is elongated and enlarged to a maximum of
4 times its original size when you tilt your stylus to an extreme).

tilt scaling 100% tilt scaling 400%

1. open Brush Properties
2. Expand the Stamp section. Below Rotation, you will see Tilt.
3. Drag the Scaling slider to control the elongating of the brush stamp in conjunction with the tilt of your stylus.

With a low Scaling value, you have to tilt your stylus a lot more to achieve the tilting effect.
With a higher value, you don't have to tilt your stylus as much to reach a similar effect.

Barrel roll

Sketchbook supports barrel roll with Apple Pencil Pro. As you rotate the barrel of your Apple Pencil Pro the brush
stamp will rotate accordingly. This can allow you to more precisely place stamps and decals, or create calligraphy
effects with chisel-tipped brushes.

Barrel roll is paired with stylus tilt in Brush Properties. If you have an Apple Pencil Pro, you will see the rotation
dynamics option "Stylus Tilt and Roll". Some brushes such as chisel-tipped markers have stylus tilt enabled by
default, or you can enable (or disable) it based on your preference.

https://sketchbook.knowledgeowl.com/docs/introduction-to-brush-properties#mobile
https://sketchbook.knowledgeowl.com/docs/connecting-styluses-for-mobile-users#ios
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Tools in Sketchbook

Jump to Mobile

We have an assortment of tools to help you create your drawing. The version of Sketchbook you are running will
determine the tools and their location. In most versions, the main repository for tools is the toolbar.

Using tools

When a tool is active, the icon is highlighted blue.

Using multiple tools

Some tools in Sketchbook can be used in combination with others. When you see a tool icon outlined in blue (not all
blue), it means two tools are active. The outlined tool is the secondary tool.

For an example of two active tools, let’s say you are working in Symmetry, and want to draw a straight line. Select
Guides, then Ruler. Symmetry is still outlined in blue, it is now the secondary tool. The Guides icon is fully blue, it is
the primary tool. Both are active.

Exiting a tool

Now, what happens when you’re finished with one tool, but not the other? Easy – tap on the tool you’re finished with,
say Symmetry.

This makes it active (fully blue). Tap it again to exit from the tool. Notice it no long has a blue outline. Now, Ruler is
the only active tool (fully blue).

Tools in Sketchbook Pro for desktop

There are fill, guide, symmetry, and text tools, as well as cropping, transform, perspective, shape, and stroke tools.
There are also an assortment of editing tools.

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/flood-fill
https://sketchbook.knowledgeowl.com/docs/rulers-and-guides
https://sketchbook.knowledgeowl.com/docs/symmetry
https://sketchbook.knowledgeowl.com/docs/text
https://sketchbook.knowledgeowl.com/docs/crop-to-a-selection
https://sketchbook.knowledgeowl.com/docs/transforms
https://sketchbook.knowledgeowl.com/docs/perspective-guides
https://sketchbook.knowledgeowl.com/docs/shape-tools
https://sketchbook.knowledgeowl.com/docs/steady-and-predictive-stroke
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Tool selection

Pick a tool using one of the following methods:
Tap a tool in the toolbar to select it. Some tools have a contextual secondary toolbar containing additional
tools. 

Use the lagoon marking menus – tap-hold the icon to display the radial menu options and make your choice.
Marking menu options will be chosen with a gesture in that direction, they do not have to be tapped. 

Pen Mode (Windows only)

When Pen Mode  is enabled, only your stylus will make marks on the canvas, you will not be able to draw with
touch. This can be useful to people using a 2-in-1 laptop or a tablet PC who may rest their hand on the screen and
wish to avoid inadvertent marks on the canvas.

When Pen Mode is on, you can still interact with the palettes and menus using touch, but the canvas will not
recognize touch. Pen Mode is only available on Windows (as there are no touchscreen Macs).

Tools in Sketchbook for mobile devices

The version of Sketchbook you are running and device determine the tools and location of these tools.

For tablet users

All your tools are in the main toolbar. You will also find selection, symmetry, shapes, fill, transforms, text, image
import, guide tools and time-lapse recording.

For handheld device users

https://sketchbook.knowledgeowl.com/docs/toolbars
https://sketchbook.knowledgeowl.com/docs/basic-ui-elements#lagoon
https://sketchbook.knowledgeowl.com/docs/intro-to-selection-tools#mobile
https://sketchbook.knowledgeowl.com/docs/symmetry#mobile
https://sketchbook.knowledgeowl.com/docs/shape-tools#mobile
https://sketchbook.knowledgeowl.com/docs/flood-fill#mobile
https://sketchbook.knowledgeowl.com/docs/transforms#mobile
https://sketchbook.knowledgeowl.com/docs/text#mobile
https://sketchbook.knowledgeowl.com/docs/importing-images#mobile
https://sketchbook.knowledgeowl.com/docs/rulers-and-guides#mobile
https://sketchbook.knowledgeowl.com/docs/time-lapse-recording
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All your tools are found under the Tools menu . Tap  in the toolbar to choose for a collection of tools for
helping you build your sketch. You will also find selection, symmetry, shapes, fill, transforms, text, image import,
guide tools and time-lapse recording.

https://sketchbook.knowledgeowl.com/docs/intro-to-selection-tools#mobile
https://sketchbook.knowledgeowl.com/docs/symmetry#mobile
https://sketchbook.knowledgeowl.com/docs/shape-tools#mobile
https://sketchbook.knowledgeowl.com/docs/flood-fill#mobile
https://sketchbook.knowledgeowl.com/docs/transforms#mobile
https://sketchbook.knowledgeowl.com/docs/text#mobile
https://sketchbook.knowledgeowl.com/docs/importing-images#mobile
https://sketchbook.knowledgeowl.com/docs/rulers-and-guides#mobile
https://sketchbook.knowledgeowl.com/docs/time-lapse-recording
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Undo and redo

Jump to Mobile

If you make a mistake or an unwanted change, it can be easier to simply undo than it is to erase. The version of
Sketchbook you're running and the capabilities of your device will determine the number of levels of undo and redo
available.

Undoing and redoing in Sketchbook Pro for desktop
To undo the previous action, in the toolbar or from the lagoon tap  or press Cmd+Z on macOS or Ctrl+Z on
Windows.
To redo an action, in the toolbar or from the lagoon tap  or press Shift+Cmd+Z on macOS or Ctrl+Y on
Windows.

Setting your maximum level of undos

Not available on iOS or Android

Sketchbook Pro gives you the ability to set the maximum number of times you can go back and undo something
within the app. We recommend a number within the range of 2-50. The default is 50; however, if you don’t see
yourself needing to go back that many steps, you can change this value to something like 25 and free up the memory
that would otherwise be used.

Changing the number of undos only takes effect once a new file is created or another one is opened. We
recommend you exit and restart Sketchbook Pro to ensure the change has taken effect.

You can change the number of undos in the General tab of Preferences.

Undoing and redoing in Sketchbook for mobile devices

The memory available to Sketchbook at the time determines how many undo and redos are available. To maximize
available memory, shut down other apps running in the background.

For handheld/phone device users, tap , then  to undo an action or  to redo.
For tablet users, in the toolbar, tap  to undo an action or  to redo.

The default screen corner hotkeys are also set to undo and redo
double-tap the lower left corner for undo
double-tap the lower right corner  for redo

You can customize your tap and corner settings for undo and redo in Preferences.

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook#general
https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook#gestures
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Adding an image

Jump to Mobile

In Sketchbook, you can import TIFF, JPEG, PNG, PSD, BMP, and GIF image files.

Importing an image in Sketchbook Pro for desktop

An image can be inserted onto the current layer or imported onto a new layer. Once an image is added, the Transform
puck appears so that you can reposition, rotate, and or scale the image.

Note: if you use File > Open, or open the image with Sketchbook Pro from File Explorer or Finder, the
image will not be imported, it will be opened as a new canvas.

To import an image to your existing canvas:
Select File > Add Image, then select your file.
or, in the Layer Editor, click  , then select a file.

To automatically add an image to a new layer, ensure that the Preference Add Image: import into a new layer is
checked. To always add an image to the current layer, ensure that the preference Add Image: import into a new layer
is not checked.

Once an image added to a layer, it is rasterized into the layer. You can no longer rotate, scale, or move it separately
from the rest of the layer without using selection and transform. If you do not like its placement, choose to undo it
and try again.

Adding an image in Sketchbook for mobile devices

Importing an image as a new layer in an existing canvas

1. In the toolbar, tap  Import Image.
2. Tap  to launch your File browser and select a file, or choose to import from Photos or take a new photo using

the camera.

When the image imports, you'll automatically be put in the Transform workspace. Use the tools to stretch, move,
scale, rotate, and/or flip the image. 

Tap-drag the image to freely move it in any direction on the canvas.
Tap  to nudge the content one pixel at a time, by tapping an arrow or tap-drag from the middle to move in any
direction or on an arrow to move in that direction.
Tap  to flip the image vertically.
Tap  to flip the image horizontally.

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/transforms
https://sketchbook.knowledgeowl.com/docs/intro-to-layer-editor
https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook#general
https://sketchbook.knowledgeowl.com/docs/transforms#mobile
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Tap  to rotate the image counter-clockwise.
Tap  to rotate the image clockwise.

When you are happy with the placement of the imported image, tap  to accept the changes

Importing an image as a new canvas

From the Gallery, tap  and select either:
 New from Image - launches your Files browser for you to select the image you want to import. A new canvas

will open with the selected image
 Add Image to Gallery - launches your Files browser for you to select the image you want to import. Once the

image is selected you will return to the Gallery
 Add Scans to Gallery - to use the scan sketches tool

https://sketchbook.knowledgeowl.com/docs/gallery-in-sketchbook
https://sketchbook.knowledgeowl.com/docs/scanning-sketches
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Text

Jump to Mobile

Though Sketchbook is not a writing or typography app, text is an integral part of visual communication. Sketchbook
includes simple text features to support the addition and of titles, comments, and captions to any image.

Text in Sketchbook Pro for desktop

Font support

Sketchbook Pro supports native and system fonts on Windows and macOS. Sketchbook Pro also supports most
downloadable font sets, including TrueType, OpenType or PostScript fonts. After installing new fonts to your
hardware, restart Sketchbook Pro to view them in the font menu in the Text Editor.

Creating Editable Text Layers

Text can be added by tapping the Text icon in the toolbar.

Adding text creates Text layers in your layer stack. Text layers exclusively store text data with font, style and color
settings. You cannot draw on a Text layer.

Text layers can be identified by a ‘T’ icon on the left side of the layer preview, which indicates that the text can be
edited. Standard features such as Quick Transform, layer visibility, layer opacity and blend modes can be applied to
Text layers.

To edit an existing Text layer, tap on the Text layer marking menu  and gesture down to the right to Edit Text
layer.

https://app.knowledgeowl.com/#mobile
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� Text layers will only remain editable when saved in Sketchbook Pro’s native TIFF format. When Text
layers are saved in PSD format, the layer will be rasterized.

Visibility and layer opacity of the Text layer can be adjusted the same as other layer.

Brush strokes and other image features cannot be applied to a Text Layer until it is rasterized to a regular, paintable
layer.

The Rasterize Text Layer option can be found in the Text layer marking menu . Once a layer is rasterized, the text
is converted to pixels and is no longer editable.

Using the Text Editor

Type or paste text into the body of the text editor. How text appears on canvas differs from how it appears in
the editor. In the editor, text will automatically wrap to fit in the window, but only explicit Returns will apply
when the text is rendered to layer.
To change the font, select the text and pick the desired font from the Font pulldown menu.
To change size, select the text and pick the size from the Size pulldown menu.
To apply styles:

On Windows, select the text and activate Bold, Italics, Underline or Underscore buttons.
On Mac, use the Typeface pulldown menu (not all fonts will have all Typeface options).

To change colors, select the text, and tap on Color Chip to select colors with the Color Editor.
When done, tap OK.
Position the text on the canvas using the Transform puck and tap the  icon when done.
The Text layer will appear above the last active layer in the stack.

Transforming text

Once you've created text with the Text Editor and tapped "OK", you are put in Transform mode on the canvas. Text
automatically appears in the center of the canvas, use the Transform puck to move, scale, rotate, flip, or distort it.

https://sketchbook.knowledgeowl.com/docs/transforms#puck
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Font size determines how much you can scale a font. A font size of 12 cannot be scaled up as much as one set to
24. A font of 12 cannot be scaled down as much as one set to 5. To scale a font further, return to the Text window
and increase/decrease the font size.

Editing an existing text layer

If you want to change the text, be it a spelling mistake, to change the font, font size, make something bold, italicized,
or underlined, or to change the color, use the Edit Text Layer window.

1. In the Layer Editor, at the text layer you want to change, click .
2. Select  Edit Text. This re-opens the Text Editor window for further editing.

Rasterizing a text layer

Rasterizing permanently converts your text to pixels, allowing you to manipulate it like a paint layer.
1. In the Layer Editor, tap-hold the marking menu .
2. Select  Rasterize Text Layer.

Once text is rasterized,  Edit Text can no longer be used.

Using text in Sketchbook for Android and iOS

To add text, select the Text Tool from the toolbar.

On mobile phones, it will be nested under the tools icon.
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Before creating text, it is a good idea to make sure the area where text is to be placed is visible on your screen, as
you will not be able to adjust the canvas view while you're in the Text Tool.

The Text Tool presents a text toolbar for text entry, text settings and positioning. Tap on these tools to make all your
edits, using two-finger gestures to move, scale and rotate the text.

 Text editor - tap to enter and edit text
 Font - tap to present and select your fonts
 Color - tap to open the Color Editor
 Transform - tap to non-proportionally adjust or distort text
 Nudge - tap to present a puck to constrain vertical or horizontal moves freely or one pixel at a time.
  Flip - flip text vertically or horizontally
  Rotate - rotate text clockwise or counterclockwise.

When complete, tapping Done will apply the final text to a new layer.

Adding custom installed fonts to Sketchbook on iOS

If additional non-system fonts have been installed to an iOS device, these can be added to the Sketchbook font list.
You'll first have to have installed the fonts on your device. See information from Apple on how to do that here.

Then to add the fonts to Sketchbook:
1. Enter the Text tool
2. Tap  Fonts
3. tap on the  icon in the top right of the Font list window. This will open a new dialog to search and select the

fonts you wish to add.

Adding custom installed fonts to Sketchbook on Android

https://support.apple.com/guide/ipad/install-and-manage-fonts-ipad952422ba/ipados
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Additional fonts can be added to the app by tapping the  Fonts and then the  menu in the upper right of the font
list window.

Tap to import TrueType font files you have downloaded to your device.

Sketchbook on AndroidOS only supports TrueType fonts. You are responsible for making sure you
have the correct usage rights for the fonts in your work. Google Fonts is a great resource for royalty-
free fonts.

You can add a maximum of 50MB of font files to Sketchbook. Once you reach the maximum, you will need to delete
some added fonts in order to add more. It is not possible to delete the six default fonts.

Your custom fonts are saved as part of your Sketchbook Preferences, along with your brush customizations, color
palettes, and UI customizations. If you uninstall the app or clear the app's data, your Preferences will be reset to the
defaults and your customizations will be gone. It is a good idea to make a back up of your Preferences.

https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook#mobile
https://sketchbook.knowledgeowl.com/docs/backing-up-preferences#mobile
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Flood fill

Jump to Mobile

To fill an area with paint, tap the paint bucket  icon, then tap a region to fill. To successfully fill an area, the area
must be closed, which means it has no gaps of transparent pixels.

In this example, the first image has a closed area. The second shows a successful fill. The third is the finished
product. The fill layer’s opacity was reduced to mute the fill and allow an underlying layer to peek through.

If the fill area is not closed, the fill will invade areas you didn’t intend to color. In the example below, the area in the
first image is NOT closed. When a fill is applied in the center it also affects the background due to the shape not
being closed. 

Brushes with a solid stamp are good choices for creating areas for fill (eg: Fountain Pen, Technical
Pen). A texture brush could still create a closed shape, but the areas of transparency created by the
texture are likely to affect the fill results.  

When you tap  the Flood Fill toolbar appears containing fills an assortment of tools. Use the tools to change the
type of the fill, set fill tolerance, change whether the area to fill is sampled from the active layer or all layers, or adjust
settings for gradient fills.

Types of Fill

https://app.knowledgeowl.com/#mobile
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 Solid Fill

Fills an area with paint.

 Gradient Linear Fill

The gradient color ramp applies linearly from your first tap (origin) to the end of the drag (destination). This
establishes the direction and size of the ramp. Fill manipulators can be added, moved, and removed.

 Gradient Radial Fill

The gradient color rap radiates from your first tap (origin) to the end of the drag (destination). Fill manipulators can
be added, moved, and removed.

Fill Tolerance

Did the fill cover more area than you wanted? Did it not cover enough? Change the tolerance of your fill to determine
the range of the area/colors affected.

The minimum tolerance, 1, selects and fills only pixels of that color value. The maximum tolerance, 255, selects and
fills all pixels within the region.

At higher levels of tolerance, the region will need to be closed with a more solid line - for example, brushes with soft
edges, texture, and/or opacity will not create a closed area for a fill with tolerance set at 255.

Sampling layers
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Sampling refers to which pixels the fill tool will reference when determining the boundaries of the fill. You can choose
to sample from the current layer or all layers for your fill:

  Sample One Layer references only the pixels on the active layer for the fill's boundaries.
  Sample All Layers references pixels on all visible layers for the fill's boundaries. The contents of hidden
layers will not be referenced.

In the first image below, we used Sample One Layer, so the doll's head was the only area used to define the fill.

In this section image, we used Sample All Layers and tapped in the area within the head, where the arm is visible. So,
though the lines of the arm are on a different layer, they help define the filled area.
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Using Flood Fill in Sketchbook Pro for desktop

1. Fill options
2. Tolerance
3. Sample All Layers
4. Reverse
5. Cancel and OK

Flood filling an area

In the toolbar, tap .
Choose your fill type - solid, linear gradient, or radial gradient.
Tap  to fill based on sampling the current layer, or  to sample all visible layers.
Tap the area you want to fill. The fill will automatically apply.

If it is a gradient fill, you have an opportunity to adjust the handles before tapping  to accept or  to
cancel.

Changing fill tolerances

In the Fill toolbar, tap-drag the slider to change the fill tolerance.
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Increase the tolerance to increase the range of colored pixels affected by the fill.
Decrease the fill to reduce the range of affected pixels.

Creating a gradient area

You can start a fill and then set the gradient colors using the handles, or select a pre-defined gradient fill from the
Color Puck's Gradient Fill Palette.

1. Select the Flood Fill tool ,
2. Select either linear or radial gradient fill from the Flood Fill toolbar.
3. Click-drag to place the gradient manipulators for the fill where you want them. You can also single-click the

area to be filled, the gradient manipulators will be placed automatically.
4. To refine your gradient:

a. Change the color of any manipulator by tapping it and then selecting another color.
b. To select a different gradient fill from the Gradient Palette, tap any manipulator and then select another

gradient from the palette.
c. Tap-drag any manipulator to reposition it.
d. To add a manipulator, tap along the axis between manipulators.
e. To delete a manipulator, tap the manipulator to activate it, then tap the  above it to remove it.

Inverting the direction of a gradient fill

While your gradient fill is still active - before tapping  to accept - click  to invert the order of the fill manipulators.

Using Flood Fill in Sketchbook for mobile devices

Filling an area

1. If on a tablet, tap  Fill.
a. If on a handheld device, tap , then  Fill.

2. Select one of the fills. The default is   Solid Fill, which will apply immediately when you tap on the canvas
3. If using a gradient fill, you can further refine your gradient before it applies to the canvas

a. Tap an area to start the fill

https://sketchbook.knowledgeowl.com/docs/color-palettes#gradient-palette
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b. To add a manipulator, tap anywhere along the fill line.
c. To move a manipulator, tap-drag it to the new position.
d. To remove a manipulator, tap-drag it away from the fill line. It will disappear.
e. Tap to  accept the fill or  to cancel.

Changing flood fill tolerance

In the Fill sub-toolbar, tap-drag the Tolerance slider to change the value. If you're using a handheld/phone device, first
tap  to expose the tolerance slider.

Increase the tolerance to increase the range of colored pixels affected by the fill. Decrease tolerance to reduce the
range of pixels affected.

Sampling one or all layers

The Sample Layers icon is at the right end of the tolerance slider. If you're using a handheld/phone device, first tap 
 to expose the options.

Select one of the following:
Tap  to fill based on sampling the current layer.
Tap  to sample all visible layers.
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Rulers and guides

Need help drawing a straight line, circle, ellipse, or curve? These guides can be found in the toolbar.
Ruler
Curved Ruler
Ellipse
French Curve (only in Sketchbook Pro on desktop)

Did you know you don't have to draw directly over a ruler or guide? Drawing anywhere in the canvas
draws a stroke along the edge of an active ruler or guide.

Ruler

Tap , then  to access the ruler.

How to use the ruler

Sketchbook Pro for desktop 

To pivot the ruler, tap-drag an end handle .
To move the ruler, tap-drag the center handle .
To snap the ruler to 0º or 90º, double-tap an end handle .
When finished using the ruler, tap  to exit the ruler. 

Sketchbook for mobile devices

Rotate the ruler with two fingers. The ruler will snap to 0º and 90º.
To move the ruler horizontally and/or vertically without changing its rotation, tap-drag with one finger.
To reset the ruler’s position, double-tap with one finger.
When finished using the ruler, tap the  icon again to disable it or tap .

Curved Ruler

Tap , then  to access the curved ruler.

Use for customizable curves. Adjust the curvature of this bendable ruler through direct manipulation. Draw curved
lines anywhere on the canvas, as your strokes will snap to the ruler.

Sketchbook Pro for desktop 

To scale the ruler, click-drag .
To rotate the ruler, click-drag and rotate .
To move the ruler, click-drag .
To move a ruler handle, click-drag a handle .
To exit the ruler, click .
To reset the ruler to the center of the canvas, double-click a handle .

https://app.knowledgeowl.com/#ruler
https://app.knowledgeowl.com/#curved-ruler
https://app.knowledgeowl.com/#ellipse
https://app.knowledgeowl.com/#french-curve
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Sketchbook for mobile devices

To change the shape of the ruler, tap-drag a handle with one finger.
To scale the ruler, pinch with two fingers within the ruler.
NOTE: If you pinch or expand outside the ruler, you will zoom in or out of the canvas.
To reset the ruler to its original size and position, double-tap within the ruler (not on a handle).
To retain the curvature, but fit the ruler within the view, double-tap a handle.

Ellipse

Tap , then  to access the ellipse guide.

Use to create ellipses, curves, and draw circles in perspective. As you rotate an ellipse, the minor axis is displayed to
line it up with your vanishing lines. Both the rotation and degree of the ellipse are displayed in the readout at the
bottom of the screen.

Sketchbook Pro for desktop 

To move the ellipse, tap-drag .
To rotate the ellipse, tap-drag .
To scale the ellipse, tap-drag .
To non-proportionally scale the ellipse, tap-drag .
To change the ellipse to a circle, double-tap either  to create a circle the size of the major axis, or  to
create a circle the size of the minor axis.
When finished, tap the  to exit the Ellipse tool.

Sketchbook for mobile devices

To move the guide horizontally and/or vertically without changing its rotation, tap-drag within the ellipse with 1
finger.
To change the rotation, within the ellipse and rotate with 2 fingers within the ellipse, or use the rotation 
handle.
To proportionally scale the ellipse, pinch or expand within the ellipse with 2 fingers.  
NOTE: If you pinch or expand outside the ellipse guide, you will zoom in or out of the canvas.
To change the dimensions in one direction, drag the dimension  handle.
To reset the ellipse to the default size and position, double-tap within the ellipse with 1 finger.
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To change the degrees of the ellipse, making it a circle, double-tap the dimension  handle.
To reset the rotation to zero degrees, double-tap the rotation  handle.

French Curve

Only available for Sketchbook Pro on desktop

Tap , then  to access the French Curve tool.
To move the French curve, tap-drag .
To rotate the French curve around its center, tap-drag .
To equally scale the French curve in all directions, tap-drag .
To flip the French curve, tap-drag .
To cycle through different French curves, tap , , or .
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Perspective guides

Jump to Mobile

There are four types of perspective guides:

 1 Point Mode

Create an image with a single vanishing point and a horizon line. Draw images that appear as if you are viewing
them head-on, such as looking down a street, train tracks, hallway, or at a building. Drag to reposition the vanishing
point and horizon.

 2 Point Mode

Create an image with two vanishing points and a horizon line. Draw images of an object with a corner facing you,
such as the corner of a building. The walls will recede to the vanishing points.

 3 Point Mode

Create an image with three vanishing points and a horizon. Draw images of an object that you are viewing from
either above or below. When you mouse over or drag a vanishing point, a horizon line (blue) and triangle connecting
the three points (light blue) appears.

https://app.knowledgeowl.com/#mobile
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 Fisheye Mode

Only available with Sketchbook Pro for desktop

Create a panoramic or hemispherical image with a very wide angle of view. Draw images of a scene viewed from a
convex mirror or lens.

This mode has five vanishing points: left, right, top, bottom, and center. The grid is composited of a horizon line,
vertical line, and circle. Curves intersect at the vanishing points. Moving the center point moves the entire grid.
Moving an edge point changes the circle’s radius.

Perspective guide tools

Snap and Unsnap

When enabled , strokes will be straight and constrained to being parallel to the horizon, perpendicular to the
horizon, and to the vanishing points.
When disabled , draw freehand curves, etc., without being constrained to straight lines. The guides are a
reference only and do not affect the stroke.

Horizon Line

You can reposition the blue horizon line by tap-dragging the vanishing point(s).  
NOTE: If the horizon line won't move, disable Lock perspective guides.
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Vanishing points

The selected Perspective Guide sets the number of vanishing points. Therefore, 1 Point Mode will have one, 2 Point
Mode will display two, and so on.

To move a vanishing point, tap-drag and reposition it. If the vanishing point cannot be moved, tap to unlock the
vanishing points, then tap-drag them into position.

Vanishing points can even be moved off the canvas to create a less dramatic camera angle. To do this, zoom out of
the canvas, then drag and reposition your vanishing points.

Locking vanishing points

When locked , the vanishing points are locked into place and there is no worry of accidentally moving them.
When unlocked , they can be repositioned.

Show and Hide perspective guides / horizon line

If you don't want to see the perspective guides on the screen, tap . The guides are still active, but the lines are not
visible. Tap  to display the lines again.

Accessing the Perspective tools in Sketchbook Pro

Tap  to access the Perspective guides.

The Perspective cursor

When you select a guide, the cursor changes to a dashed, three-line cursor.

As the cursor moves around the canvas, one of the dashed lines rotates to always point at the vanishing point.
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If you draw in the general direction of the vanishing point, your stroke will automatically snap to it.

Saving perspective guides

Only in Sketchbook Pro on desktop

The file format determines whether the location of the perspective guide is saved in the document, and will reappear
in the same location when the file is reopened.

To maintain the last location of the perspective guide, the file must be saved as a Sketchbook TIFF. Perspective
guide locations are not maintained if you save your file as PSD

Perspective Guides in Sketchbook for mobile devices

In the mobile (Android and iOS) versions of Sketchbook, you will have the following tools:

NOTE If you don't see the Perspective Guides icon  in the toolbar, tap-drag the middle of the toolbar to the left.
This will expose the icons on the right end of the toolbar, particularly when using your device in portrait mode, or a
smaller window or side-by-side mode.

Customize Grid

Tap , then set the following parameters:
Density - Sets the density of lines radiating from the vanishing points to create the perspective grid. The higher
the number, the more grid lines.
Opacity - Sets the visibility of the grid. The higher the number, the more visible the grid lines.



224

Infinite and Constrained Grid

Infinite Grid - the lines of the grid extend out, infinitely, from the vanishing point. 

Constrained Grid - the lines of the grid are constrained within a frame. 

Tap-drag the green handles to change the size and shape of the frame.

Resetting perspective guides

Perspective guides will maintain their location between canvases. If you want to reset the guides to the default, tap
Reset.
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Symmetry

Jump to Mobile

Use Symmetry tools to draw one side of something and have Sketchbook automatically mirror it and draw the other
side. Create flowers, mandalas, or other symmetrical objects. 

You can set whether strokes can cross over lines of symmetry, move the line of symmetry around the canvas, and
also lock the manipulators in place to avoid inadvertently moving your symmetry guides. 

The types of symmetry

 Horizontal

Horizontal symmetry  mirrors your drawing across the line of symmetry (Y-axis).

 Vertical

Vertical Symmetry  reflects your drawing above or below the line of symmetry (X-axis).

 Vertical and  Horizontal

You can combine the vertical and horizontal symmetry tools. Tap both  Vertical Symmetry and  Horizontal
Symmetry. Both icons will be blue, indicating both tools are active at the same time.

 Free Symmetry

Use  when you want to create mirrored symmetry on an axis that is not X or Y. The free symmetry tool can be
freely rotated to the angle you need.

 Radial

Use  with up to 16 sectors, to create patterns such as mandalas. To set the number of radial segments, either tap-
drag the slider or enter a numeric value in the option box in the symmetry sub-toolbar.

How to move the line of symmetry

By default the line of symmetry appears in the center of the canvas, but it can be moved. Tap-drag the manipulator 
 in the center to drag and reposition the center point and line of symmetry. Double-tap the manipulator to reset

the line of symmetry to the center of the canvas.

How to rotate the axis of symmetry (Radial and Free Symmetry)

Tap-drag the rotation manipulator  to rotate the axis of symmetry.

https://app.knowledgeowl.com/#mobile
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Accessing symmetry in Sketchbook Pro for desktop

In the main toolbar, tap  to access the Symmetry tools

1. Horizontal symmetry
2. Vertical symmetry
3. Free symmetry
4. Radial symmetry
5. Number or radial symmetry sectors
6. Extend/stop strokes at center line
7. Lock/unlock symmetry lines
8. Show/hide symmetry lines

Accessing symmetry in Sketchbook for mobile devices

On a tablet:

On a handheld:
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Shape tools

Jump to Mobile

In Sketchbook, Draw Style tools are there to help you create shapes such as ovals, circles, rectangles, and lines.

Draw styles "draw" using the active brush and active color.

The draw styles: 
 Line
 Rectangle (the starting point becomes one of the corners, depending on which way you draw)
 Oval (the starting point will be the center point of the oval)
 Polyline. Only in Sketchbook Pro for macOS and Windows. Double-tap the last point to complete your line.

Using shape tools in Sketchbook Pro for desktop

In the toolbar, tap  and then choose a Draw Style tool to help create shapes and lay down lines.
If you hold down the Shift key while using a Draw Style tool, the shape will be constrained - a line will be either
vertical or horizontal, an ellipse will be constrained to a circle, and a rectangle will be constrained to a square.

Once you are finished with the Draw Styles, tap the  icon again to exit the tools and return to freestyle stroke
mode.

NOTE: because Draw Styles are a tool, they are not restricted by Pen Mode. When Pen Mode is enabled you can still
create shapes on the canvas using touch.

Using shape tools in Sketchbook for mobile devices

Tap   to open Draw Styles. A sub-toolbar will appear, where you can choose the shape.

You can stay in the tool but minimize the toolbar by tapping .  The sub-toolbar will close by Draw Styles are still
active - you will notice  appears below the toolbar to indicate you are still in the Draw Styles tool.

To exit the tool, tap the Draw Styles icon again, or tap  .

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/brushes-in-sketchbook
https://sketchbook.knowledgeowl.com/docs/color-editor
https://sketchbook.knowledgeowl.com/docs/tools-in-sketchbook#pen-mode
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Steady and predictive stroke

Jump to Mobile

Sketchbook has two stroke tools to help create smooth and uniform strokes: Steady Stroke and Predictive Stroke.

Steady Stroke

Use  Steady Stroke to draw smoother strokes.

Think of Steady Stroke like painting with a brush that has long bristles. The longer the bristles are, the steadier the
stroke is in the direction you are 'pulling', producing a smoother stroke overall.

Steady Stroke has a level setting that determines the offset. The higher the setting, the longer the offset will be
between your cursor and the stroke.

To draw large smooth curves, increase the offset.
To draw small curves with tight turn radii, decrease the offset.

Increasing the offset will affect your stylus response time. When drawing short curves, if you have
difficulties try reducing the smoothness setting.

To return to freestyle stroke mode, tap the Steady Stroke  icon again to toggle it off.

Predictive Stroke

Predictive Stroke helps to improve your stroke quality by making some assumptions about your intent and adjusting
the drawn line accordingly. This tool can be particularly useful when drawing slowly, or if your hand isn't necessarily
steady.

Notice in this first image, how jagged the lines are. The second was made with Predictive Stroke.The lines are much
smoother and the intent of the strokes is captured nicely.

Want to draw a perfect ellipse, circle, triangle, rectangle, or line? With Predictive Stroke activated and Level set to for
or 5, draw any one of these on the screen and see the tool fix them.

Setting the level of smoothness

Use the smoothness Level slider to set just how much you want your stroke to be smoothed. The higher the number,
the smoother the stroke. A higher level also makes it easier for Sketchbook to recognize a circle, ellipse, or straight
line when drawing freehand. If you want to draw a straight line, sharp corners, a circle or ellipse freehand, set Level to
4 or 5. The higher the number the better the shape recognition.

Snapping

https://app.knowledgeowl.com/#mobile
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Predictive stroke tries to understand your objective when drawing shapes such as lines, triangles, rectangles, and
ellipses. However sometimes this can get in your way - an example is if you are trying to draw a straight line with a
slight angle, Predictive Stroke is likely to snap that angle to 0 degrees making it perfectly horizontal.

To avoid this problem, you can turn off snapping in the Predictive Stroke sub-toolbar.

Note: turning off snapping will not affect rectangular shapes, their angles will still snap to 45 degrees.

Effect of zoom on Predictive Stroke

Your view in the canvas can also influence the amount your stroke is changed. More detail is removed from your
stroke, making it smoother when you’re zoomed out. When zoomed tightly into your image, less detail is lost.

How to exit Predictive Stroke

To return to freestyle stroke mode, tap to exit Predictive Stroke.

Using Steady and Predictive Stroke in Sketchbook Pro for desktop

Using Steady Stroke

In the toolbar, tap to create a smoother stroke as you draw. Another toolbar appears with a slider.

Tap-drag the slider or enter a numeric value to set the offset between your cursor and the stroke.

Tap to exit the tool.

Using Predictive Stroke

In the toolbar, select .

Determine how much smoothing you want and set a value using the Level slider. High number for a lot or small for a
little. Remember that how much you’re zoomed in will have an affect.

Draw.

Tap to exit the tool.

Using Steady Stroke and Predictive Stroke in Sketchbook for mobile devices

Using Steady Stroke

In the toolbar, select Steady Stroke.
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Tap-drag the slider to set the offset between your cursor and the stroke

Draw.

you can tap to minimize the sub-toolbar and continue drawing with Steady Stroke

When finished, tap X to exit and turn off Steady Stroke

Using Predictive Stroke

In the toolbar, select Predictive Stroke.

Determine how much smoothing you want and set a value using the Level slider. High number for a lot or small for a
little. Remember that how much you’re zoomed in will have an effect.

Draw.

you can tap to minimize the sub-toolbar and continue drawing with Predictive Stroke

When finished, tap X to exit and turn off Predictive Stroke



232

Transforms

Jump to Mobile

Transforms are used for moving, rotating, scaling, flipping, mirroring, and distorting pixels. 

If you're looking for moving, rotating, or zooming into the canvas read Changing your view.

Transform tools in Sketchbook Pro for desktop

In Sketchbook Pro, there are two main tools for transforming your content:  Quick Transform and  Transform.

Distinctions between Quick Transform and Transform:
Quick Transform enables combining selection and transform into a single tool.
Transform can be constrained using the Shift key, while Quick Transform cannot.
Quick Transform uses the Transform puck to manipulate the content, where Transform uses manipulator
handles.

Both tools will allow transforming multiple full layers at the same time. In the Layer Editor, select one or more layers
(use Shift to select consecutive layers and Ctrl / Command to select non-consecutive layers) before launching
Transform or Quick Transform. It is not possible to transform a selection across multiple layers. 

Using  Quick Transform

Tap  in the toolbar and choose one of the Quick Transform tools:

1.  Rectangle - make a rectangular selection, when you complete the selection the puck will automatically
appear.

2.  Lasso - make a lasso selection, when you complete the selection the puck will automatically appear.
3.   Transform puck - immediately launches the transform puck to transform the entire layer. However if you

have separately made a selection using selection tools, the effects of the transform puck will only apply to the
selection.

The default Quick Selection tool is Lasso. If you change the tool to Rectangle or the Transform Puck, Sketchbook Pro
will remember your choice throughout the session. It will return to the default after exiting and restarting the app.

The Transform puck 

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/changing-your-view
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To move a selection, highlight the outer circle. Tap, then drag to move the layer around the canvas.

To rotate a selection around its center, highlight the middle circle. Tap, then drag in a circular motion in the direction
you want to rotate.

To non-proportionately scale a selection, highlight the upper part of the inner circle. Tap, then drag in the direction
you want scaled.

To scale a selection bigger or smaller, highlight the inner circle. Tap, then drag to scale up or down to display the
percentage scaling.

Using  Transform

In the toolbar, select  Transform to move, scale, or distort content. The Transform tool has a sub-toolbar where
you can differentiate between scaling or distorting the selection.
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Transform applies a bounding box around the content that will be transformed. The bounding box will automatically
surround the pixels of the active layer(s) unless a selection is made first using selection tools. Areas of full
transparency are not included in the automatically generated bounding box.

Moving

Either  Scale or  Distort can be used to move a selection. In the toolbar, select  Transform and then mouse
over inside the selection area - your cursor changes to . Tap-drag within the selection to freely re-position the
selection.

Constraining your movement

Press the Shift key to constrain your movement to straight vertical or horizontal. Once you move a direction, the
constraint is in place for that axis. To constrain the selection to the other axis, release the Shift key, then press-hold it
again as you move in the new direction.

Rotating

Either  Scale or  Distort can also be used to rotate a selection. In the toolbar, select  Transform and then
mouse over outside the selection area - your cursor changes to . Tap-drag outside the selection area to freely
rotate the selection.

Using Scale 

In the toolbar, select  Transform, then  Scale. A bounding box appears surrounding the content.
Tap-drag a  handle to freely scale the selection.
If you wish to constrain the scale, press and hold the Shift key while tap-dragging a  handle.

Using Distort

1. In the toolbar, tap  Transform, then  Distort. A bounding box appears surrounding the content.
2. Tap-drag the outer handles  to change the bounding box and distort the content inside it
3. Tap-drag the central handle, Bias, to foreshorten or change the proportions of the selection

For more detailed information, see Distorting a selection.

Using transforms in Sketchbook for mobile devices

Tap  in the toolbar to enter the Transform workspace. When in this mode, you can proportionally scale, move,
rotate, and distort an active selection or an entire layer, using gestures or your stylus.

https://sketchbook.knowledgeowl.com/docs/intro-to-selection-tools
https://sketchbook.knowledgeowl.com/docs/distorting-a-selection
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Transform will apply to the entire active layer if no selection has been made first. To transform only a part of a layer,
use the selection tools to define the area before entering Transform mode.

When finished, tap Done or  in the toolbar to exit Transform mode.

When transforming, any content that is expanded beyond the edge of the canvas will be cropped off.
Undoing this action will restore the content; otherwise, it will be lost.

Moving content

Tap  in the toolbar to enter Transform mode.
In the Transform workspace, tap-drag with your finger to freely move the content
 Or tap  to launch the nudge puck for more constrained movement:

Tap-drag one of the arrows to move the content along the axis selected.
If you select either arrow along the sides, your movement is constrained to left and right.
If you select either arrow at the top or bottom of the puck, your movement is constrained to up and
down.

Tap-drag within the middle of the puck to move freely in any direction
When finished, tap Done to exit Transform mode.

Scaling content

Tap  in the toolbar to enter Transform mode.
With two fingers, pinch the canvas to decrease scale or expand to increase scale. 

Flipping a layer

Tap  in the toolbar to enter Transform mode.
Use  and  to flip the content either horizontally or vertically.

Rotating a layer

Tap  in the toolbar to enter Transform mode.
Use a two-finger rotation gesture to freely rotate the content. To constrain rotation to 45 degree increments,
use  for clockwise rotation and  for counterclockwise rotation.

https://sketchbook.knowledgeowl.com/docs/intro-to-selection-tools#mobile
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Transforming a canvas

Jump to Mobile

Learn how to transform canvases to rotate, scale, and/or reposition them, using gestures or various tools in the
different versions of Sketchbook.

For how to use the Transform tool, see How to use transforms.
If you're looking for how to resize an image, not the entire canvas, see How to resize images.

Transforming your canvas in Sketchbook Pro for desktop

In the menu bar, in the Image menu, you will find tools for flipping and mirroring your canvas.

To flip the canvas vertically, select Image > Flip Canvas Vertically.

To flip the canvas horizontally, select Image > Mirror Canvas.

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/transforms
https://sketchbook.knowledgeowl.com/docs/resizing-images
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Transforming your canvas in Sketchbook for mobile devices

Rotating your canvas

Rotate an existing canvas in the Gallery
1. Enter the Gallery and scroll to the piece you want to rotate. Note: canvas rotation tools are not available in

Album view
2. Above the piece, tap  to rotate the canvas clockwise in 90 degree increments. When the canvas looks the

way you want it to, tap it to open it.

Flipping the canvas

Flipping the canvas can be done from the canvas view (in canvas). Tap the marking menu  at the bottom of the
screen and choose .

https://sketchbook.knowledgeowl.com/docs/gallery-in-sketchbook
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Time-lapse recording

Time-lapse recording is only available in Sketchbook on Android and iOS

Time-lapse recording captures still frames while you are drawing and then stitches them together in a video. Every
16 frames captured gives you one second of footage. As you draw, if you zoom in to do detailed work, the recording
zooms in, too.

Warning

If you keep Time-lapse running for a long period, the size of the content may exceed the storage space
on your device. If this happens the file will not save and your Time-lapse will be lost. Keeping Time-lapse on for
hours is generally not a good idea.

If you're on a handheld/phone device, in the toolbar, tap , then Time-lapse .

If you're on a tablet, in the toolbar, tap .

Tap the canvas and start sketching.

When finished drawing, tap the  icon again.

This window will appear, providing feedback on the playback time, captured frames, and session duration, so you
can keep track of the length of your video.

To save your recording, tap Save to Photo Library.
To continue recording, tap Continue in the upper right corner of the window to return the canvas and continue
the recording in progress.
To delete the recording and exit the tool, tap Discard.
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Saving your recording

The file format of the saved recording depends on your device platform. The resolution of the movie is dependent on
the device's screen size.

Android - MP4 file
 iOS  - MOV file (H.264 movie) 

Where is my recording

If you would like to share the recording, this is where you can find it:
Android - Pictures > Sketchbook Gallery
iOS - Photos (Photo Library)

Troubleshooting

When using Time-lapse, if your device enters sleep mode or you leave the app, the captured session is ended and the
movie is saved. You can bring any saved captures into a video editing package to create a movie from them.
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Introduction to selection tools

Jump to Mobile

There are an assortment of Selection tools. Use some for choosing a type of selection, and others to help once a
selection has been made.

You can also use a selection like a mask. You can select an area and constrain the paint to the selection. You won’t
need to worry about paint going outside the bounds of the selection.

The different types of selection

The version of Sketchbook you are using determines the types of selection available.

 Lasso

Tap-drag and trace around the object to select it.

 Rectangle

Place your finger where you would like the bottom right corner of the selection to be, then tap-drag to expand the
selection.

 Oval (Mac/Windows only)

Place your finger where you would like the center of the selection to be, then tap-drag to expand the selection.

 Polyline (Mac/Windows only)

Click to add points to the polyline. When the cursor reaches back to the first point, it will change to indicate that this
click will complete the selection. Alternatively, you can automatically close a polyline selection with a double-click.

 Magic Wand

Select a region based on the color of the pixels. Use the Tolerance slider to expand the range of color selected (by
increasing the tolerance) or limit it (by deceasing the tolerance).

Sample one layer/Sample all layers 
When  is displayed, you will be selecting from pixels on the active layer. Tap the icon to change it to  and

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/using-a-selection-like-a-mask
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select based on pixels from all visible layers.

Selection editing tools

 Replace

Tap Replace, then tap-drag to replace the current selection with a new one.

 Add

Tap Add, then tap-drag or click an area to add to the current selection. Use this when your selection is almost perfect
and it would be easier to add to it than to start again.

 Remove

Tap Remove, then tap-drag or click areas to remove them from the current selection. Use this when you’ve included
too much content to your selection and it would be easier to remove it than to start again.

 Invert

The current unselected content will become the selection, once you’ve tapped Invert.

 Deselect

Tap Deselect to deselect everything. Use this when finished with the Selection tools or if you need to start over.

Remember, you can use your selection as a mask and paint or fill it, distort, or crop it. To select the entire layer,
select Edit > Select all or press Cmd+A on Mac or Ctrl+A on Windows.

NOTE: Did you know that you could use another tool, while still in selection mode? See Using a
selection like a mask for more information.

Using  Quick Transform (Mac and Windows only)

Quick Transform combines selection and transform into a single task. In the toolbar, tap  to accesses the Quick
Transform tools.

 Rectangle (hotkey M) – tap-drag to select a rectangular area.
 Lasso (hotkey L) – tap-drag to select a closed, freeform area.

Once you've made a selection, the Transform puck automatically appears for moving, rotating, and/or scaling the
selected content.

https://sketchbook.knowledgeowl.com/docs/using-a-selection-like-a-mask
https://sketchbook.knowledgeowl.com/docs/transforms
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Selection tools in Sketchbook for mobile devices

Once you access the Selection tools on your device, the workflows and tools are the same.
On a handheld device, in the toolbar, tap , then .
On a tablet, in the toolbar, tap  and select a tool from the Selection toolbar.

Some of the tools have additional options. Use any additional selection editing tools you need.

1. Lasso selection
2. Rectangle selection
3. Magic Wand selection

On a phone device, the three selection icons are grouped together. Tap this icon to select another option
4. Selection editing tools are grouped under this icon: replace, add, subtract, and tolerance setting for Magic

Wand
5. Nudge the active selection
6. Invert the active selection
7. Clear the active selection
8. Crop the canvas to the active selection
9. Accept the selection and minimize the sub-toolbar

Tap  to dismiss your selection and exit the tool

The selection tool isn't working!

If you create a selection and the selection line immediately disappears, your selection editing tool is probably set to
remove/subtract. Change it to replace or add in order to make a selection.

selection is set to  subtract

selection is set to  replace
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Adding to a selection

When making a selection, sometimes you don’t grab everything the first time. When this happens, instead of re-
selecting everything, use  Add.

Adding to a selection in Sketchbook Pro for desktop

Once you’ve made a selection, in the selection sub-toolbar tap  , then either tap-drag to add to your selection or
when using Magic Wand selection, tap other areas. If you are using Magic Wand,  you may need to increase the
Tolerance to add similar pixels to your selection.

Adding to a selection in Sketchbook for mobile devices

Once you've made a selection, in the selection sub-toolbar tap . Then either tap-drag to add to your selection or
when using Magic Wand selection, tap other areas. If you using Magic Wand,  you may need to increase the
Tolerance to add more similar pixels to your selection.
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Repositioning your selection

Repositioning your selection in Sketchbook Pro for desktop

To only move the active selection (NOT the content within the selection), mouse over the selection area until the
cursor changes to a hand . Then tap-drag anywhere within the canvas.

To move the selection and its content, first, tap Quick Transform  and ensure  is active. Make your selection,
then tap  and use the puck to move, scale, or rotate the content. Also see Cutting and pasting.

Repositioning your selection in Sketchbook for mobile devices

To only move the selection (NOT the content within the selection), once you have made a selection, in the Selection
toolbar, tap  Nudge.

To free-form move the selection, drag with your finger in the middle of the puck to place the selection.
To move the selection a pixel at a time , tap the arrow for the direction you want. Each time you tap it, the
selection is moved one pixel in that direction.

When finished with your selection, tap  to accept the changes or  to decline.

https://sketchbook.knowledgeowl.com/docs/transforms#quick-transform
https://sketchbook.knowledgeowl.com/docs/transforms#quick-transform
https://sketchbook.knowledgeowl.com/docs/transforms#quick-transform
https://sketchbook.knowledgeowl.com/docs/cutting-and-pasting
https://sketchbook.knowledgeowl.com/docs/transforms#quick-transform
https://sketchbook.knowledgeowl.com/docs/transforms#quick-transform
https://sketchbook.knowledgeowl.com/docs/transforms#quick-transform


246

Removing sections from a selection

When making a selection, sometimes you grab areas you don’t want. When this happens, instead of redoing your
selection, use Remove.

Removing sections from a selection in Sketchbook Pro for desktop

Once you’ve made a selection, tap  to switch the selection tool to Remove. Then either tap-drag to remove
sections from it or for the Magic Wand selection, tap areas you want deselected.

Removing sections from a selection in Sketchbook for mobile devices

Once you made a selection, tap  to switch the selection tool to Remove. Then either tap-drag to remove sections
from it or for Magic Wand selection, tap areas you want deselected.

https://sketchbook.knowledgeowl.com/docs/intro-to-selection-tools
https://sketchbook.knowledgeowl.com/docs/intro-to-selection-tools#mobile
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Replacing a selection

Replacing a selection dismisses the current selected area and starts a new one. It is the default state of the
selection tool. But if you've changed your selection tool state to Add or Subtract, you may need to change it to
Replace.

Replacing a selection in Sketchbook Pro for desktop

In the selection sub-toolbar, make sure Replace is selected, then tap-drag to capture a new selection.

Replacing a selection in Sketchbook for mobile devices

In the selection sub-toolbar, make sure Replace is selected, then tap-drag to capture a new selection.

https://sketchbook.knowledgeowl.com/docs/adding-to-a-selection
https://sketchbook.knowledgeowl.com/docs/removing-sections-from-a-selection
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Using a selection like a mask

You can use another tool while staying in selection mode, and limit the effect of that tool to the selected area,
masking off the rest of the canvas. For example, sketching while a selection is active will confine the marks on the
canvas to the selected area. 

Using a selection like a mask in Sketchbook Pro for desktop
1. Choose a type of selection: Rectangle, Oval, Lasso, Polyline, or Magic Wand.
2. Make your selection. If you need to make additional changes to your selection, don't forget to use the selection

editing tools.
3. Draw using brushes, or use another tool, such as Fill . The change is confined to the selection.
4. When finished, release your selection.

Using a selection like a mask in Sketchbook for mobile devices
1. Tap  and create a selection.
2. Draw using brushes, or use another tool, such as Fill . The change is confined to the selection.
3. When finished, tap , then  to exit the selection.

https://sketchbook.knowledgeowl.com/docs/intro-to-selection-tools
https://sketchbook.knowledgeowl.com/docs/adding-to-a-selection
https://sketchbook.knowledgeowl.com/docs/intro-to-selection-tools
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Crop to a selection

If you want to reduce the size of your canvas, you can crop it by creating a selection and then using the crop tool.
This will crop the entire canvas (all layers) to the selection.

Regardless of the type of selection, the cropped canvas will be a rectangle.

Keep in mind that this action will also reduce the number of pixels in your canvas.

In Sketchbook Pro for Mac and Windows

The  crop tool can be found in the main toolbar. When the tool is enabled, there is a sub-toolbar that shows the
width and height of the crop area.

You can either use the crop tool to select the area directly, or you can use the selection tool and then choose the crop
tool.

In Sketchbook for mobile devices

In Sketchbook for mobile devices, the crop tool can be found in the selection sub-toolbar.

First make a selection, then tap  the crop icon to crop the canvas. A non-rectangular selection will apply as a
rectangular crop, since the canvas must be a rectangle.

https://sketchbook.knowledgeowl.com/docs/intro-to-selection-tools
https://sketchbook.knowledgeowl.com/docs/toolbars
https://sketchbook.knowledgeowl.com/docs/intro-to-selection-tools
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Inverting a selection

Jump to Mobile

Sometimes using Invert can make it easier to create your selection. When you have a large area to select such as
removing a background, selecting the smaller focus area and then inverting the selection can save you time. 

Inverting a selection in Sketchbook Pro for desktop
1. In the toolbar, tap  to access Selection tools.

2. Once a selection is made, tap  Invert. The opposite area will become the active selection
3. Use  and  to further modify your selection

Inverting a selection in Sketchbook for mobile devices
1. Make your selection

On a handheld device, tap  , then  and select a tool from the Selection toolbar
On a tablet, tap  and select a tool from the Selection toolbar.

2. Tap  Invert to switch the selection. The current unselected content will become the selection
3. Use  and  to further modify your selection

https://app.knowledgeowl.com/#mobile
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Distorting a selection

Jump to Mobile

With  Distort, you can drag the handles in any direction to distort a selection. Content is automatically stretched to
fit the confines of the newly-shaped bounding box.

 Since they aren’t constrained to 90 degrees, you can use them to create a sense of perspective or speed.Move the
handles to force perspective upon the contents of the bounding box. 

NOTE: you can use Distort in conjunction with perspective guides to fit something into an existing
scene.

What is the bias

When using Distort, you will see a manipulator in the middle of the bounding box . This is the bias. Use it to
foreshorten, change the proportions of a sketch, or change the actions of a character.

Distorting a selection in Sketchbook Pro for desktop
1. In the toolbar, tap  Transform and select  . A bounding box appears surrounding the content.
2. Tap-drag the outer handles  to change the bounding box and distort the content inside it
3. Tap-drag the central handle, Bias, to foreshorten or change the proportions of the selection

Distorting multiple layers

Select multiple layers, using Shift, then tap . Tap-drag the handles of the bounding box to distort the content
across all the selected layers.

Distorting a selection in Sketchbook for mobile devices

Tap  Transform and select . A bounding box appears surrounding the content.

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/perspective-guides
https://sketchbook.knowledgeowl.com/docs/transforms
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Tap-drag the outer handles to automatically stretch the content to fit the confines of the newly-shaped bounding box.

Tap-drag the central handle, Bias, to foreshorten or change the proportions of a sketch, such as changing the actions
of a character.
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Colors in Sketchbook

Most color tools (with the exception of Flood Fill) can be found in the Color Editor.

Where to begin with color

Below, we will look at a very basic and simplified way to build up color in your drawing. By no means is this the only
way to do things.

If you are new to Sketchbook or to coloring, starting this process can be a bit daunting. The great news is that you
have layers and undo. Both help the stress out of coloring. There are also thousands of great, free resources
available on YouTube and other websites.

Flat color

Many artists sketch first, then add color. Use layers to separate parts of the sketch, so you can color components
separately. Duplicating layers, Locking transparency, and Multiply are all tools that can help with this process.

You can start with selecting a sketch layer, duplicating it, and locking the transparency of the duplicated layer. Then
color over with a single color. At this point you will have a shape that’s all the same color, but you can no longer see
your line work. Change the blend mode of the colored layer to Multiply, so you can see both the color and the line
work. Repeat the process for each component of the drawing.

Shadows

Start by determining the placement and direction of the light source. Some people even add arrows on a layer to
serve as a reminder of the light’s direction. Duplicate a sketch layer, then lock the transparency of the duplicate, so all
coloring stays within the lines. On the new duplicated layer, change the color to a dark color and color wherever a
shadow would be. Drag this layer above the color layer, and change the blend mode to Multiply, so the shadow, color,
and the line work are visible.

You can then adjust the shadow layer’s opacity to make the shadow more subtle, use the soft eraser to feather the
edges of the shadow, or combine the two techniques to get the effect you want.

Highlights

As with the flat color and shadows, start by making a duplicate of a sketch layer. Drag the duplicate above the
shadow layer. Change your color to a light color, lock transparency, and add the light color wherever a highlight
would be. When finished, change the blend mode to Overlay so the highlights, shadow, color, and the line work are all
visible. As with shadows, you can use layer opacity and the soft eraser to soften the highlights and edges.

Gradient fills

Gradient fills are another way to get a soft transition from light to dark. Start with duplicating a sketch layer and
dragging the duplicate above the color layer. Once transparency is locked, use Flood Fill and select one of the
gradient fills (Linear or Radial) from the Fill options. Change the blend mode to Multiply, for a gradual shadow and
highlight, while the color and the line work show through.

https://sketchbook.knowledgeowl.com/docs/flood-fill
https://sketchbook.knowledgeowl.com/docs/color-editor
https://sketchbook.knowledgeowl.com/docs/layers-in-sketchbook
https://sketchbook.knowledgeowl.com/docs/undoing-and-redoing
https://sketchbook.knowledgeowl.com/docs/duplicating-layers
https://sketchbook.knowledgeowl.com/docs/locking-transparency
https://sketchbook.knowledgeowl.com/docs/blending-layers#multiply
https://sketchbook.knowledgeowl.com/docs/blending-layers#multiply
https://sketchbook.knowledgeowl.com/docs/blending-layers#overlay
https://sketchbook.knowledgeowl.com/docs/flood-fill
https://sketchbook.knowledgeowl.com/docs/blending-layers#multiply
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The Color Editor

Jump to Mobile

The Color Editor contains a variety of methods for selecting color.
Color Wheel to dynamically adjust Hue, Saturation and Luminance
Color sliders
Randomize Color
Gradients for creating color ranges
HEX code

The top section of the Color Editor displays an active color swatch and two color bars one for displaying color
harmony and the other showing a history of recently used colors.

Color Editor in Sketchbook Pro for desktop

https://app.knowledgeowl.com/#mobile
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1. Previous color chip for comparison when adjusting the current color
2. Current color
3. Complementary of current color
4. Select different color bar options
5. Color history or gradient colors
6. Transparent color
7. Color picker
8. Saturation/Luminance diamond
9. Hue wheel

10. Toggle visibility of color harmony handle(s) on hue wheel
11. HEX color field and copy button
12. Color sliders for HSL, HSV and RGB
13. Custom color gradients for generating blends between 2 colors
14. Randomize color options (HSL ranges, gradient bar, or the active palette set in Custom Color Editor)
15. Collapse/expand window

Accessing the Color Editor

To access the Color Editor, tap  in the main toolbar, or from the menu bar select Window > Color Editor, or tap on
the current color indicator in the Lagoon.

https://sketchbook.knowledgeowl.com/docs/turning-a-brush-into-an-eraser
https://sketchbook.knowledgeowl.com/docs/using-the-color-picker
https://sketchbook.knowledgeowl.com/docs/randomizing-color
https://sketchbook.knowledgeowl.com/docs/basic-ui-elements#lagoon
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Color Editor in Sketchbook for mobile devices

1. Previous color
2. Active color
3. Transparent color
4. Hue wheel
5. Saturation / Luminance diamond
6. View HSL sliders
7. View RGB sliders

https://sketchbook.knowledgeowl.com/docs/turning-a-brush-into-an-eraser
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8. Complementary of current color
9. Color Harmonies (Premium Bundle feature)

10. Color history
11. Custom Gradients (Premium Bundle feature)
12. Color Picker
13. Current HEX value - tap to edit
14. Color palette
15. Randomize color
16. Gradient
17. Switch to Color Sets
18. Switch to Image Sets

Accessing the Color Editor

Open the Color Editor from the toolbar , by tapping the color chip at the top of the Layer Editor, or by tapping the
color chip on the Double Puck.

Additional features with the Premium Bundle

The Premium Bundle for Sketchbook on iOS and Android includes extended functionality for the the Complementary
and Color History bars in the Color Editor.

An icon beside each bar will open pages to select different options.

The top bar can be customized to display different color harmonies:
Complementary
Split Complementary
Analogous
Triad
Tetrad

The second bar can be customized to display different gradients:
Hue
Saturation
Lightness
Complementary
Grayscale
One of four user-customized gradients
Color history

https://www.sketchbook.com/get-more
https://www.sketchbook.com/get-more
https://sketchbook.knowledgeowl.com/docs/using-the-color-picker
https://sketchbook.knowledgeowl.com/docs/color-palettes
https://sketchbook.knowledgeowl.com/docs/randomizing-color
https://sketchbook.knowledgeowl.com/docs/color-palettes#color-sets
https://sketchbook.knowledgeowl.com/docs/color-palettes#image-sets
https://sketchbook.knowledgeowl.com/docs/intro-to-layer-editor#mobile
https://sketchbook.knowledgeowl.com/docs/color-puck#double-puck
https://www.sketchbook.com/get-more
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The Color Puck

Jump to Mobile

Use the Color Puck for a quick access way to mix and create new colors.

The Color Puck in Sketchbook Pro for desktop

If the puck is not visible you can access it by going to the menu bar and selecting Window > Color Puck.

Drag within the puck to change luminance and saturation.

To change the active color, tap the center of the puck. This opens the mini Color Wheel. It also provides access to
Transparent Color, the Color Picker, and a mini color palette. Add the active color to the palette by dragging the
swatch down into one of the nine spaces. Note that this palette is separate from the palettes available in the Custom
Colors window.

The Color Puck in Sketchbook for mobile devices

Sketchbook on mobile doesn't have a separate color and brush puck, but has the Double Puck, which has combined
them.

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/creating-custom-colors#color-puck
https://sketchbook.knowledgeowl.com/docs/turning-a-brush-into-an-eraser
https://sketchbook.knowledgeowl.com/docs/using-the-color-picker
https://sketchbook.knowledgeowl.com/docs/color-palettes#puck-palette
https://sketchbook.knowledgeowl.com/docs/color-palettes
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1. Brush size and opacity
2. Current brush
3. Current color

Use the lower half to change the saturation and luminance/brightness of a color. Drag within this area. See Creating
custom colors. Tap the center of the bottom section to access the Color Editor and change hue, luminance, and
saturation.

On a phone device, the Double Puck  appears when you tap the  marking menu. On a tablet device, the Double
Puck is shown by default. 

To enable/disable the Double Puck on a tablet:
1. tap  to open the marking menu
2. then tap  to show or hide the Double Puck.

https://sketchbook.knowledgeowl.com/docs/basic-ui-elements#marking-menu
https://sketchbook.knowledgeowl.com/docs/basic-ui-elements#marking-menu
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Using the Color Picker

Jump to Mobile

The Color Picker (you might also know it as the eyedropper or pipette) is a tool for selecting color.

Using the Color Picker in Sketchbook Pro for desktop
1. Tap the center of the Color Puck or open the Color Editor, and tap  to activate the picker 

alternatively, use the hotkey Alt (Windows) or Option⌥ (Mac)
2. Tap . The cursor will change to the picker  indicating it is active
3. Tap-drag over the canvas. A zoomed-in view of the pixels will follow the cursor. The center color of the Color

Puck changes to display the current selection.
4. When you find the color you want, release the tap-drag. The selected color becomes the Active Color, and the

Color Picker is automatically dismissed.

Using the Color Picker in Sketchbook for mobile devices

There are few ways to access the Color Picker:
1. Tap and hold on the screen until the cursor changes to . 

You can enable or disable Tap-hold for the color picker  in Preferences.
2. or, in the Color Editor, tap . The cursor changes to .
3. or, tap the marking menu and select . 

Tap-drag the Color Picker over the canvas to find the color you want to select. As the cross-hairs in the center of it
move over a color, you’ll notice the color of the outer ring change to that color. When the outer ring is the color you
want, lift your finger. The selected color becomes the Active Color, and the Color Picker is automatically dismissed.

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/color-puck
https://sketchbook.knowledgeowl.com/docs/color-editor
https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook#gestures
https://sketchbook.knowledgeowl.com/docs/color-editor#mobile
https://sketchbook.knowledgeowl.com/docs/basic-ui-elements#marking-menu
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Turning a brush into an eraser (Transparent Color)

Jump to Mobile

Transparent color transforms the active brush into an eraser with the properties of the brush.

So for example, if the active brush is pressure-sensitive and creates a stroke that fades off, as an eraser it will do the
same. Use it to erase existing color on the current layer.

Turning a brush into an eraser in Sketchbook Pro for desktop

Transparent Color can be triggered in the following places:
1. In the Color Editor by tapping  
2. In the Lagoon, select  and choose  

3. Tap the center of the Color Puck and choose   

You can also set up a hotkey for toggling on/off Transparent Color. A hotkey is not set by default, but you can set
one yourself in Preferences.

Turning a brush into an eraser in Sketchbook for mobile devices

Select the brush you want to transform into an eraser.
1. From the marking menu, tap 
2. In the Color Editor, tap   

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/color-editor
https://sketchbook.knowledgeowl.com/docs/basic-ui-elements#lagoon
https://sketchbook.knowledgeowl.com/docs/hotkey-shortcuts
https://sketchbook.knowledgeowl.com/docs/hotkey-shortcuts#customize
https://sketchbook.knowledgeowl.com/docs/basic-ui-elements#marking-menu
https://sketchbook.knowledgeowl.com/docs/color-editor#mobile
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Creating custom colors

Jump to Mobile

The version of Sketchbook you are using will determine the tools available to generate custom colors. They all have
a Color Editor with a Color Wheel; however, on macOS and Windows you have a dedicated Color Puck, on Android
and iOS you have the Double Puck. See the sections below for more information.

To create custom colors, use either a color puck or wheel. You will need to change one or more of the following:
Hue - this is the color. Think red, green, or yellow.
Saturation - this is the intensity or pureness of the hue (color). Sometimes this is referred to as the chroma. If
you have a true blue, with no gray added to the color, it has a saturation of 100% (pure blue). If it has a
saturation of 0%, you would have a medium gray. Think of 100% saturation as bright and vivid, where as the
saturation decreases, the color becomes duller.
Luminance - the brightness or lightness of the hue. If you have a pure red with no white added to the hue, it has
a luminance of 50%. As you add white to it, the luminance increases. At 100% luminance it is white. At 0%
luminance it is black.

Creating a custom color in Sketchbook Pro for desktop

There are a few ways to create a custom color:

Using the Color Puck

If the puck is not visible, from the menu bar select Window > Color Puck.

Tap-drag right and left across the puck to quickly change the saturation. 

Tap-drag up and down to quickly change the luminance of the color. 

Using the Color Puck to access the Color Wheel

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/color-editor
https://sketchbook.knowledgeowl.com/docs/color-puck
https://sketchbook.knowledgeowl.com/docs/color-puck#double-puck
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Tap the Color Puck to open a mini version of the Color Wheel and mix a color of your own.

Using the Color Editor

To access the Color Editor, do one of the following:
In the toolbar, tap .
or, in the Lagoon, tap the active color indicator.
or, from the menu bar select Window > Color Editor.

Drag the handle on the Color Wheel to change the hue of a color (like from green to red). Drag the handle within the
diamond to change saturation and luminance. Drag right or left to change the saturation. Drag up or down to change
the luminance of the color.

Creating a custom color in Sketchbook for mobile devices

There are a few ways to create a custom color:

From the Color Editor:
1. Tap-drag within the diamond to change the saturation and luminance.
2. Tap-drag around the ring to change the hue.
3. Tap HSL, RGB, or , then tap-drag the sliders to change or Randomize the values.
4. Tap , then select a color from your canvas.

https://sketchbook.knowledgeowl.com/docs/color-editor
https://sketchbook.knowledgeowl.com/docs/basic-ui-elements#lagoon
https://sketchbook.knowledgeowl.com/docs/color-editor#mobile
https://sketchbook.knowledgeowl.com/docs/randomizing-color#mobile
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Using the bottom half of the Double Puck

If the Double Puck is not already visible, tap the marking menu and choose .

To change color saturation, tap-drag right across the bottom section of the puck to increase color saturation and left
to decrease it.

To change color luminance, tap-drag up across the bottom section of the puck to increase luminance and down to
decrease it.

https://sketchbook.knowledgeowl.com/docs/color-puck#double-puck
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Color Palettes

Jump to Mobile

Sketchbook comes default with three sets of color palettes. The Basic, Greys, and Variety Collection contain over
1000 color swatches between them. These are just a start. You can create and organize your own palettes for your
projects.

Any palette can have up to 60 color swatches, there can be up to 12 palettes in a set, and a maximum of 50 color
sets in the Color Library.

More color palettes are available on our Extras site.

Color Palettes in Sketchbook Pro for desktop

There are multiple color palettes available in Sketchbook Pro, including the Custom Colors palettes and the Color
Puck palette.

Custom Colors

The Custom Colors window is where you access your sets of color palettes, and where you can make and organize
your own palettes and sets of palettes.

There are a few ways to access Custom Colors:
tap the  icon in the toolbar
from the menu bar, go to Window > Custom Colors

You can also customize your Lagoon to access Custom Colors from one of the marking menus. You'll find Custom
Colors as an option in the "Windows" section.

Adding swatches

The round swatch at the top of the Custom Colors window shows your active color. Add a swatch to any palette in
the current set by dragging the active color swatch down to the palette.

https://app.knowledgeowl.com/#mobile
https://www.sketchbook.com/extras
https://sketchbook.knowledgeowl.com/docs/customizing-your-ui#lagoon
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You can drop the swatch in a specific position in the open palette, or drop it in one of the other palettes in the set by
dragging it over the palette thumbnail preview on the left side of the window. The new swatch will be added to the
last position of the palette.

Tapping the add swatch icon  at the end of a palette will also add the active color to that position.

You can also drag the active color from the Color Editor window to create a swatch. Swatches cannot be created
from the Color Harmony, Gradient, or Color History bars.

Deleting swatches

To delete a swatch, tap-hold the swatch. The trash can icon will appear at the top of the Custom Colors window. Drag
the swatch over the trash can to delete it. This action cannot be undone.

Organizing swatches and palettes

You can organize swatches within a palette by dragging them to a new position. As you drag, a blue outline will show
the position that the swatch would be in if you drop it. Dropping a swatch over another swatch will swap their
positions. If you drag a swatch to another palette and drop it, it will be placed at the end of that palette.

https://sketchbook.knowledgeowl.com/docs/color-editor
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Double-tap the name of the palette to rename it. You can also rename the set of palettes from this view by double-
tapping the set name.

Once created, palettes cannot be reordered within the set. However you can reorder and organize your sets in the
Color Library.

Color Library

Tap the  icon to access the Color Library. Here you will see all your sets of palettes. You can have a maximum of
50 sets.

1. Tap the  icon to create a new set
2. Tap  to import a set (.skcolors)
3. Tap  to access the set menu. Here you can rename, duplicate, export, and delete a set. Deleting a set cannot

be undone.
4. Drag the handle of any set to reorder it up or down in the Library.
5. Close the Color Library and return to palette view

When in palette view, you can navigate through your sets by tapping the arrow buttons next to the set name.
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The Color Library is also where you can import, back up and restore your color sets.

Image sets

Image sets let you extract colors from reference images. There are three sample image sets that come default in the
app to give you some ideas of how you might use this feature.

Extracting colors from an image

Scroll your pen over an image in the Image Sets and you'll see the active color update in real time. This is a quick and
easy way to choose a color from a reference image.

You can also extract an entire palette from an image. Tap  to set the color palette extraction options

https://app.knowledgeowl.com/#backup
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1. Which set the new palette will be added to
2. Title of the new palette
3. Position of the new palette within the set
4. Maximum number of colors to extract (extraction may be fewer colors based on other choices below)
5. Choose how the palette colors will be chosen; the most frequent colors in the image, the lighter colors, or the

darker colors
6. Merge options allow to reduce the number of very similar colors within the new palette. Colors can be reduced

based on difference in RGB value, hue value, saturation or lightness. Adjust the percentage difference for the
selection.

7. A preview of the color palette based on the current extraction settings

Loading images

A new image will load in the active position. If there is already an image loaded in that position, you'll be asked if you
want to replace it. To load an image without replacing one, tap an empty position before loading.

You can load .png, .jpg, or .tif files. There are a few ways to load an image to image sets.
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1. tap the  icon and in the file manager window that opens, navigate to the image and tap "Open"
2. Copy an image to your clipboard, and then in the Custom Colors images window, tap  to paste
3. Drag and drop an image from a file manager window into the Custom Colors images window

Deleting images

Tap the trash can icon to delete an image from Image sets. You'll be asked to confirm that you want to delete, as  this
action cannot be undone.

Resetting palettes and images

If needed, you can reset your color palettes and image sets from Preferences.

Color Puck Color Palette

There is a mini-palette associated with the Color Puck that contains 9 color swatches.This is a quick-access palette
and is not connected with the palettes in the Custom Colors window.

https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook#defaults
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Accessing the Color Puck palette

Tap the Color Puck, then tap  to access the palette and  to close it.

Adding custom colors to the Color Puck palette

To add a new swatch to the palette, create a color with the Color Wheel, then click-drag the new color swatch onto
another swatch in palette to replace it.
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Gradient Fill Palette

When a linear or radial fill is selected from the Fill toolbar, and you tap the Color Puck, the Gradient Fill Palette is also
available. It contains swatches of pre-made gradient fills. You can select a fill and then adjust it using the mini-wheel.
If you create a fill and want to save it, tap-drag the gradient swatch to the palette below. The new swatch will replace
the one it is dropped onto.

https://sketchbook.knowledgeowl.com/docs/flood-fill
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Backing up and restoring your custom color palettes

1. In the Color Library, tap the Color Set you want to export
2. Tap the menu icon  
3. Select Export. The file will be saved as .skcolors

To restore a Color Set or import a color set to another device:
1. At the top of the Color Library, tap Import 
2. In the file window, navigate to where you have the .skcolors file saved
3. Tap Open

Color sets and color palettes are also backed up and restored with a full Preferences backup.

Color palettes in Sketchbook for mobile devices

Color Sets can be accessed quickly in the main Color Editor window by tapping the  palette icon above the sliders:

https://app.knowledgeowl.com/#color-library
https://sketchbook.knowledgeowl.com/docs/backing-up-preferences
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Or opened in full view by swiping left or tapping to the next tab

Customizing your swatches

To customize, drag and drop from any of the swatches on the top of the Color Editor (current color, previous color,
complementary color, or a swatch from the color history). Drag it over an existing swatch to replace it or append a
new color to the end position of the palette.
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TIPS:
Staying in the Color Wheel view with the palette tab is most versatile for selecting a palette and dragging in
colors.
Deleting swatches from a palette is available in the full Color Set view.
Renaming individual palettes is available in the full Color Set View.

TIP: When you have multiple sets, use the arrow keys on the full Color Set view to move to next or previous color sets
quickly.

Color Set Library

Tap on the Library icon to manage all the Color Sets, or to create new ones.

In the Library, you can create new blank color sets or use a preset as a starting point. You can create up to a
maximum of 50 distinct color sets.

Each set can be renamed, duplicated, deleted or re-ordered.

https://app.knowledgeowl.com/#mobile-color-library
https://app.knowledgeowl.com/#mobile-color-library
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Resetting color sets

If you would like to reset all your color sets to factory default, you can do that in Preferences. Keep in mind that all of
your custom color sets will be deleted.

Importing and exporting color sets

Importing and exporting color palettes in Sketchbook on iOS and Android requires the Premium Bundle

More color sets are available as free Extras on the Sketchbook website. You may also want to share color sets with
others on your project, or use the same sets in both Sketchbook Pro on desktop and Sketchbook on mobile devices.

To import a color set
1. In the  Palettes tab, tap  in the lower right corner to go to the Color Library
2. Tap  in the lower right corner of the window to import a set. The file browser will launch.
3. Navigate to where you saved the color set you want to import (.skcolors) and tap on it
4. The file will import into the Color Library as a new set

To export a color set
1. In the  Palettes tab, tap  in the lower right corner to go to the Color Library
2. Locate the set you want to export and tap  next to the set name. The actions window will launch.
3. Select an app to share via (eg: text or email), or choose to save to files.
4. The file will export in .skcolors format

Image sets

Image sets in Sketchbook on iOS and Android require the Premium Bundle

Image sets let you extract colors from reference images. There are three sample image sets that come default in the
app to give you some ideas of how you might use this feature.

Extracting colors from an image

Scroll your finger or pen over an image in the Image Sets and you'll see the active color update in real time. This is a
quick and easy way to choose a color from a reference image.

You can also extract an entire palette from an image. Tap  in the lower right corner of the window to extract a

palette from an image. You'll see a warning that the new palette will extract to the currently selected palette - tap "Go
to Palettes" to make sure the current selection is an empty palette in the set you want to add to.

NOTE: in Sketchbook on mobile, color palette extraction from images is automatic, there are no customized settings
as in Sketchbook Pro on desktop.

Loading images

You can load .png, .jpg, or .tif files.

https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook#defaults-mobile
https://www.sketchbook.com/get-more
https://www.sketchbook.com/extras
https://www.sketchbook.com/get-more
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To load a new image:
1. Tap the  icon at the bottom of the window, and choose where you want to import the image from
2. Navigate to the image and tap on it
3. The image will load into the next open spot in the Image Set tab

Deleting images

Tap the trash can icon to delete an image from Image sets. This action cannot be undone.

Resetting palettes and images

If needed, you can reset your color palettes and image sets from Preferences.

https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook#defaults-mobile
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Randomizing color

Jump to Mobile

Quickly lay down varying colored strokes using the same brush. I’ve found this really fun to use when playing with
Radial Symmetry.

Set a range for the hue, saturation, and luminance of the active color. In Sketchbook Pro on macOS and Windows
you can also  randomize colors from a particular color palette, or randomize from within a gradient.

Randomizing color in Sketchbook Pro for desktop
1. Open the Color Editor, either by selecting Window > Color Editor or from the toolbar, tap .
2. In the bottom half of the Color Editor, tap .

3. Select the color range you want to randomize from the dropdown:
HSL – use the sliders to define the hue, saturation and lightness ranges you want the randomized colors
to fall within. Blue indicators over the color wheel preview the range
Palette – colors will be chosen at random from the currently selected palette in the Custom
Colors window. The Custom Colors window does not need to be open for this selection to be enabled,
however you might want to open it to double-check which palette is currently selected.
Gradient – colors will be chosen from the pinned gradient (including Color History) in the Color Editor.

Note: When Randomize is on, if you have the Color Puck visible you will see the randomize icon in the
center of the puck.

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/symmetry
https://sketchbook.knowledgeowl.com/docs/color-palettes#custom-colors
https://sketchbook.knowledgeowl.com/docs/color-editor
https://sketchbook.knowledgeowl.com/docs/color-editor
https://sketchbook.knowledgeowl.com/docs/color-palettes#custom-colors
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4. To turn off Randomize Color, tap one of the other color selection options: HSL, HSV, RGB, or Gradient

Randomizing color in Sketchbook for mobile devices
1. Open the Color Editor
2. Tap  below the color wheel to turn on randomizing color
3. Use the sliders to set the range of colors to randomize - blue indicators over the color wheel preview the range:

Hue – to set the color range of the stroke.
Saturation – to set the range from pure color to gray of the stroke.
Luminance – to set the range of color brightness of the stroke.

4. To disable randomizing color, tap either HSL, RGB, the palettes, or the gradients tab.

https://sketchbook.knowledgeowl.com/docs/color-editor#mobile
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Layers in Sketchbook

Jump to Mobile

Layers help you organize the content that makes up your image. Using multiple layers can be very helpful when
creating complex drawings, making it easier to adjust and/or manipulate different parts of the drawing. 

What are layers

Think of layers as transparent sheets that can be ordered and reordered, made invisible, blended, and adjusted.
Combined the content of your layers creates the picture. 

In the case of comic book artists, a panel might use four basic layers. Pencils, ink, and color layers, separated
strategically from one another, as well as from the background plate. This makes it easy to change elements or add
them later.

They can be used as a ‘preservation’ tool. If you’re happy with a certain aspect of your art, lock that layer and start a
new layer and continue. You can choose to merge all layers afterwards, or keep them separated for future edits.

If you find yourself using lots of layers, the Layer Editor can become cluttered fast. Consider grouping layers into
folders. You can group layers and group groups up to 9 levels.

Layers can be created, duplicated, merged, turned on and off, reordered, blended, and deleted using the Layer Editor.
As content is added to a layer, the Layer Editor thumbnail preview updates, displaying the content and making it
easier to identify a layer.

How many layers can I have?

The number of layers available is dependent on the capabilities of your device. If you have multiple apps running in
the background, your device is low on memory, or your canvas is huge, this will affect the number of layers available.

We have tried to make the Layer Editor and tools as consistent as possible across platforms. However, due to the
form factor of some devices, you will see some minor differences in design.

No current version of Sketchbook or Sketchbook Pro limits the layers available based on a purchase / paywall. We
stopped doing that almost 10 years ago.

If you want to transfer images containing files, check out this article: Transferring images with layers

Layers in Sketchbook Pro for desktop

To access the Layer Editor and its layers, in the toolbar, tap .

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/locking-layers
https://sketchbook.knowledgeowl.com/docs/grouping-layers
https://sketchbook.knowledgeowl.com/docs/intro-to-layer-editor
https://sketchbook.knowledgeowl.com/docs/transferring-images-with-layers
https://sketchbook.knowledgeowl.com/docs/intro-to-layer-editor
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There are three types of layers:
Regular layers contain functionality for showing/hiding the layer content, locking the layer, changing opacity,
creating a clipping mask and accessing other layer tools through the marking menu. As you add content to
your canvas, the layer corresponding to it will update a thumbnail preview of the content.
The Background layer is used for setting the color of the canvas and creating an alpha channel. It is at the
bottom of the Layer Editor.
Text layers contain the text created with the Text tool.

Layers in Sketchbook for mobile devices

Layers are found in the Layer Editor. There are two types of layers:
Regular layers contain functionality for showing/hiding the layer content, locking the layer, changing opacity,
and accessing other layer tools through the Layer Menu. As you add content to your canvas, the layer
corresponding to it will update a thumbnail preview of the content.
The Background layer is used for setting the color of the canvas and creating an alpha channel. It is at the
bottom of the Layer Editor.

https://sketchbook.knowledgeowl.com/docs/showing-and-hiding-layers
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If you're on a tablet, the editor should always be visible along the right side of the screen. If it isn't, then your UI is
hidden. See either Basic UI elements or Hiding the UI while you draw.

If you're on a handheld (phone) device, to access the Layer Editor and its layers, in the toolbar, tap . You can keep
the Layer Editor open by tapping the pin icon  in the lower left corner. The pin will automatically reset to off when
the app is fully exited.

https://sketchbook.knowledgeowl.com/docs/basic-ui-elements#mobile
https://sketchbook.knowledgeowl.com/docs/hiding-the-ui-while-you-draw
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Introduction to the Layer Editor

Jump to Mobile

The Layer Editor contains all your layers and layer tools.

You can add, delete, rearrange, group, and even hide layers.

There are blending modes, opacity controls, transparency lock toggles, and clipping masks, plus typical editing tools
and a default background layer that can be hidden to create an alpha channel or used to set the over-all background
color of your image.

Background layer

The Background layer is at the bottom of the Layer Editor, and can be used to change the background color of your
image. When hidden (tap to hide it), this creates an alpha channel.

The Layer Editor in Sketchbook Pro for desktop

You will need to open the editor to access the layers and layer tools. There are two ways to do this:
From the menu bar, select Window > Layer Editor.
From the toolbar, tap .

The Layer Editor in Sketchbook for mobile devices

Tablet devices

The Layer Editor is visible by default, along the right of your screen.

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/adding-layers
https://sketchbook.knowledgeowl.com/docs/deleting-layers
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Phone devices

If you're on a handheld device, tap  to open the Layer Editor.
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The Layer Menu

Jump to Mobile

The Layer Menu contains an assortment of layer tools, which may vary depending on the version of Sketchbook
you're using. Some of these tools are also available as Layer Editor icons or in a layer marking menu.

The Layer Menu in Sketchbook Pro for desktop

When you’re in the Layer Editor, tap  in the upper right of the window to access the menu of layer tools for
creating a layer, adding an image (import), grouping, duplicating, renaming, locking, deleting, and merging layers.
Also, if you've been using the Text tool, you'll find an option for rasterizing the text.

Layer Marking Menu

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/intro-to-layer-editor
https://sketchbook.knowledgeowl.com/docs/intro-to-layer-editor
https://sketchbook.knowledgeowl.com/docs/text
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Actions using the marking menu apply at the layer where the menu was opened.

In the Layer Editor, select a layer and tap-hold  to open the Layer Editor marking menu.

Here you can access tools for quickly adding, deleting, renaming, merging, locking, showing and hiding layers, and
duplicating layers.

The Layer Menu in Sketchbook for mobile devices

When you’re in the Layer Editor, double-tap any layer to access the menu.

Actions in the menu apply at the layer where the menu was opened.

Cut, copy, paste, duplicate, clear, merge, and delete are all found here.
Below these are Lock Layer and Color Adjustments
Grouping layers and Clipping Masks are also available with the Premium Bundle.
Use the slider for changing opacity. Set blend modes. Assign a color to help identify layers.

https://sketchbook.knowledgeowl.com/docs/adding-layers
https://sketchbook.knowledgeowl.com/docs/deleting-layers
https://sketchbook.knowledgeowl.com/docs/renaming-layers
https://sketchbook.knowledgeowl.com/docs/merging-layers
https://sketchbook.knowledgeowl.com/docs/locking-layers
https://sketchbook.knowledgeowl.com/docs/showing-and-hiding-layers
https://sketchbook.knowledgeowl.com/docs/duplicating-layers
https://sketchbook.knowledgeowl.com/docs/intro-to-layer-editor#mobile
https://sketchbook.knowledgeowl.com/docs/locking-layers#mobile
https://sketchbook.knowledgeowl.com/docs/making-color-adjustments-to-a-layer#mobile
https://sketchbook.knowledgeowl.com/docs/grouping-layers#mobile
https://sketchbook.knowledgeowl.com/docs/clipping-masks#mobile
https://www.sketchbook.com/get-more
https://sketchbook.knowledgeowl.com/docs/blending-layers
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Using the Background layer

Jump to Mobile

The Background layer is at the bottom of the Layer Editor. It cannot be drawn on. 

The default color of the background layer is white, but it can be changed at any time. If you are looking for a way to
make the subject “pop”, adjusting the background layer can help.

You can also make the background transparent; see Creating an alpha channel.

Changing the background color in Sketchbook Pro for desktop

If you want to change the color of the background of your composition, tap the circle on the Background layer to
open the Color Editor and select a color.

Notice the Color Editor icon  appears on the Background layer when you are changing its color.

Tap the circle again to stop editing the background color - note the icon will disappear once you've exited edit mode
(the Color Editor will remain open).

Setting the background color in Sketchbook for mobile devices

If you want to change the color of the background of your composition, tap the circle within the bottom layer to
access the Color Editor and select a color.

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/intro-to-layer-editor
https://sketchbook.knowledgeowl.com/docs/creating-an-alpha-channel
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Adding layers

Jump to Mobile

When you add a layer, it will appear above the current active layer.

If you add a layer and it isn't in the order you want, you can reorder your layers.

The number of available layers is device dependent, meaning that if your device has a lot of available memory, you
can have more layers. Smaller canvases will allow you more layers than extremely large canvases, due to the
demands placed on the device by the larger file size.

For Sketchbook on iOS and Android, see the article, Maximum layers and canvas size on mobile, to get
an idea of the number of layers available to you.

Adding a layer in Sketchbook Pro for desktop

To add a layer to your sketch, do either:
At the top left of the Layer Editor, tap 
tap the  menu in the Layer Editor, and select New Layer
tap the marking menu  on a layer , and sweep up to choose  to add a layer
use the hotkey combination Ctrl+L (Windows) or ⌘L (Mac)

Adding a layer in Sketchbook for mobile devices
At the top of the Layer Editor, tap .
The new layer appears above the active layer and becomes the new active layer.

To reposition layers after you've created them, see Reordering layers.

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/reordering-layers
https://sketchbook.knowledgeowl.com/docs/max-layers-on-mobile
https://sketchbook.knowledgeowl.com/docs/intro-to-layer-editor
https://sketchbook.knowledgeowl.com/docs/intro-to-layer-editor#mobile
https://sketchbook.knowledgeowl.com/docs/reordering-layers#mobile
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Deleting layers

Jump to Mobile

If you were working with a reference image and are finished with it, use Delete to remove the layer containing it.
When you delete layers, this frees up space in the Layer Editor for new layers.

Deleting layers in Sketchbook Pro for desktop

In the Layer Editor, tap a layer to select it.

Do either of the following:
1. tap-hold  and select .

2. or click  and select Delete.
If you have any hidden layers, you can delete them all at the same time by choosing Delete Hidden
Layers.

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/showing-and-hiding-layers
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Deleting layers in Sketchbook for mobile devices
1. In the Layer Editor, tap a layer to select it.
2. Tap the selected layer again to open the Layer Menu.
3. Then, tap  and OK.

If you have any hidden layers, you can delete them all at the same time by choosing  Delete Hidden Layers.

Another way to delete a layer is to drag the layer up to the top of the Layer Editor, the    icon will change to a trash
can  as you drag over it.

https://sketchbook.knowledgeowl.com/docs/intro-to-layer-editor#mobile
https://sketchbook.knowledgeowl.com/docs/intro-to-layer-menu#mobile
https://sketchbook.knowledgeowl.com/docs/showing-and-hiding-layers
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Cutting and pasting

Jump to Mobile

Cutting and pasting is slightly different, depending on the version of Sketchbook you are using.

Cutting and pasting in Sketchbook Pro for desktop

Use one of the selection tools first to choose the content. If you want the entire layer, use Ctrl+A (Windows) or
Command+A (Mac) first to select the entire layer.

Then:
Use the hotkey Ctrl+X (Win) or Command+X (Mac) to cut the content

alternatively, use Ctrl+C / Command+C to copy the content to the clipboard
Use the hotkey Ctrl+V (Win) or Command+V (Mac) to paste.

If you have preferences set to add/import images to a new layer, your pasted content will automatically be applied in
a new layer. To change this, de-select Add image: import into a new layer in the General tab of Preferences.

See Introduction to Selection Tools for information on using the selection tools.

Cutting and pasting in Sketchbook for mobile devices
1. In the Layer Editor, double-tap the layer you want to cut content from to access the Layer Menu.
2. Tap  to Cut the entire layer or the active selection.

alternatively, tap  to Copy the layer or active selection.
3. Create a new layer or select a layer where you want to paste the content
4. Open the Layer Menu at the destination layer and tap .

Removing parts of an image

If you want to remove parts of an image, such as the background, use the Selection tools in conjunction with  Cut
or  Clear in the Layer Menu.

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook#general
https://sketchbook.knowledgeowl.com/docs/intro-to-selection-tools
https://sketchbook.knowledgeowl.com/docs/intro-to-layer-menu#mobile
https://sketchbook.knowledgeowl.com/docs/intro-to-selection-tools#mobile
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Copying content and layers

Jump to Mobile

Want to copy layers or selections, and then paste the content elsewhere and reposition it? Copying and pasting is
slightly different, depending on the version of Sketchbook you are using.

Copying and pasting in Sketchbook Pro for desktop

If you want to copy and paste just a section of a layer, use one of the selection tools first. Otherwise the copy/paste
action will apply to the entire active layer.

Use the hotkey Ctrl+C (Win) or Command+C (Mac) to copy the content to the clipboard.
Use the hotkey Ctrl+V (Win) or Command+V (Mac) to paste.

Alternatively, you can go to the menu bar and choose Edit > Copy and then Edit > Paste
From the menu bar, you also have the option to Copy Merged. This copies the contents (or the selected
area) across all layers, not just the active layer.

If you have preferences set to add/import images to a new layer, your pasted content will automatically be applied in
a new layer. To change this, de-select Add image: import into a new layer in the General tab of Preferences.

Another option to copy an entire layer is to duplicate it. See Duplicating layers for how to do this.

Copying and pasting in Sketchbook for mobile devices
1. In the Layer Editor, double-tap the layer you want to cut content from to access the Layer Menu.
2. Tap  to Copy the entire layer or the active selection.
3. Create a new layer or select a layer where you want to paste the content
4. Open the Layer Menu at the destination layer and tap .
5. You will be entered into the transform workspace, where you can use the transform tools to reposition the

pasted content.

Tap the + icon next to   Copy to access an additional copy option - Copy Merged - which will copy the combined
effect of all visible layers to the clipboard.

https://app.knowledgeowl.com/#mobile
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Duplicating layers

If you've created a layer that you want to use again, use Duplicate.

Duplicate will always apply to the entire layer, it cannot be limited by an active selection. If you want to only duplicate
a piece of a layer, use copy and paste instead. 

Duplicating a layer in Sketchbook Pro for desktop
Select the layer and tap-hold  and sweep up and left to .

or tap  and select Duplicate.

https://sketchbook.knowledgeowl.com/docs/copying-and-pasting
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Duplicating a layer in Sketchbook for mobile devices

Sketchbook on mobile devices does not have the duplicate layer function. Use copy and paste instead. 

https://sketchbook.knowledgeowl.com/docs/copying-and-pasting#mobile
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Merging layers

Jump to Mobile

When finished with the layer content on a couple layers, you can merge layers, using one of the merge tools to
combine them.

There are two merge tools:
Merge with below takes the selected layer and combines it with the layer below.
Merge all layers combines all your layers.

Merging layers in Sketchbook Pro for desktop

Use Merge with below to combine two layers into one.

Tap the upper layer's marking menu  and choose  to merge it with the one below

Or use the hotkey combination Cmd+E on Mac or Ctrl+E on Windows.

Use Merge all layers to flatten all layers in the project into a single layer.

Tap the upper layer's marking menu  and choose  to merge all layers. The merge action will include locked
layers and hidden layers. Unhide all layers with data you want to keep before merging as hidden layers will be lost in
a merge.

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/hotkey-shortcuts
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Merging layers in Sketchbook for mobile devices

In the Layer Editor, double-tap a layer to open the Layer Menu. 

If you plan to merge only two layers, tap the upper of the two layers to open its Layer Menu. If you are merging all
layers, or all visible layers, you can open the Layer Menu on any layer.

The default action is to merge two layers. Tap the  icon to merge the current layer with the layer below it. 

To merge all layers, or all visible layers, tap  to access the additional options.

https://sketchbook.knowledgeowl.com/docs/intro-to-layer-menu#mobile
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Flipping and mirroring layers

Do you need to flip a layer vertically (reflect) or horizontally (mirror)?

Flipping layers in Sketchbook Pro on desktop
1. Select the layer you want to flip.
2. In the menubar, select Image > Flip Layer Vertically 

or Image > Mirror Layer to flip horizontally.

Flipping layers in Sketchbook on mobile devices

Flipping a layer in Sketchbook on mobile devices uses the Transform tool. As long as you don't have an active
selection, Transform applies to the entire layer.

1. Select the layer you want to flip.
2. In the toolbar, tap  and then  to flip horizontally 

or  to flip vertically.

https://sketchbook.knowledgeowl.com/docs/transforms#mobile
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Clearing content and layers

Jump to Mobile

Want to remove all content from a layer or from a selection? Use Clear to erase all pixels in an area. Unlike Cut or
Copy, Clear does not put content in the device's clipboard; it simply erases it. 

Clearing content in Sketchbook Pro for desktop

In the Layer Editor, make sure the layer with the content you want to clear is active. Select the content you want to
clear; if there is no selection made then Clear will apply to the entire layer.

Then do any of the following:
On your keyboard, tap the Delete or Backspace key
Tap the  icon at the top of the Layer Editor
Tap the Layer Editor menu  and select Clear
From the menu bar, select Edit > Clear

Clearing content in Sketchbook for mobile devices

In the Layer Editor, make sure the layer with the content you want to clear is active. Select the content you want to
clear; if there is no selection made then Clear will apply to the entire layer.

Then do either of the following:
Tap the layer in the Layer Editor to open the Layer Menu, then tap  Clear
Double-tap the top left corner of your canvas to activate the Clear shortcut

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/intro-to-selection-tools
https://sketchbook.knowledgeowl.com/docs/intro-to-selection-tools#mobile
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Locking layers

Jump to Mobile

When you lock a layer, it prevents any changes from being made to the layer. This can be helpful to ensure that
nothing on that layer is accidentally altered. Locking a layer can also be used to indicate completion.

You can also lock layer transparency. Locking transparency has a different effect than locking a layer.

Pay attention to any warnings that appear. They will explain what is locked and needs to be unlocked to perform
certain actions.

Locking layers in Sketchbook Pro for desktop

In the Layer Editor, tap the layer's marking menu  then gesture down and to the left to  Lock.

Simply repeat the process to  Unlock the layer. This icon is a toggle, switching back and forth between locked and
unlocked states.

Locking layers in Sketchbook for mobile devices

In the Layer Editor, tap a selected layer or double-tap an unselected layer to open the Layer Menu.

Tap  Lock Layer. Repeat the process to  Unlock the layer. This icon is a toggle, switching back and forth between
locked and unlocked states.

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/locking-transparency
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Reordering layers

Jump to Mobile

Rearranging your layers can support the total effect you want by overlapping content in a specific way, and
facilitating layer blending and masking. This is different than visual organization.

To make a layer appear in front of another, move it above.
To make a layer appear behind another, move it below.

In the example below, the nameplate layer is below the box layer, so it isn't visible. Dragging the nameplate layer
above the box layer would fix this.

Reordering layers in Sketchbook Pro for desktop
1. In the Layer Editor, tap a layer to select it.
2. In the top right corner of the layer, tap-hold  as you drag the layer to a different order in the Layer Editor. The

active layer line (blue) will move to indicate where the layer will appear when you release the hold.

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/blending-layers
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https://sketchbook.knowledgeowl.com/docs/intro-to-layer-editor
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Reordering layers in Sketchbook for mobile devices
1. In the Layer Editor, tap a layer to select it.
2. Tap-hold and drag the layer above or below a layer into position.

https://sketchbook.knowledgeowl.com/docs/intro-to-layer-editor#mobile
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Grouping layers

Jump to Mobile

Use layer grouping to organize layers of your drawing.

You might group layers that belong to a certain aspect of the drawing such as a subject or a background, or you may
want to group layers to refine how you apply blending, masking, or clipping effects.

Grouping layers in Sketchbook Pro for desktop

Layer grouping tools can be found in the Layer Editor.

1. Layer Menu
2. Blend modes
3. Group container expanded
4. Layer visibility (show/hide)
5. Color label
6. Locked layer
7. Clipping mask layer

Creating a layer group

There are three different ways to create a layer group, all three appear in the Layer Editor:
1. In the top bar of the Layer Editor, click  to create a new group.

https://app.knowledgeowl.com/#mobile
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2. or click the Layer Menu  and select New Group.
3. or shift-select the layers you want grouped, then click  and select Group Layers.

To ungroup layers, select the group folder, click the Layer Menu  and select Ungroup.

Adding a layer to a group

To add a layer to a group, click the layer’s handle  and drag it either onto the Group folder or over a layer within the
group. A blue line will indicate where the layer will be positioned once you release the handle.

Showing/hiding a layer group

To hide all the content in a layer group, tap  on the group's folder level. Tap  to display the content again.

Visually organizing layer groups

Assigning a color tag  to a group to makes it easier to distinguish one group and its layers from another.
1. To assign a color, select a group in the Layer Editor.
2. At the bottom left corner of the group tap-hold , and choose a color.
3. The color tag will appear on the group folder level and will also automatically be assigned to all layers inside

that group.
You can individually change the tag on a layer if you want it to be different.

To unassign a color, repeat the steps and select .

Collapsing/Expanding a group

Collapsing groups can make it easier to navigate the Layer Editor.
To collapse a group and hide its layers in the Layer Editor, tap .
When a group is collapsed, its icon changes to . Tap it again to expand the group and access all its layers in
the Layer Editor.

Layer blending in groups

When you create a group, the group's blend mode is set to Pass Through by default. This means that blend modes
applied to layers within the group will affect all layers below it, including layers not in the group.

If you want the blend mode to only apply within the group, change the group's blend mode to Normal. Now any blend
mode applied to a layer within the group affects only layers inside that group.

Grouping layers in Sketchbook for mobile devices

Layer Grouping is unlocked with the purchase of the Premium Bundle

https://sketchbook.knowledgeowl.com/docs/blending-layers
https://www.sketchbook.com/get-more
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Creating a layer group

Double-tap a layer that you want to be part of the new group. The Layer Menu will open.
On the Layer Menu, tap  Make Group
The Layer Menu will close and you will see your new group folder in the Layer Editor

the number of layers in the group will appear in the lower right corner
tap the folder to manage the group; rename, ungroup, transform, duplicate, lock, flatten, delete, set
opacity, blend modes, and color label
tap the chevron  to the right of the folder to enter the group and manage the individual layers

Adding a layer to a group

To add a layer to a group, drag a layer up and over the group folder.

Showing/hiding a layer group

To hide the content in a layer group, tap . Tap  to display the content again.
If you want to see some of the group content, you can hide individual layers within the group.

Visually organizing layer groups

Assigning a color tag to a group to makes it easier to distinguish one group from another. 
1. To assign a color, tap a group in the Layer Editor to open the Layer Menu. 
2. In the Layer Menu, assign a Color Label to the group

Unlike Sketchbook Pro, the color label will not automatically apply to the layers within the group. This is because you
cannot see outside layers when viewing layers within a group.

To unassign a color, repeat the steps and select None.

Layer blending for groups

If you want blend modes applied to layers inside the group to affect all layers below it, set the group's blend mode
to Pass Through.

If you want the blend mode to only apply within the group, make the group's blend mode Normal. Any blend mode

https://sketchbook.knowledgeowl.com/docs/intro-to-layer-menu#mobile
https://sketchbook.knowledgeowl.com/docs/intro-to-layer-menu#mobile
https://sketchbook.knowledgeowl.com/docs/blending-layers


312

applied to a layer within the group affects only layers inside that group.
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Visually organizing layers

Jump to Mobile

When working with a number of layers, color coding them can help you quickly distinguish one from another. It also
helps you group content to create one visual component. Say you’re designing a car. You could assign all
components that make up the steering wheel one color. For the tires, you assign another color. Then, whenever you
want steering wheel components, you look for layers with the same assigned color.

Visually organizing layers in Sketchbook Pro for desktop

At the bottom left corner of each layer is a circle . Tap it to access a marking menu of available colors. Select a
color to assign it to that layer, making it easier to distinguish it from the others.

Visually organizing layers in Sketchbook for mobile devices

Tap a layer to open the Layer Menu. At the bottom of the menu, tap Color Label and select a color from the list. Now
a colored spot appears in the lower right corner of the layer in the Layer Editor, making it easier to distinguish it from
the others.

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/intro-to-layer-menu#mobile
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Showing and hiding layers

There are times when you will want to show/hide layers, such as to reduce visual distraction when working on a
specific area of your composition; to see how one variation of a design looks compared to another; to place
something else in the scene, or to remove an element.

You can show/hide layers from the Layer Editor
To hide a layer, tap the layer's  icon. It changes to , indicating the layer is hidden.
To show a layer, tap the layer's  icon. It changes to , indicating the layer is now visible.

In Sketchbook Pro for desktop, you can also show and hide a layer from the layer's marking menu .

https://sketchbook.knowledgeowl.com/docs/intro-to-layer-editor
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Renaming layers

Jump to Mobile

If you're working on a project with a large number of layers, layer naming, grouping layers, and visual organization
can be helpful. 

Renaming a layer in Sketchbook Pro for desktop
1. In the Layer Editor, select the layer you want to rename
2. Do either of the following:

tap-hold , gesture to the right to , and change the name.

or in the upper right corner of the window, tap  and select Rename.

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/grouping-layers
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Renaming a layer in Sketchbook for mobile devices
1. In the Layer Editor, double-tap the layer you want to rename to open the Layer Menu.
2. At the top of the Layer Menu, tap the name field to edit it.
3. Tap Done to complete the name change.

https://sketchbook.knowledgeowl.com/docs/intro-to-layer-menu#mobile
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Blending layers

Jump to Mobile

Create complex multi-layered textures. Choose from an assortment of blend modes, apply them and experiment
without the fear of permanently altering your composition. Change the order of your layers and experiment with the
settings to achieve the result you want.

For the below examples of blend modes, the blended layer is the transparent to orange gradient layer, which is one
level above. The layer below is the base layer, in this case the illustrated layer. Each example will show a result of a
particular blend on this combination of layers.

Blend modes that are noted below as proprietary to Sketchbook will only be preserved when the file is
saved as a Sketchbook TIFF. Saving/exporting to PSD will convert these blend modes to Normal when
the PSD is reopened.

Normal

The layers appear exactly as created. Removes any color correction applied to the blended layer.

Pass Through

Pass Through is a blend mode available to Groups, that make the blend modes of the layers within the group carry
through to layers outside of the group.

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/grouping-layers
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Alpha Mask

Uses the alpha channel of the blended layer (where there are no painted pixels) as a mask. Any colors on the layer do
not contribute to the masking. An empty layer with this blend mode will mask the entire canvas.

This blend mode is proprietary to Sketchbook, and will not be preserved if files are saved to PSD.

Inverse Alpha Mask

Uses the inverted alpha channel of the blended layer (where there are painted pixels) as a mask.

This blend mode is proprietary to Sketchbook, and will not be preserved if files are saved to PSD

Darken

Compares the pixels between the blended layer and the base layer, and displays the darker of the two.

Multiply

A similar effect to combining one or more photographic transparencies together and looking through them. Each
pixel on the blended layer is darkened by a value equal to or greater than the value of pixels on the base layer
occupying the same location in the layer stack.

TIP: If the top selected layer uses tints (colors mixed with white), more of the colors from the layer will show through.
If it uses shades (colors mixed with black), most of the colors from the layer below are obscured.
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Color Burn

Enhances contrast between the colors of the blended layer and base layer. The intensity of the tones in the blended
layer determines the degree of color change:

darker colors will create a more intense effect.
white areas remain the same.

Linear Burn

The blended layer is decreased in brightness based on the brightness values on the base layer.

Lighten

The opposite of Darken. Compares the pixels between the two layers and displays the lighter of the two.

Screen

Produces an overall lightening effect, a softer effect than Add. Each pixel on the blended layer is brightened by a
value equal to or lesser than the value of pixels on other layers occupying the same location in the layer stack. This
effect is opposite to Multiply.

https://app.knowledgeowl.com/#darken
https://app.knowledgeowl.com/#linear-dodge
https://app.knowledgeowl.com/#multiply
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TIP: If the top layer uses tints (colors mixed with white), most of the colors from the layer below will be obscured. If it
uses shades (colors mixed with black), more colors from the layer below to show through.

Color Dodge

The opposite of Burn – though results aren’t always opposite. Increases contrast by lightening light areas without
having any effect on darker ones.

Linear Dodge (Add)

Lightens the overall composition, similar to Screen, but more dramatically. Each pixel is brightened by a value equal to
or lesser than the value of pixels on other layers occupying the same location in the layer stack. This is applied as a
linear calculation.

TIP: If the top selected layer uses tints (colors mixed with white), most of the colors from the layer below will be
obscured. If it uses shades (colors mixed with black), more of the colors from the layer below to show through.

Glow

Defines the brightness of a glow, like the effect of a star in the night sky. The higher the setting, the brighter the glow.

This blend mode is proprietary to Sketchbook, and will not be preserved if files are saved to PSD

https://app.knowledgeowl.com/#burn
https://app.knowledgeowl.com/#screen
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Soft Glow

Softens or blurs the color and intensity of Glow, like the light emanating from a translucent object.

This blend mode is proprietary to Sketchbook, and will not be preserved if files are saved to PSD

Overlay

A mix of Multiply and Screen. Takes dark values and multiplies them and screening light values from the base layer.
Brightness is unchanged, so it tends to look harsher than Soft Light.

Soft Light

A mix of Darken and Lighten. Takes dark values and multiplies them and screens light values from the base layer;
however, in this case, the effect is softer and more subtle than Overlay.

Hard Light

Similar to Overlay, just more dramatic. Determines the pixel color based on grayscale. When more than 50% gray,
base layer pixels are screened. Less than 50% gray, they are multiplied.

Hue

https://app.knowledgeowl.com/#multiply
https://app.knowledgeowl.com/#screen
https://app.knowledgeowl.com/#soft-light
https://app.knowledgeowl.com/#darken
https://app.knowledgeowl.com/#lighten
https://app.knowledgeowl.com/#overlay
https://app.knowledgeowl.com/#overlay
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Takes the hue of the blended layer, while keeping the brightness and saturation levels of the base layer.

Saturation

Takes the saturation of the blended layer, changing that of the base layer, without affecting the brightness or hue
levels.

Color

Takes the hue of the blended layer, changing the color of the base layer, without affecting the luminosity.

Luminosity

The opposite of Color, it blends the lightness, while ignoring the color information.

Layer blending in Sketchbook Pro for desktop

In the Layer Editor, with a layer selected, tap the dropdown menu (below the Layer Editor toolbar) to select a layer
blending method.

https://app.knowledgeowl.com/#color
https://sketchbook.knowledgeowl.com/docs/intro-to-layer-editor
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Blend modes are also available in the form of Shading brushes.

Changing your image to black and white

1. In the Layer Editor, add a layer to the top of the layer stack.
2. In the toolbar, select  Flood Fill, then select  (Solid Fill), and fill the layer with black.
3. In the blend modes menu, select Hue.

Layer blending in Sketchbook for mobile devices
1. In the Layer Editor, tap the layer the blend mode will be applied to and open the Layer Menu
2. Tap the Blending section for a list of blend modes.
3. Select a blend mode from the list.

Changing your image to black and white on mobile

1. In the Layer Editor, add a layer to the top of the layer stack.
2. In the toolbar, select  Flood Fill.
3. Select  (Solid Fill) and fill the layer with black.
4. Double-tap the new filled layer to open the Layer Menu.
5. Tap Blending and select Hue from the list.

https://sketchbook.knowledgeowl.com/docs/flood-fill
https://app.knowledgeowl.com/#hue
https://sketchbook.knowledgeowl.com/docs/intro-to-layer-menu#mobile
https://sketchbook.knowledgeowl.com/docs/intro-to-layer-editor#mobile
https://sketchbook.knowledgeowl.com/docs/flood-fill#mobile
https://sketchbook.knowledgeowl.com/docs/intro-to-layer-menu#mobile
https://app.knowledgeowl.com/#hue
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Clipping masks

What are clipping masks?

Clipping masks are a way to blend and manage the content of your canvas across different layers more easily. They
are flexible, allowing you to alter the visible results such as experimenting with texture or color without making more
permanent changes to your art.

When a clipping mask is enabled on a layer, that layer will reference the contents of the layer below it (the base layer)
to define what is visible and what is "clipped" or hidden.

no clipping mask clipping mask enabled

For example, if the base layer has a solid shape and the rest of it is blank (i.e.: transparent), then the contents of the
clipping mask layer will only be visible where the solid shape is.

If the base layer is hidden, the contents of the clipping mask layer will also be hidden. Transparency of the base layer
is also inherited by the clipping mask layer - if the base layer has 50% opacity, then the contents of the clipping mask
layer will also have 50% opacity.

You can put multiple clipping mask layers above a single base layer. When several sequential layers all have clipping
masks enabled, they will all be masked by the same base layer.

multiple clipping masks above a base layer

How to apply clipping masks
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In Sketchbook Pro on Windows and macOS, clipping masks are enabled in the Layer Editor. There is a clipping mask
button on the right side of each layer which will display the current state;  disabled or  enabled.Tapping it will
toggle the clipping mask on or off.

In Sketchbook on Android and iOS, clipping masks are included with the Premium Bundle.
Clipping masks can be enabled and disabled in the Layer Menu.
Layers with a clipping mask applied will show in the Layer Editor with this icon  

Adding or moving layers around a clipping mask

If you add a layer between a clipping mask and its base layer, that added layer will automatically also become a
clipping mask layer.

Moving a layer between a clipping mask layer and its base layer will convert the moved layer to a clipping mask.

If you move a clipping mask in the layer stack, it will adjust to reference the new base layer.

https://sketchbook.knowledgeowl.com/docs/intro-to-layer-editor
https://www.sketchbook.com/get-more
https://sketchbook.knowledgeowl.com/docs/intro-to-layer-menu#mobile
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� Note: when using Quick Transform the mask will be inactive and the contents of clipping mask layers
will be fully visible until the transformation is complete, at which point the mask(s) will become active
again.

Groups and clipping masks

When layers are grouped, a clipping mask layer must have the base layer also within its group. This is why the layer
at the bottom of a grouped stack cannot be a clipping mask layer.

It is not currently possible for a group to be the base layer for a clipping mask above, or for a group to become a
clipping mask. We plan to make expansions to the clipping mask functionality in future updates.

File compatibility

Clipping masks are preserved both in Sketchbook's native TIFF format and when saving as PSD. Only Sketchbook
will recognize layers in a TIFF file, so if you are working across different image applications you should use PSD to
preserve your layers (read more about PSD files and Sketchbook here).

Opening a TIFF or PSD with clipping masks in a version of Sketchbook that does not support clipping masks will
disable the mask.

Sketchbook clipping masks are tested to ensure cross-compatibility with Adobe Photoshop. A Sketchbook PSD with
clipping masks will read correctly when opened in Adobe Photoshop, and vice versa. Different drawing applications
have different implementations of clipping masks, and cross-compatibility of clipping mask layers with other
applications may vary.

https://sketchbook.knowledgeowl.com/docs/transforms#quick-transform
https://sketchbook.knowledgeowl.com/docs/import-from-photoshop
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Mask blend modes

Layer masking is available as blend modes in Sketchbook Pro on macOS and Windows, and in Sketchbook on
mobile with the Premium Bundle.

Masks provide a flexible method for layering details, coloring, or shading. By using layers as masks, you can
dynamically modify your masks and see the results interactively as well as reuse layers (by duplicating or
copy/paste) to repeat results with consistency.

Masking blends work the same way as other blend modes - their effect applies to all the layers below; they can be
used in layer groups to help define/control which layers are affected; and they can be applied to a group allowing you
build up a mask using different layers as components.

Clipping masks are different than mask blend modes; see the article Clipping Masks

Types of Blend Modes

There are two masking blend modes.
Alpha Mask will mask out the transparent areas of a layer. Areas that have painted pixels will define the visible
region of the layers below.
Inverse Alpha Mask reverses the effect to mask out the painted areas. The transparent portions of the layer
define what remains visible.

Mask blends only use the alpha channel (transparency). Any color on the the mask layer will not affect the masking,
only where there are opaque or semi-transparent pixels.

Results when using Alpha Mask vs. Inverse Alpha Mask

https://www.sketchbook.com/get-more
https://sketchbook.knowledgeowl.com/docs/clipping-masks
https://app.knowledgeowl.com/#alpha-mask
https://app.knowledgeowl.com/#inverse-alpha-mask
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This illustrates the different effects of each blend mode when used without Groups.

The background layer is unaffected by mask blends, so if you want to export a transparent PNG simply turn off the
visibility of the background layer

Normal blend mode

When the spade sketch and other layers all use Normal blend mode, the final composite allows you to see through all
the transparent and semi-transparent portions of the layers, down to the background color.

Alpha Mask

When Alpha Mask is applied to the spade sketch, the transparent areas mask the layers below leaving only opaque
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and semi-transparent areas visible.

When a background color is visible, it is not masked and shows in the final output.

Turning the background off will allow you to export out transparent PNG or TIF.

Inverse Alpha Mask

This mode makes the painted areas mask the sky layer to see through to the background color.

And this is the result with the background turned off:

Masking and Layer Groups

When creating more than one mask layer in the Layer Editor, it is important to remember that the top most mask
layer will also mask those below it. To create multiple mask regions on a canvas, use grouping techniques to get
different combinations of masking.

https://sketchbook.knowledgeowl.com/docs/creating-an-alpha-channel
https://sketchbook.knowledgeowl.com/docs/intro-to-layer-editor
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Using Groups to isolate mask effects

Using groups, you can define if a mask layer affects all layers below or just the layers below it in a group. By default,
new groups are created with the ‘pass-through’ setting. As the name suggests, any blend mode in the group be
passed along in the same manner as if the layers were not grouped.

By selecting the group and changing the blend mode to ‘Normal’, any layer with a blend mode will only affect layers in
the same group.

Using this technique, you can control exactly which layers inherit the masks while layers below that group remain
untouched and visible.

Building up a mask with separate component layers using Groups

Groups can also be used to composite multiple layers to define a mask. It can be easier to create complex masks in
parts rather than getting it right in a single layer.

To do this, just make a group and create layers with the ‘Normal’ blend mode applied. Then, select the group and
change the group's blend mode  to either Alpha Mask or Inverse Alpha Mask. Now all those layers behave as a single
mask.

Tip: Give meaningful names to your groups so you can easily identify them, particularly when you have
multiple groups or sub-groups in your layer stack.

Working with other painting and image editing apps

Sketchbook’s mask blend modes are not supported by other applications, so here are a few tips if you are planning to
transfer your layers to another app:

When exporting in PSD format, blend modes not supported by the PSD format will be saved as ‘Normal’. You
can apply new masking techniques once you've opened the PSD in the destination app.
Using the grouping technique with ‘Normal’ blend mode will give you the option of ‘baking’ your masks before
exporting. When you use Merge Layers to flatten a group, this will maintain the blend mode effects on the
resulting merged layer. It is a good idea to save a copy of your file or duplicate the group before you merge the
layers, in case you want to make further changes at another time.
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Making color adjustments to a layer

Jump to Mobile

In the examples below the left side shows an adjustment option applied to the original image (right side). The
version of Sketchbook you are using will determine the tools available for color adjustment.

Brightness/Contrast

Make colors pop. Increase the contrast to make colors richer. Decreasing it to wash them out for images that text
can be placed over top. Increase brightness to bring out details from darker areas. Decrease it to melt away darker
aspects of an image and shift the focus to things that are bright.

Hue/Saturation

Change the color range, increase or decrease the purity of a color or brilliance of the colors. Adds/subtracts color
(hue) or adjusts the relative amount of color (saturation) in each pixel.

Color Balance

https://app.knowledgeowl.com/#mobile
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Remove unwanted color casts by adjusting the cyan, red, magenta, green, yellow, and blue in each pixel.

Grayscale

Change a color image to one that uses black, white, and various shades of gray.

Invert

Switch the contrast of an image. Change black elements to white and white to black to create an opposite image.
Converts color information for each pixel to its complementary color.
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Blur

A Gaussian blur that reduces the visible detail in the image. Blur adjustment is currently available in Sketchbook on
mobile devices and coming soon to Sketchbook Pro on desktop.

Sharpen

Finds the edges in the image - areas where adjacent pixels are significantly different - and enhances the differences
to generate the effect of making the image crisper. Sharpen adjustment is currently available in Sketchbook on
mobile devices and coming soon to Sketchbook Pro on desktop.
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� You can also use layer blending to make color, tonal, or effects changes to an image. See Blending
layers for more information.

Making color adjustments in Sketchbook Pro for desktop

In Sketchbook Pro, go to the menu bar and choose Image > Adjust to adjust the brightness/contrast, hue/saturation,
color balance, grayscale, or invert values.

The canvas must contain some image data for adjustment options to be available, they will be greyed out on a blank
canvas.

Preview

See real-time changes in the preview to the left as slider values are changed. When disabled, the preview doesn't
update as values are changed.

Show All

See all content on visible layers when Show All and Preview are enabled. When disabled, only content on the active

https://sketchbook.knowledgeowl.com/docs/blending-layers
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layer is previewed.

Reset

Return to the original settings, as long as Apply has not been used. If changes have already been applied, the only
way to undo the change is to use Undo.

Apply

Apply the settings to the image on your canvas, while keeping the dialog open for making further changes. Use this
when setting a value beyond the slider's range. For example, the sliders have a range from -100 to 100. If you wanted
to a value of -120, you would set the slider to -100, press Apply, then set the same slider to -20 and press OK when
finished to close the dialog.

OK - Applies the changes and closes the dialog.
Cancel - Closes the dialog without applying the current unapplied changes.

Apply Hue to Gray

Only available for Color Balance.

On by default. When disabled, grayscale areas - where Red, Green and Blue values are the same (eg: 100,100,100) -
will not be affected by color balance adjustments. 

Making color adjustments in Sketchbook for mobile devices

Do you want to make changes to your image, but without redoing the colors? If so, try the two color adjustment tools
in the Layer Menu: HSL Adjustment and Color Balance.

Additional adjustment options are available with the Premium Bundle:
Brightness/Contrast
Grayscale
Invert
Blur
Sharpen

https://sketchbook.knowledgeowl.com/docs/undoing-and-redoing
https://www.sketchbook.com/get-more
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To access adjustments, tap the Layer Menu and then choose  Adjust. A drop-down menu will show the available
adjustments.

If you only want to apply the adjustment to a part of the layer, first make a selection and then open the Layer Menu to
apply your adjustment.

HSL Adjustment

Use HSL Adjustment to make the content of a layer warmer, cooler, lighter, or darker.

The top slider changes the hue, the middle the saturation, and the bottom the luminance.

Color Balance

Select one of the following options from the top of your screen: Shadows, Midtones, or Highlights. Your selection
determines which elements are affected by your changes.

Tap-drag the sliders. The top slider changes the reds, the middle slider affects the greens, and the bottom slider
affects the blues.

Brightness/Contrast

Adjust the sliders to the right to increase the brightness and/or contrast of the pixels, or to the left to decrease.

Grayscale

Each pixel is reduced to only the Lightness value, producing an image in which the range of color is only black to
white.

Invert

Converts the color information for each pixel to its complementary color.

https://sketchbook.knowledgeowl.com/docs/intro-to-layer-menu#mobile
https://sketchbook.knowledgeowl.com/docs/intro-to-selection-tools#mobile
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Blur

Each point on the slider increases the blur radius by one pixel. You need to release the slider by removing your stylus
or finger for the effect to be generated in the preview.

If you notice repeating patterns in the blur effect, these can be triggered by the contrast in the image. Tap 1x at the
top of the screen and change it to 2x or 3x - this will automatically repeat the blur function twice or three times,
softening the effect.

Sharpen

The sharpness slider defines the amount of contrast applied to the edges, and the strength slider increases the area
that will be affected. You need to release the slider by removing your stylus or finger for the effect to be generated in
the preview.



339

Changing layer opacity

Jump to Mobile

Change opacity to make the content of a layer more transparent. This can be useful when drawing elements that
should have transparency to them anyway (eg: water) or when tracing or referencing an image on another layer.

Changing layer opacity in Sketchbook Pro for desktop

Changing opacity affects the active (highlighted) layer.

You can either drag the slider up and down to the desired opacity level, or enter a percentage in the box. 100 will be
100% opaque, and 0 will be fully transparent.

Changing layer opacity in Sketchbook for mobile devices
1. In the Layer Editor, tap the layer you want to adjust.
2. Tap the layer again to access the Layer Menu.
3. Drag the Opacity slider:

left to increase transparency
right to decrease transparency

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/intro-to-layer-menu#mobile
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Creating an alpha channel

Jump to Mobile

The Background layer is at the bottom of the Layer Editor. When hidden (tap  to hide it - the icon changes to ),
this creates an alpha channel.

The alpha channel doesn’t contain any pixels, so the background of the image becomes transparent. Sketchbook will
display a grey and white checked pattern to indicate the alpha channel/transparency.

When saving an image with an alpha channel, select TIFF, PNG, or PSD. The JPG file format does not
support transparency.

Creating an alpha channel in Sketchbook Pro for desktop
1. In the Layer Editor, on the Background layer, tap . The icon changes to  indicating the background is

hidden and you have an alpha channel.
2. If you want to disable the alpha channel, tap  on the Background layer to enable the background color.

Creating an alpha channel in Sketchbook for mobile devices

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/using-the-background-layer
https://sketchbook.knowledgeowl.com/docs/intro-to-layer-editor
https://sketchbook.knowledgeowl.com/docs/intro-to-layer-editor
https://sketchbook.knowledgeowl.com/docs/using-the-background-layer
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If you're on a tablet, the Layer Editor is visible by default, along the right of your screen.

If you're on a handheld (phone) device, tap   to open the Layer Editor.
1. Within the Layer Editor, find the Background layer. Tap   - the icon changes to  indicating the background

is hidden. A grey and white checked pattern will appear in the background. This is the alpha channel.
2. Tap the icon again to toggle the background color back on.

Warning: The iOS Photos app is known to convert PNG files to JPG, with the most obvious result being
the loss of a transparent background. It is more common for files over 4k and under 360px, but it can

happen to any file. The only workaround if this is happening on your device is to save your PNGs to Files instead
of to Photos.

https://sketchbook.knowledgeowl.com/docs/intro-to-layer-editor#mobile
https://sketchbook.knowledgeowl.com/docs/using-the-background-layer#mobile


343

Locking transparency

Jump to Mobile

Lock Transparency creates a mask that locks the transparent portion of the layer from being edited. This means
that when you draw on that layer, you can only affect areas containing pixels.

In the example below, I only wanted to paint on the hippo. With Lock Transparency on, I can paint in broad strokes
without worrying about coloring outside the shape.

Locking transparency in Sketchbook Pro for desktop
1. In the Layer Editor, tap a layer to select it.
2. To lock its transparency, tap . You will see the icon change to indicate transparency is now locked .

3. Tap the icon again to unlock transparency.

Locking transparency in Sketchbook for mobile devices

In the Layer Editor, tap a layer to select it. The transparency icon will appear in the lower left corner .
1. Tap the icon to lock transparency . The icon will remain visible while the layer's transparency is locked, even

when the layer is not active.
2. Tap the  icon again to unlock transparency.

You can also access layer transparency lock in the Layer Menu

https://app.knowledgeowl.com/#mobile
https://sketchbook.knowledgeowl.com/docs/intro-to-layer-editor
https://sketchbook.knowledgeowl.com/docs/intro-to-layer-editor#mobile
https://sketchbook.knowledgeowl.com/docs/intro-to-layer-menu#mobile
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Gallery in Sketchbook

NOTE: The Gallery is only available on Sketchbook on mobile devices. 
On desktop, your files are saved via the operating system's file manager (Finder/File Explorer)

The Gallery is where your sketches are saved. If you worked on something and want to go back to it, if it is not still on
your canvas, you can find it in the Gallery. When you open the Gallery, your sketch appears.

From the Gallery, you can swipe left or right to see other sketches, rename sketches, create new sketches, import
images, rotate your canvas, delete images, share images, view a slide show, make a duplicate, export as a PSD,
organize your sketches into folders, and select a sketch to load it into the canvas to continue working on it.

Accessing the Gallery

To access the Gallery, in the toolbar tap  the menu, then  Gallery.

The different Gallery views

When you open the Gallery, all your saved sketches appear in a large thumbnail view.
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Pinch the canvas to switch to a small thumbnail view with all the folders. You can also switch to small thumbnail
view by tapping the  icon, or by tapping the Album name in the upper left corner.

In small thumbnail view, you can see your Albums across the top of the screen, as well as the Gallery Trash folder. In
the main body of the screen are smaller thumbnails of the sketches in the currently selected Album.

Tap any small thumbnail to return to the large thumbnail view. Tap a large thumbnail to open the sketch and continue
drawing.

Small thumbnail view:

1. Current Album
2. View/hide Albums
3. Exit to canvas
4. Trash
5. Albums
6. Album menu (new, export, delete)
7. Thumbnails of sketches in current Album
8. Tap to select sketches or Albums
9. New sketch menu

10. Gallery menu (share, duplicate, export, delete). You first need to select a sketch or sketches before the menu
will be active. In large thumbnail view, the menu will apply to the centered preview sketch.

Organize sketches into Albums

https://sketchbook.knowledgeowl.com/docs/gallery-folders
https://sketchbook.knowledgeowl.com/docs/gallery-folders
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Tap Select to enter selection mode. The bar across the bottom of the Gallery view will turn blue. Tap all the
thumbnails you want to select, and then tap Move To in the blue bar. The thumbnails will collapse into a single
thumbnail - you can drag this to any other album in the top bar.

You can also long-press any single sketch until it enters the selected state, then drag it to another album.

To exit the Select state, tap Select again. Note the blue bar will go away.

For more about Albums, see Using Gallery folders

Album menu

The album menu  is available in small thumbnail view. This menu is where you can
1. Create a new album
2. Export an entire album
3. Create a multi-page PDF from an album (requires the Premium Bundle)
4. Delete the Album

For more about Albums, see Using Gallery folders

Creating a new canvas in the Gallery

From the Gallery, to create a sketch, select  and choose how you want to create a new sketch
1. New Sketch initiates the new canvas workflow for a blank canvas
2. New from Image allows you to browse your device or camera roll and create a new canvas from any image.

The image will open in Canvas view for you to start working.
3. Add Image to Gallery allows you to browse your device or cloud storage for files you want to import to

Sketchbook. After the image is imported, you remain in Gallery view.
4. Add Scans to Gallery initiates scanning sketches

Selecting sketches

To select one or more sketches in the thumbnail view, tap Select, then tap the sketches. A blue bar appears at the
bottom of the screen. 

To share, export, or delete, tap 
To exit selection mode, tap Select again

Opening a sketch

Tap a sketch to select and load it onto the canvas for further editing.

Naming/renaming your sketch

https://sketchbook.knowledgeowl.com/docs/gallery-folders
https://sketchbook.knowledgeowl.com/docs/exporting-pdf-files
https://www.sketchbook.com/get-more
https://sketchbook.knowledgeowl.com/docs/gallery-folders
https://sketchbook.knowledgeowl.com/docs/scanning-sketches
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To name your sketch, tap where it says Untitled and enter another name.

The dimensions and number of layers your sketch has appear below the name.

iOS and special characters in filenames 
On some iOS devices, special characters such as slash, backslash, hyphen, or parentheses, may cause
issues saving and/or exporting files. We are in the process of investigating a fix for this problem. If

you've encountered this issue and need help, please reach out to our support team.

Quickly deleting a sketch

Tap-drag a thumbnail up to the top of the screen to delete it. To undo this, tap the red bar that immediately appears
at the top of the screen after this action.

If you inadvertently deleted your sketch and missed the opportunity to undo, you can restore it from the Gallery Trash.

Rotating your canvas in the Gallery

In large thumbnail view, you can rotate a canvas from the  icon above the thumbnail.

Sharing, exporting, duplicating, and deleting a sketch

Tap  in the lower right corner to open the menu (this menu is disabled in small thumbnail view until you select at
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least one canvas).
Select Share / Export to send the sketch to another app, via text or email, or to export the file to your device or a
cloud location you have already set up in your Files app.

You will have the option to choose the file type after you select either Share or Export
Duplicate will create a duplicate of the sketch in the Gallery, and remain in Gallery view.
To delete the current sketch, select Delete.

Exiting the Gallery

There are two ways to exit the Gallery:
1. Tap an image in the Gallery to open the image in canvas view.
2. Tap X at the top right corner of the screen to exit the Gallery to the last canvas you worked on.
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�
Using Gallery folders

NOTE: the Gallery is only available on Sketchbook for mobile devices.

Gallery folders are called Albums.

All your Albums can be seen in small thumbnail view. Switch to small thumbnail view by:
tapping the  icon
or tapping the Album name in the upper left corner
or by pinch-zooming out

Along the top of the screen you will see your Albums listed. When you select an Album, the sketches in that Album
appear below, in the main part of the screen.

Album menu

Tap  to open the Album menu.

This is where you can:
create a new Album
Export an entire album as individual TIFF files (iOS only - Android users can access their TIFF files directly in

https://sketchbook.knowledgeowl.com/docs/gallery-in-sketchbook#small-thumbnail-view
https://sketchbook.knowledgeowl.com/docs/saving-files#android
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their File browser)
Create a multi-page PDF from an album (unlock this option with the Premium Bundle)
Delete the Album

Renaming an Album

To rename an Album, tap the name under the album thumbnail, and enter the new name.

Organize sketches into Albums

Tap Select to enter selection mode. The bar across the bottom of the Gallery view will turn blue.

 

Tap all the thumbnails you want to select, and then tap Move To in the blue bar. The thumbnails will collapse into a
single thumbnail - you can drag this to any other album in the top section.

You can also long-press any single sketch until it enters the selected state, then drag it to another album.

To exit the Select state, tap Select again. The blue bar will disappear, indicating you have exited the mode.

Deleting an Album

In older versions of Sketchbook, deleting an Album was permanent and cannot be undone. Starting in Sketchbook
v6, deleting an Album puts it in the Trash. You may see a message that your Trash folder settings will be
automatically updated to enable the Album to go into the Trash, for example if the number of sketches in the Album
exceeds the current Trash folder setting.

1. To delete an Album, Tap  to open the Album menu.
2. Tap  Delete Album to delete the selected folder. A warning appears to ensure you aren't deleting something

accidentally.
On AndroidOS, you can also start the deletion process by long-pressing the folder

https://sketchbook.knowledgeowl.com/docs/exporting-pdf-files
https://www.sketchbook.com/get-more
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3. Tap Yes to delete the folder.

Deleting sketches within an Album

1. To delete one or more sketches, tap Select, then the sketch or sketches from the Gallery or from within an
Album.

2. Tap  and select  Delete. The sketch appears in the Trash folder.

The Trash folder

When you delete a sketch or Album, this is where is goes. However, if you ever mistakenly delete something, you can
get it back by restoring it from the Trash.

When you open the Trash folder, thumbnails of its contents appear. At this point, you can do any of the following:
To restore a sketch to the Gallery, tap it to select it, then tap  and Restore selected sketch
To delete a sketch permanently, tap it to select it, then tap  and Delete selected sketch to permanently delete
it the app.
To permanently delete the entire contents of the Trash folder, tap  and then  Empty Trash
Tap  in the lower right corner to set how many files are kept in Trash at any one time. When the number of
sketches sent to the Trash exceeds this setting, the sketches that have been in the Trash the longest will be
permanently deleted.
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Exporting PDF files from the Gallery

PDF Export from the Gallery is included with the Premium Bundle

From the Gallery, you can select and export multiple canvases as pages in a single PDF document.

You can also export a single canvas to PDF from the Share / Export menu option

Create a multi-page PDF by selecting several canvases

Switch to small thumbnail view and select the canvases you want to include in your PDF document. Tap  the
menu in the lower left corner and choose Share / Export and choose PDF as the file type.

Export an entire Album to a multi-page PDF

Switch to small thumbnail view and tap on the header to show your Albums. You can export any selected album to
PDF from the  Album menu on the right side.

Setting PDF quality and page size

During the export process you will be prompted to select your PDF details.

Quality

Select good, better or best quality settings. The higher the quality, the larger the PDF size will be.

https://www.sketchbook.com/get-more
https://sketchbook.knowledgeowl.com/docs/exporting-images#mobile
https://sketchbook.knowledgeowl.com/docs/gallery-in-sketchbook#small-thumbnail-view
https://sketchbook.knowledgeowl.com/docs/gallery-in-sketchbook#small-thumbnail-view
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Page size

Define the page size of the document. Fit to image(s) will use the size of each individual canvas for each page in the
PDF

Standard A4 and Letter size orientations are available as quick selections.

You can also select ‘custom’ to define a specific page size. Selecting the custom option presents the canvas size
dialog, allowing you to enter values or select from a stored size from the Preset tab.
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Generating the PDF

After set up, a progress dialog will appear while the PDF is being created.

Exporting the PDF

Once the processing is complete, you will be prompted to select a the destination to save the PDF using the Share
dialog.
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�
Scanning sketches

Scan Sketches is only available in Sketchbook for mobile devices.

Scan a physical image and import it to Sketchbook as the foundation for a new canvas. Sketchbook will help you
scan your drawing by providing perspective correction and background clean-up to bring it into the digital world.

NOTE: If your image cannot fit within the view, it will be scaled down from the border edges.

How to scan a sketch

1. Tap  and select  Gallery.
2. In the Gallery, tap  and select  Add Scans to Gallery.
3. A message "Looking for sketch" will appear as Sketchbook attempts to detect your image or document. A blue

box appears around the detected area. If found it will auto-scan the sketch, including automatically adjusting
perspective and cleaning up the background

If the sketch is not automatically found, you can tap the shutter button  to capture the entire contents of
the camera preview.
you can disable automatic scanning by tapping  in the upper right corner of the screen. The icon will
change to .
tap  to use the camera's flash. 

Adjusting the scanned image

When the scan is loaded, do any of the following:
If you don’t like the capture, tap Rescan.
If you need to make some changes to the image, here is what you can do while still in scan mode:

to rotate the image 90 degrees counterclockwise, tap .
to show or hide the background, tap . The background is displayed by default, tapping the icon will
toggle the background off.

To make color adjustments, tap .
To convert the image to black and white and remove the background, tap B&W.
To keep the color of the images, but remove the background, tap Color.
To keep the original color and background of the image, tap Original.

When finished, tap Done to save the image and return to the Gallery.

Error messages

There are a few error messages you might encounter as you are scanning your images:
“Your device doesn’t support this feature” – your device doesn’t have a camera, so there is no way to scan an
image.
“Unable to launch the camera” or "Sketchbook is Restricted from Camera Access" - error messages that may
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vary depending on what version of the operating system your device has. These messages indicate you need
enable access to your camera for Sketchbook in the Settings app.
“Sketchbook must use the full screen to scan sketches” – your device is in a split view, Sketchbook must be in
full screen mode to scan images. 
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�
Animation in Sketchbook Pro

Flipbook is only available in Sketchbook Pro for Mac and Windows.

Sketchbook Pro on desktop for Mac and Windows has Flipbook functionality that incorporates traditional keyframe​
animation using a timeline​.

Flipbook

If you are a professional animator or someone who loves creating animated sequences, Flipbook provides a simple
user interface and workflow that anyone can learn while staying true to key animation techniques. 

Different uses for Flipbook

Have you ever used Sketchbook Pro to sketch a concept, then annotated it, adding other sketches to try to get an
idea across? Next time, create a flipbook. Imagine sending someone a sketch that comes to life to better illustrate
your concept. With Flipbook, you can create cell animation, a prototype, or proof of concept.

Flipbook is not a complete animation package and does not replace animation production software; it is a
‘sketchbook’ of sequential animation. It has all the familiar tools and simplicity of Sketchbook Pro, keeping it fun
and creative.

Use Flipbook to create quick animations that communicate motion and pacing of a sequence
Use the timeline as a storyboard, where each frame is an individual board or page. Flipbook lets you see them

https://sketchbook.knowledgeowl.com/docs/using-the-timeline
https://sketchbook.knowledgeowl.com/docs/creating-flipbooks
https://sketchbook.knowledgeowl.com/docs/using-flipbook-for-storyboarding
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all together in a sequence, and can also export them as individual images.
Use the timeline to create multiple iterations of a character or design and use the animation playback as a way
to visualize all the concepts at once. You can also import a single image or photograph as a background, and
do iterations of it as paint-overs on individual keyframes 

https://sketchbook.knowledgeowl.com/docs/using-flipbook-for-paint-overs
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What's new in Flipbook

Sketchbook Pro 9.3 introduced new updates to Flipbook that expanded the capabilities for keyframe animation.

For long-time users of Flipbook, this article summaries the key changes in Flipbook features and workflow. 

Flipbook Layers

Prior to this update, Flipbook had a constrained Layer Editor that only allowed three layers - Foreground, Midground,
and Background.

In Sketchbook Pro 9.3, Flipbook now uses the common Layer Editor, providing access to all layer features and
supporting up to 20 layers or groups per keyframe.

1. Title bar
Displays the current keyframe
Displays count of layers/groups

2. Layer header
Access to all layer and grouping features

3. Layer controls - reordering, opacity and features

The Midground concept is deprecated as you now have the ability to create more layers.

The Background has moved and is now accessed in the timeline, underneath the keyframes. 

https://sketchbook.knowledgeowl.com/docs/layer-editor-in-flipbook
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�

When the background is selected, the Layer Editor switches to edit your background layers. You can have up to 20
layers/groups as well as set the Background Color.

Working on Flipbook files created in older versions of Sketchbook Pro

When you import .skba created in a previous version of Sketchbook Pro, the Foreground and Midground layers will
be assigned to the Foreground layer stack and the Background will be assigned to the Background layer stack.

Important: new .skba files are not backward compatible with older versions of Sketchbook Pro.

Flipbook Frame Size

Flipbook supports a maximum frame size of 3840 pixels in width and 3508 pixels in height.

When creating a New Empty Flipbook, the Preset list now includes:
4K (3840x2160)
2K (2560x1440)
Letter aspect ratio (1700x2000)
A4 aspect ratio (1654x2339)

Larger canvas sizes and using multiple layers will increase memory usage and file sizes when saving.

Tinting Ghost Keyframes



361

You can now apply preset color tints to previous and next onion skinning.

Tap on the marking menu to toggle between 7 colors to visualize motion across keyframes.

https://sketchbook.knowledgeowl.com/docs/onion-skinning
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�
Using the timeline

Flipbook is only available in Sketchbook Pro for Mac and Windows.

The timeline is where you will find all your primary animation tools. This is where you create and manage your
keyframes, enable/disable onion skinning (ghosting) and preview your animation (scrubbing the timeline or
playback).

1. Commands for creating, duplicating and clearing frames and keyframes
2. Starting frame of the flipbook
3. Playback range - Start frame
4. Frame bar to select and scrub across frames
5. Current frame is highlighted in blue
6. Background - create/edit a common background used across all frames.
7. Playback range - End frame
8. Number of all frames in the flipbook
9. Auto Keyframe setting

10. Loop Setting
11. Ghosting controls for previous and next keyframes
12. Playback controls
13. Playback range scroll bar

Creating a new keyframe

Select the empty frame in the timeline you want to make into a keyframe.
Tap   Add Keyframe

This converts the empty frame to a keyframe.
The keyframe will have its own new layer stack.  

https://sketchbook.knowledgeowl.com/docs/onion-skinning
https://sketchbook.knowledgeowl.com/docs/onion-skinning
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1. Indication that you are working in “Foreground”, and the keyframe number
2. Count of layers/groups used/available
3. An initial blank layer 

Duplicating a keyframe

Duplicating an existing keyframe can be an effective starting point for a new keyframe. It inherits the same layers
and layer order for you to adjust and build on.

When you have a keyframe selected in the timeline, tapping   Duplicate Keyframe  will place the duplicate in the
next frame.

If you have an empty frame selected, Duplicate Keyframe will automatically duplicate the last keyframe into the
selected frame.

Moving keyframes

To move a keyframe, tap-hold and drag it to the new location. 

When you hover over the preview of a keyframe, a hand cursor  will appear

Once you tap-drag, the preview will appear as the cursor and as you drag, frames will highlight to give you feedback
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on which frame you are over. 

When you release the keyframe, it will instantly move to the new position in the timeline.

Pasting from the clipboard

When you have an image copied to your clipboard, you can paste into a layer stack - or you can use it make a new
keyframe.

Pasting to a keyframe or the background
Select the keyframe or background and open the Layer Editor
Activate the layer that you want the pasted image to be placed above
Paste from the menu bar Edit > Paste, or Windows Ctrl+v or Mac CMD+v

Pasting to make a new keyframe
Select the empty frame you want to make into a keyframe
Paste from the menu bar Edit > Paste, or Windows Ctrl+v or Mac CMD+v

The frame will be converted to a keyframe with one layer containing the image from the clipboard

Tips
Pasting from the clipboard is an effective way to quickly make repeats of existing keyframes when you do not
require the full layer stack duplicated in each instance.
Use Edit > Select and  Edit > Copy Merged to quickly capture all the visible content in a layer stack into a
flattened image.

Inserting an empty frame

Empty frames are not blank; they are extensions of the preceding keyframe. When you tap on an empty frame, it will
always show the content of the keyframe it is associated with.

Use empty frames to define the duration of your keyframes. 

When you tap  Insert Empty Frame it will add a new frame to the next frame position, shifting all the following
frames/keyframes to the right. 

https://sketchbook.knowledgeowl.com/docs/intro-to-layer-editor
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When you have an empty frame selected, the frame bar will highlight blue to show the keyframe associated to it. 

Clearing a keyframe

When a keyframe is selected, the  Clear Keyframe icon will show in this position in the timeline. 
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Tapping   Clear Keyframe will remove the keyframe, making it an empty frame.
This will not shift any frames or keyframes in the timeline.
Remember, this action deletes the entire layer stack that was associated with that keyframe. 

Deleting a frame

When an empty frame is selected, you can delete it.

Deleting a frame will remove it and shift all subsequent frames and keyframes to the left.

Auto keyframe

When the  icon is dark gray, Auto Keyframe is enabled. This setting enables quickly converting an empty frame to
a keyframe by tapping in the canvas.

Looping the animation

Tap the  icon to toggle on/off playback looping. This applies both for the Play button (for the selected range) and
Play All (to play every frame in the Flipbook).
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Playback controls

The Playback controls let you play back by jumping to the beginning (frame 1), step back one frame, step forward
one frame, or jump to the end of the animation.

1. Go to beginning - takes you to first frame
2. Go to previous frame
3. Playback range
4. Go to next frame
5. Play back all frames in Flipbook

Creating & editing the background

The background applies across all frames within the Flipbook. 

Toggling the eye icon  on the Background layer toggles background visibility.

Tapping on the background layer will open it in the Layer Editor. When active, the background layer will be outlined in
blue in the timeline. While in the background layer, other keyframe tools are disabled.

While working in the background layer, the Layer Editor panel will update to note Background Layers, there can be a
maximum of 20 groups/layers in the background. 

https://sketchbook.knowledgeowl.com/docs/intro-to-layer-editor


368

Setting a frame range

The frame range is the number of visible frames you can see in the timeline. In this image, you can see that the range
of what you see matches the Start/End fields as well as in the scroll bar.

Adjusting the range can be done in two ways:
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Click-drag the handles at the ends of the scroll bar.
Pulling the bar wider will show more frames
Pulling it closer together will show less frames
The maximum number of frames you can set is dependent on the available space in the timeline window
and the minimum width of each frame where you can still select and interact with them.

Alternatively, you can also enter specific values into the Start and End fields.
The same maximum number of frames also apply.

Scrubbing the frame bar

Another method of previewing motion is to tap in in the frame bar and drag left and right. This will dynamically
update the canvas view and the frame you release on will become the active frame.
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�
Creating Flipbooks

Flipbook is only available in Sketchbook Pro on Mac and Windows.

From the menu bar, click on File > New Flipbook. A menu will appear for you to select a New Empty Flipbook, or to
create one from an existing Image Sequence.

New Empty Flipbook

Create a new, blank animation sequence.

An Animation Size window will open where you can define the settings for the animation
Set the Frame Size

Select from a list of preset sizes, or manually enter the pixel dimensions  
The frame size cannot be changed after this is set.

Set the Frame Rate
Set the Frame Number

This is the number of blank frames that appear in the timeline.
It can also be adjusted later, but a Flipbook cannot exceed 1000 frames

New Flipbook from Image Sequence

This option will open a browser window to allow you to select a sequence of images as your starting point.
These images could be created from another application, such as Maya, 3DMax, or Blender.

Images must be PNG, JPG, BMP or PSD images.
They all must be the same resolution.
They must be named with sequential numbering.

The Flipbook will use the size of the images as the Frame size and automatically place them into keyframes as
a single layer.
PSD files with layers will be flattened to a single layer.
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Flipbook files

Flipbooks save as .skba files. You can export your files as movies files or sequences of images

Learn more about Saving and exporting Flipbooks here.

 

https://sketchbook.knowledgeowl.com/docs/saving-and-exporting-flipbooks
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�
Saving and exporting Flipbooks

Flipbook is only available in Sketchbook Pro for Mac and Windows.

When you save Flipbook files from Files > Save, Save As, or Save a Copy as , they are saved as a proprietary
Sketchbook Animation format (.skba) that stores all the animation settings, keyframes, background layers, and
timeline data. 

Flipbooks can also be exported as:
Sequential PNG
Sequential layered PSD

export only - Flipbook cannot import layered files or sequences.
MOV (macOS only)
WMV (Windows only)
MP4
Animated GIF

Exporting a single keyframe 

If you have a keyframe that you wish to save as an individual image, you can export it from the menu using File >
Export Current Frame…

In the Save dialog, TIFF will be the default format. Tap on File Format for the drop-down of options:
Flattened image formats

JPEG
PNG (to export transparent PNGs, turn off visibility of the background color)
BMP

Layered formats
Sketchbook Tiff

Exports the layer stack of the selected keyframe and the background layers and background color.
This is a useful format if you want to further develop the frame as a static canvas in Sketchbook
Pro.
Remember, you cannot re-import layered files back to Flipbook.

PSD
Exports the layer stack of the selected keyframe and the background layers, but subject to the
limitations of exporting PSD files

Adobe TIFF
Exports the layer stack of the selected keyframe and the background layers, but will not retain
background color.

Export sequential images

You can export a sequence of PNG or PSD files. This is a full export of every frame, including all the duplicates from
empty frames.

https://sketchbook.knowledgeowl.com/docs/import-from-photoshop
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From the menu bar, select File > Export Flipbook.
By default, Export As is set to PNG Sequence

If you want PSD, tap to select from the dropdown
Customize export options as needed

Background color - by default, this is OFF 
Export all frames or a custom range (minimum 2 frames)

Changing export size
By unchecking Match Document Size you can export at a different proportional size. 
The size cannot exceed the maximum canvas size for Flipbook (13 MPX).

Export location
Windows: after tapping Export, the browser will open.

Enter your file name. This creates a Folder with this name.
All images will have this name with a .### numbering suffix.
Tap Save

Mac: after tapping Export, Finder will open
Images will be automatically use the name of the folder you select.
Navigate to the desired folder or create a new folder
Select Open to export images.

Exporting Animated GIF
1. From the menu bar, select File > Export Flipbook.
2. Choose Animated GIF from the Export As options.
3. Customize options

you can uncheck Match Document Settings to reduce the image size or frame rate.
For a looping Animated GIF, you can choose the Loop Playback setting

Exporting Video
1. From the menu bar, select File > Export Flipbook.
2. Choose the video format from the Export As options.
3. Customize Range or Size and Frame Rate options

Background color and Loop Playback are not options for video formats.
4. Tap Export.
5. Enter File Name and Save.
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Layer Editor in Flipbook

Starting with Sketchbook Pro 9.3, Flipbook uses the same Layer Editor as the standard canvas, with all Layer Editor
features including blend modes, clipping masks, text layers and layer management tools.

When working on a Flipbook, the Layer Editor has two modes. The title bar will indicate if you are editing the layers in
a Foreground keyframe or if you are editing the Background.

Foreground

1. Can have a maximum of 20 layers/groups per keyframe
2. Does not have a background color

Background

1. There is only one background that is used for every frame of the scene
2. You can have a maximum of 20 layers/groups in the background.
3. The background color is also controlled here

To change the background color, tap the color swatch. This will allow you to set the color using the Color
Editor, Color Puck or Custom Color window.
When you have set your color, tap on the swatch again to deactivate background color selection

https://sketchbook.knowledgeowl.com/docs/intro-to-layer-editor
https://sketchbook.knowledgeowl.com/docs/blending-layers
https://sketchbook.knowledgeowl.com/docs/clipping-masks
https://sketchbook.knowledgeowl.com/docs/text
https://sketchbook.knowledgeowl.com/docs/intro-to-layer-menu
https://sketchbook.knowledgeowl.com/docs/color-editor
https://sketchbook.knowledgeowl.com/docs/color-puck
https://sketchbook.knowledgeowl.com/docs/color-palettes
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�
Onion Skinning (Ghosting)

Flipbook is only available in Sketchbook Pro for Mac and Windows.

‘Onion skinning’ is an animation technique used to view previous and following keyframes at the same time. It is
used to visualize the motion across multiple keyframes.

When working on a Flipbook in Sketchbook Pro, onion skinning is available via the Ghosting controls in the Flipbook
timeline​.

1. Toggle Ghosting of previous keyframes
2. Set number of previous keyframes to ghost
3. Set tint color for previous keyframes
4. Toggle Ghosting for next keyframes
5. Set number of next keyframes to ghost
6. Set tint color for next keyframes

Toggling Ghosting

By default, ghosting is off. To turn on ghosting, tap on  to view previous keyframes and/or  to view next
keyframes. These are independent toggles and allow you to set ghosting controls separately for previous and next
keyframes.

https://sketchbook.knowledgeowl.com/docs/using-the-timeline


378

Number of ghosts

By default, two keyframes will be ghosted. You can define between 1-10 ghosts.

Color tint

By default, the ghost keyframes will appear semi-transparent.
Tap-hold on the mini circular swatch to see the radial marking menu of preset colors. Gesture in the direction
of color you want to select.

Applying different tints to previous and next ghosts can be extremely helpful to make them easily identifiable. 
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�
Importing image sequences

Flipbook is only available in Sketchbook Pro for Mac and Windows.

Existing image sequences can used as a starting point for creating a new Flipbook or added as new frames into an
existing Flipbook. 

Starting a new Flipbook from an existing set of images

Tips before you get started:
Images should be within the maximum canvas size of 13 MPX

If the image sequence is larger, Sketchbook Pro will attempt to scale down and resample. 

The new Flipbook will be the same width and height as an imported sequence
Supported image formats

PNG, JPG or BMP
Layered PSD images will be flattened on import

The number of images cannot exceed the maximum frame count of 1000
Animation or sequential stills should be named with an ordered number suffix.

Images without a naming system will imported based on alpha numeric order.
Image sequences will always be loaded as the first layer of each keyframe.

Import a sequence as a new Flipbook:

From the menu bar, go to File > New Flipbook > New Flipbook From Image Sequence. 
Use File Explorer/Finder to navigate to the folder with the sequential images all images to import

SHIFT select multiple ordered images
CTRL/CMD to select unordered set of images

Tap Open to import sequence

Import a sequence into an existing Flipbook

If you have images you want to add to a Flipbook, use Add Images as Frames.
Ensure you are actively in your Flipbook file (.skba), on the frame you would like to import to.
Select File > Add Images as Frames.

In File Explorer/Finder, select the images you want to import.
On Windows, ensure Image Sequence option at the bottom of the browser is unchecked. This
option would create a new Flipbook file instead of importing to the open file.

Tap Open.
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Using Flipbook for storyboarding

Flipbook is designed for keyframe animation, but because it is so simple to use it can also be a great tool for
storyboarding.

If you need to create multiple pages based on a common panel layout, Flipbook may provide a more efficient
alternative vs. creating individual files for each page. 

Tips for setting up a storyboard template in Flipbook
When you set up the Flipbook, set the Frame Number to a small value. You will be able to add frames (pages)
as you go, so there is no need to start with too many.
If you have an existing image to use as a template, make sure you use the same pixel dimensions and aspect
ratio when setting up your Flipbook file.

If the image is larger than the maximum 13 MPX, you'll see a notification prompting you to scale it to fit
the Flipbook size. 
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You will use the timeline window in Flipbook window to create and manage your Background and Foreground.
Review the article Using the timeline to familiarize yourself with the controls. 

If importing an image that does not have transparency
You will not be able to see through this image to use the Background Color in the Layer Editor
You can still add layers on top of an opaque layer that you want part of the template

Once you’ve set up a background layer that meets your needs, save your Flipbook. This will give you a template
that you can use over and over again.

From the menu, File > Save. Save the file as a Sketchbook Animation file (.skba)
Select your folder from the File Explorer/Finder and give it a descriptive name you will remember.
When you open and use it for a new project, be sure to use File > Save As to not overwrite the original
template.

Check our sample storyboarding templates to get an idea of what you can create.

A4 aspect ratio (4 panel or 8 panel): 
Letter aspect ratio (3 panel or 6 panel): 

We imported graphics to produce the clean geometry and structured lines, but you can easily create background
from existing images, photographed documents, or hand-drawn layouts.

 

Will Flipbook meet your storyboard needs?
The canvas size is limited to a maximum of 13 MPX

This is the equivalent of a 4K pixel dimensions, A4 aspect ratio at 200 dpi, or Letter proportions at 200 dpi
Each page you create on top of the background template can have up to 20 layers or groups 
A single common background template can be used across multiple pages

The background can have up to 20 layers or groups
Your total page count can be 1000 pages or less per Flipbook file.
The export output of individual pages can be either PNG or layered PSD

Storyboard-A4-Portrait.skba �
Storyboard-Letter-Portrait.skba �

https://sketchbook.knowledgeowl.com/docs/using-the-timeline
https://sketchbook.knowledgeowl.com/docs/using-the-timeline
https://dyzz9obi78pm5.cloudfront.net/app/image/id/686ee6ab3c6115f3180fc7b1/n/storyboard-a4-portrait.skba
https://dyzz9obi78pm5.cloudfront.net/app/image/id/686ee6ba60fe4f74f0050636/n/storyboard-letter-portrait.skba


385

If Flipbook meets your criteria, check out this article to learn more details on creating Flipbooks.

Tips on using frames as pages
When using Flipbook for storyboarding, you do not need empty frames because their purpose is strictly for
timing animation.

You will only use keyframes in the timeline. Each keyframe is a new page.
Each new keyframe will have its own layer stack that can hold up to 20 layers or groups

Benefits of using Flipbook

Quickly look at other pages. You can see multiple pages in context without having to swap to different files.
Copy layers or selected elements from one page to reuse in another.

Tips on exporting your pages
Exporting your Flipbook out as individual pages is easy using File > Export Flipbook…

Export as a sequence in PNG or layered PSD
Read more in this article on Saving and Exporting Flipbooks

You can use the sequentially named PNG images to produce PDF documents.
Use Preview on Mac
Use Print to PDF on Windows
Use Adobe's free online PDF tool, or another app of your choice

 

 

https://sketchbook.knowledgeowl.com/docs/creating-flipbooks
https://sketchbook.knowledgeowl.com/docs/saving-and-exporting-flipbooks
https://www.adobe.com/acrobat/online/convert-pdf.html
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Using Flipbook for paint-over iterations

Flipbook is designed for keyframe animation, but because it is so simple to use, it is a powerful way to explore design
concepts through paint-overs.

Benefits of using Flipbook for paint-overs
Create many versions on top of a common background underlay in a single document.

Quickly view other iterations without opening another file.
Copy and paste layers and elements from one concept to another.
Duplicate concepts to make sub-variations and easily flip between them to compare.

Create options within the background underlay by using layers to hide/show elements that appear across all
paint-over pages.
Easily export out all concept pages as individual images.
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Will Flipbook meet your concept workflow?
The canvas size is limited to a maximum of 13 MPX

This is the equivalent of a 4K pixel dimensions, A4 aspect ratio at 200 dpi, or Letter proportions at 200 dpi
A single common underlay/reference that is used as a background across multiple paint-overs

The background can have up to 20 layers or groups
Each page of paint-over can have up to 20 layers or groups.
Your total page count is 1000 pages or less per Flipbook file.
Export output of individual pages can be PNG or layered PSD

If your assignment fits these criteria, Flipbook can be a powerful and creative tool for concept exploration; check out
this article to learn more details on creating Flipbooks.

 

https://sketchbook.knowledgeowl.com/docs/creating-flipbooks
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Preferences in Sketchbook

Jump to Mobile

Use Preferences to customize Sketchbook.

Preferences in Sketchbook Pro

On Mac, Preferences can be accessed from the menu bar Sketchbook Pro > Settings.

On Windows Preferences can be accessed from the menu bar Edit > Preferences.

The Preference window includes 6 tabs that group similar settings:
General
Brush
Canvas
Hotkeys
Lagoon
Factory Defaults

General

Add Image: import into a new layer
When importing an image from the Layer Editor or using copy/paste, the default setting will automatically
create a new layer to place the image. When this option is disabled, imported and pasted images will be
applied to the active layer.
With either setting, the Quick Transform widget allows positioning an image before it is finalized.

Pen Mode (Windows only)

https://app.knowledgeowl.com/#mobile
https://app.knowledgeowl.com/#general
https://app.knowledgeowl.com/#brush
https://app.knowledgeowl.com/#canvas
https://app.knowledgeowl.com/#hotkeys
https://app.knowledgeowl.com/#lagoon
https://app.knowledgeowl.com/#defaults
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This option is for devices that support touch input for drawing (as there are no touchscreen Macs, the option is
only available on Windows). By default this option is OFF
When Pen Mode is enabled, only the stylus input will draw on the canvas, but touch input will still interact with
the interface.
Pen Mode can also be enabled/disabled from the toolbar

Pixel Preview
By default, Sketchbook Pro uses anti-aliasing to smooth the rendering of pixels that can produce jagged edges
on curved or diagonal strokes.
When active, this option will show all the pixel detail on canvas and when exported as an image.

Undos
Set the maximum number of undos/redos that can be performed.

Language (Windows)
On Windows, the language setting can be changed in Preferences. 
On Mac, language options are available in the Language & Region settings of the Mac System Preferences. In
the App option, Sketchbook Pro will appear with a pull-down option to change the language
Sketchbook Pro requires a restart for language changes to take effect.

Graphic Options
Enable Rotate Canvas. Enabled by default, this setting allows for the canvas to be rotated using the Puck,
hotkeys or with touch-enabled input devices. Rotate Canvas functionality requires OpenGL 2.0 support, so the
feature will not be available when Sketchbook Pro is run on devices that do not meet this requirement.
Optimize buffers (Windows). This option provides the best brush performance and is on by default. There are,
however, some devices where it may be required to disable this setting. For example, some devices with multi-
monitor configurations may fail to run Sketchbook Pro on extended displays. See Freezing on a secondary
monitor for more information

Default Save Format
TIF is the default file format for saving. TIF is the native format of Sketchbook.
You can switch this to save files in PSD format by default. This is particularly useful when you are working with
a pipeline where final layered art moves into Photoshop. Note that there are some features that will not be
preserved when Sketchbook files are saved as PSD

File options
Create backup files. When enabled, a copy of the previous file will be stored with a .BAK extension. This
provides added protection for instances where accidentally overwriting a file instead of saving a copy. To
restore a .BAK file, you must manually rename the file to remove the .BAK extension before it can be opened in
Sketchbook.
Incremental file name. By default, Sketchbook Pro will use your last saved file name and add incremental
numbering as a suffix (i.e. Untited2.tif). Naming files this way supports the Next Image and Previous Image
hotkeys that open the next or pervious file name from disk. When this is disabled, the save dialog will use
‘Untitled’ as the default in the name field.
Verify TIF files after saving. When enabled, this runs a secondary check on the saved TIF file. This provides
added reassurance that a file has been saved without error. If an issue is detected, a notification be presented.

Note: This feature is only available for single TIF file saves.

https://sketchbook.knowledgeowl.com/docs/toolbars
https://sketchbook.knowledgeowl.com/docs/freeze-on-launch
https://sketchbook.knowledgeowl.com/docs/import-from-photoshop
https://sketchbook.knowledgeowl.com/docs/hotkey-shortcuts
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Recovery File Auto Save
By default, Sketchbook Pro attempts to save a recovery file after 20 seconds of idle time if changes have been
made to the canvas.
Recovery files are only accessed in the case of crashes or unexpected exits of the application, and attempt to
minimize the amount of lost data.
Disabling Auto Save may help if you are experiencing performance issues

Page Up (Windows only)
This setting defines the mapping of the Page Up/Down keys for activating the Next Image and Previous Image
feature for opening files.
This feature can be used as a quick presentation tool or as a simple storyboarding tool to move back and forth
between sequential images (ideal when the incremental file names option is enabled).

Brush

As of Sketchbook Pro version 9.0, Brush cross-hair, outline and stamp options are available in the View menu.

Brush Puck
By default, pen-drag up and down across the puck changes the brush opacity/flow and dragging left and right
will increase/decrease the brush size. This can be simplified to to only allow changing brush size (disabling
changes to opacity/flow) by checking the option for ‘change brush size only’

Color Puck
By default, the color puck will use up/down and left/right drags to adjust luminance and saturation,
respectively. If you uncheck one of the options, the puck will use both directional drags to change the
remaining value.

Brush Palette
The Brush Palette defaults to 2 columns of brushes that scroll vertically. Check this option to enable a single
column palette to streamline the the brush palette footprint.

Tablet API (Windows only)
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If you are encountering issues such as cursor offset or pressure problems with Sketchbook Pro on your
peripheral tablet, you can try changing the API used. Please reach out to Sketchbook Support at
support@sketchbook.com if issues persist so we can help.

Canvas

Use width and height of window. On by default, if you disable the checkbox you can then customize the width,
height and resolution of a new canvas. 
Note: Sketchbook Pro has a 100MPX canvas size maximum. When inputing new values, the fields in canvas
Preferences and image size will observe these restrictions.

These settings only apply to creating new files. Opening an existing image will always use the size and resolution of
the respective file.

Hotkeys
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This tab contains the features and tools that support customization of hotkey combinations.

Hotkeys can be reset to factory default settings individually.

Lagoon

The Lagoon is the user interface that allow you to tap on the icons to trigger radial menus (called marking menus).
Tapping and holding reveals the 8 tools stored in each menu, but you can also activate each tool with a gestural flick
without having the icons appear first.

Customizing each of marking menus with your favorite brushes, tools and file options is the best way to take
advantage of the Lagoon.

https://sketchbook.knowledgeowl.com/docs/basic-ui-elements#lagoon
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Select the group you want to edit by tapping on the lagoon presented inside the Preference window.
Once selected, the 8 assigned tools will appear below.
To change a tool, you can select from the list of customizable tools. You can scale the Preference window
vertically to make viewing and scrolling easier.
You can also change the icon in the lagoon to any of the preset icons available on the top right of the section.

Factory Defaults

You can reset specific Preferences or all of the app Preferences back to factory settings from this tab.

Reset Brush Palette and Library
All brushes are restored back to original settings
Brush Palette will reset to the default Basic brush set.
Brush Library is reset to the original brush sets. All custom created brush sets, re-ordering, or imported brushes
will be cleard.

Reset Custom Color palettes
Restores the original factory defaults for all Color Sets and their respective palettes in the Custom Color Editor.
All custom and imported color sets will be cleared from the Color Set library.

Reset Custom Color images
Restores the original 3 sample images to the Image tab in Custom Color Editor.
All imported images will be cleared.

Reset all
This does a reset to all Preferences, removing all customizations and restoring factory default settings as if
you'd just installed the app.

Backup



394

This option was introduced with version 9.0 for Windows and macOS. Backups are not backward compatible to
older versions. Backups are not cross-platform compatible with Sketchbook on iOS and Android.

Select Create to make a Preference backup. This will open a prompt to select a save location for a ZIP file.
There is no need to uncompress this file as the contents are not individually usable. Just keep it in a safe
location
To import a Preference backup, select Restore and select the backup file. Sketchbook Pro will need to be
restarted to initialize the loaded Preferences.
Tip: back up your Preferences before performing a factory reset or uninstalling Sketchbook Pro.

Preferences in Sketchbook for mobile devices

Preference settings customize the app to how you prefer to work. To access your Preferences, tap  and select 
 Preferences. There are multiple sections under Preferences:

1. User Interface
2. Canvas
3. Gestures
4. Pen Connection
5. Factory Defaults
6. Sketchbook Data

To return to the canvas, at the top left of your screen tap Done.

User Interface

Status bar - toggle on or off the device status bar that shows time, battery, etc. Off by default
Show Tooltips – display or hide tool tips as you sketch. On by default
Marking menus - customize the tools that appear in the marking menu, or toggle off to have the marking menu
disabled
Show Brush Panel - enable or disable the Brush Panel. On by default
Small Double Puck - toggle on a smaller version of the Double Puck. Off by default

Canvas

Rotate Canvas – Use to rotate the entire canvas with two fingers. On by default.
Pixel Preview – when enabled, this disables anti-aliasing so that you can see individual pixel details at high
levels of zoom. Off by default.
Lock Canvas Orientation (tablets only) - when enabled, both the canvas and UI rotate when you rotate your
device. When disabled, the UI rotates but the canvas stays in position. Off by default.
High Precision Strokes (Android only) - enables more points in a stroke, allowing for higher precision. May
impact performance on lower-end devices. Off by default

Gestures

Tap-hold for Color Picker – an optional way to launch the color-picker with a long press. Off by default.
Pinch to Gallery (Android only) - quickly save a sketch and enter the Gallery. In the canvas, with two fingers,

https://app.knowledgeowl.com/#ui
https://app.knowledgeowl.com/#canvas-mobile
https://app.knowledgeowl.com/#gestures
https://app.knowledgeowl.com/#pen
https://app.knowledgeowl.com/#defaults-mobile
https://app.knowledgeowl.com/#data
https://sketchbook.knowledgeowl.com/docs/basic-ui-elements#marking-menu
https://sketchbook.knowledgeowl.com/docs/brush-palette
https://sketchbook.knowledgeowl.com/docs/color-puck#double-puck
https://sketchbook.knowledgeowl.com/docs/using-the-color-picker#mobile


395

pinch the screen. As your fingers come together, a message appears and the screen changes to black. Lift or
release the image to enter the Gallery. Off by default
Two-handed Fullscreen mode (Android only) - when using Rapid UI mode, this setting causes the menus and
windows to only stay open while the trigger is held down. When the setting is off, windows stay open until
making a mark on the canvas or tapping the trigger again. Off by default
Corner shortcuts – assign frequently used tools to the four corners of the canvas for quick access. On by
default, assigned to (clockwise from upper left) Clear Layer, Frame Canvas, Redo, Undo.
2-finger single-tap - assign frequently used tools to the gesture.
2-finger double-tap – assign frequently used tools to the gesture.
3-finger single-tap – assign frequently used tools to the gesture.
3-finger double-tap – assign frequently used tools to the gesture.
3-finger swipe – assign frequently used tools to the gesture.

Pen Connection

Only available for the iOS version. Android Pen settings are in the main menu.

Sketchbook will automatically work with Apple Pencil without needing to be paired. In the Pen Connection section,
you can set additional options after you select Apple Pencil.

Tap-hold to activate color picker
Pen Mode. When toggled on, Pen Mode will only recognize Apple Pencil for drawing on the canvas. Touch
inputs will be ignored for drawing.
Enable Multi-touch Gestures enables touch on the canvas for gestures only. Disabling this will prevent multi-
touch input, including 2- and 3-finger interactions.
Brush Stamp - see a stamp preview of your brush when hovering with Apple Pencil. Requires Apple Pencil (2nd
Gen) or Apple Pencil Pro and supporting iPad device.

Sketchbook no longer actively supports 3rd party styluses. The interface to pair these older input devices is still
available in the Pen Connection options, however, we are no longer able to verify their operation.

Factory Defaults

Use the Factory Defaults to reset Preferences to their original state. 
Brush Settings - resets all brushes in the Brush Library. Any imported or custom-made brushes will be deleted.
Color Sets - resets color palettes, and the Color Editor, including color history and custom gradients. All custom
and imported palettes will be deleted.
Image Sets - resets reference images. All imported images will be deleted.
Canvas Presets - resets custom new canvas presets
All Preference Settings - resets all Preferences at once
In-app Purchase - restores an in-app purchase from your account

Sketchbook Data

Verify Sketches on Save - runs a quick verification to ensure a file has completely saved. On by default.
Automatically Save to Gallery (Android only) - when enabled, Sketchbook will save your open canvas on the
interval you select: every 15 minutes, every 30 minutes, or every 60 minutes. Set to None to disable.
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Recovery tool - scans for files that have become displaced from the Gallery, and reconnects them with the app
Export Preferences - create a backup of your Preferences
Import Preferences - restore a backup of your Preferences
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Backing up Preferences

Backing up your Preferences backs up your custom brushes, colors, and settings so that they can be restored if
needed. This can be helpful when setting up Sketchbook on a new device, or in cases when you experience a device
loss or a corrupted Preferences file that cannot be recovered.

Backing up Preferences in Sketchbook Pro on desktop
1. On Mac, Preferences can be accessed from the menu bar Sketchbook Pro > Preferences. 

On Windows, Preferences can be accessed from the menu bar Edit > Preferences.
2. Navigate to the last tab: Factory Defaults
3. Choose Create a Preferences backup

Backing up Preferences in Sketchbook on mobile devices
1. Tap  Menu and select  Preferences
2. Scroll down to the bottom of the screen to the Sketchbook Data section
3. at Export Preferences, tap Create
4. the File browser will open, navigate to where you want to save your backup, and tap Save

Warning. A Preferences backup from Sketchbook on mobile will not restore to Sketchbook Pro, nor will
Sketchbook Pro Preferences load into Sketchbook on mobile.
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Resetting Preferences

Jump to Mobile

Resetting Preferences will restore your Preferences to the defaults, and any customizations you have made will be
removed. 

Resetting Preferences in Sketchbook Pro for desktop

Resetting hotkeys

You can reset some or all hotkeys to their default setting in the Hotkeys tab of Preferences.
To reset the hotkey for a specific command, select the command, tap Reset, then OK.
To reset all hotkeys to their default settings, in the lower left corner of the window tap Reset All, then OK. 

Resetting the Lagoon

You can reset the Lagoon to the factory default tools and marking menus.
In the lower left corner of the window tap Reset All, then OK. 

https://app.knowledgeowl.com/#mobile-prefs
https://sketchbook.knowledgeowl.com/docs/preferences-in-sketchbook#hotkeys
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Resetting palettes and Preferences

To reset your Color Palette, Brush Palette, or Preference settings, select the Factory Defaults tab.
Reset Brush Palette and Library - resets all brushes to their original state. All imported and DIY/custom
brushes are removed.
Reset Custom Color Palettes - resets the color palettes in Custom Colors to the factory default colors. All
custom swatches, palettes and sets are removed.
Reset Custom Color Images - resets the Images in Custom Colors to the factory default samples. All imported
images are removed.
Reset All - resets all Preferences to the factory default settings.

Resetting Preferences in Sketchbook for mobile devices

https://sketchbook.knowledgeowl.com/docs/color-palettes#color-library
https://sketchbook.knowledgeowl.com/docs/color-palettes#image-sets
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To access Preferences, tap  and select  Preferences.

Scroll down to the Factory Defaults section
Brush Settings - resets all brushes in the Brush Library. Any imported or custom-made brushes will be deleted.
Color Sets - resets color palettes, and the Color Editor, including color history and custom gradients. All custom
and imported palettes will be deleted.
Image Sets - resets reference images. All imported images will be deleted.
Canvas Presets - resets custom new canvas presets
All Preference Settings - resets all Preferences at once

Locating Preferences files

If you need to find your Preferences files for troubleshooting, the information below should help you find it on your
device.

Preferences file on Mac

1. Open Finder. Hold the Option key when you click on Menu > Go to make hidden folders viewable. Select Library.
2. Preferences should be stored in the following location:

Library/Containers/Sketchbook Pro/Data/Library/Application Support/Sketchbook, Inc/Sketchbook Pro/9.0/

Preferences file on Windows

This is the location of Preferences for Sketchbook Pro 9.0 and above. If you are using an older version, your
Preference file may be in a different folder.

1. First enable viewing Hidden Files in Explorer:
2. Preferences should be stored in the following location:

c:\Users[user_name]\AppData\Roaming\Sketchbook, Inc\Sketchbook Pro\9.0

Preferences file on Android and iOS

On mobile devices, Preferences are stored within the app's container. It is not possible to navigate to your
Preferences files from outside the app.

https://sketchbook.knowledgeowl.com/docs/color-palettes#color-library
https://sketchbook.knowledgeowl.com/docs/color-palettes#image-sets
https://sketchbook.knowledgeowl.com/docs/creating-a-canvas#mobile
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